Erro: A dependência não é contentável: libunarr [RESOLVIDO]

1. Erro: A dependência não é contentável: libunarr [RESOLVIDO]

Clodoaldo Braga
MinoCosmik

(usa Linux Mint)

Enviado em 04/05/2019 - 22:24h

Estou tentando instalar o pacote .deb do programa YACReader para ler HQ's no formato .CBR .
No site tem duas opções: Pacotes para Debian Testing e Pacotes para Debian 9.0
Eu escolhi a Debian 9.0 . nome do arquivo: yacreader_9.5.0-1_amd64.deb

Ao clicar duas vezes no pacote mostra essa mensagem: http://i.imgur.com/v4WkIKh.png



  


2. MELHOR RESPOSTA

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 05/05/2019 - 12:35h

A dependência não esta presente no repositório do seu sistema.
Você pode obter a dependência (libunarr) a que:
https://packages.ubuntu.com/disco/libunarr1
Instale a dependência a cima.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.

3. Re: Erro: A dependência não é contentável: libunarr [RESOLVIDO]

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 04/05/2019 - 23:43h


MinoCosmik escreveu:

Estou tentando instalar o pacote .deb do programa YACReader para ler HQ's no formato .CBR .
No site tem duas opções: Pacotes para Debian Testing e Pacotes para Debian 9.0
Eu escolhi a Debian 9.0 . nome do arquivo: yacreader_9.5.0-1_amd64.deb

Ao clicar duas vezes no pacote mostra essa mensagem: http://i.imgur.com/v4WkIKh.png

Boa noite.
A mensagem indica que falta o pacote "libunarr"
instale com o apt:
sudo apt update
sudo apt install libunarr
depois instale o YACReader
sudo dpkg -i nomedopacote.deb #(YACReader)


Importante => echo -e "$(lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p')"
Att.: Marcelo Oliver


4. Re: Erro: A dependência não é contentável: libunarr

Clodoaldo Braga
MinoCosmik

(usa Linux Mint)

Enviado em 04/05/2019 - 23:57h

Não deu certo o comando > sudo apt install libunarr > http://i.imgur.com/KBqZHUF.png

msoliver escreveu:

Importante => echo -e "$(lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p')"
Att.: Marcelo Oliver

Não entendi , oq devo fazer com isso?


5. Re: Erro: A dependência não é contentável: libunarr [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 05/05/2019 - 13:25h


pode pegá-la aqui também. Tem pra Debian

https://software.opensuse.org/package/libunarr-dev


6. Re: Erro: A dependência não é contentável: libunarr

edps
edps

(usa Slackware)

Enviado em 05/05/2019 - 18:26h

sudo apt update
$ sudo apt install libunarr1 libunarr-dev

* se estiver usando o Debian Testing.

https://packages.debian.org/buster/libunarr1
https://packages.debian.org/buster/libunarr-dev


7. Re: Erro: A dependência não é contentável: libunarr [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 05/05/2019 - 18:38h


Já se usa Debian Stretch (ou o pacote destinado a essa release), o pacote libunnar1 e libuunar-dev só estão presentes do Debian Buster parar cima, mas nada que não possa ser resolvido, segue a solução:

Atualização do sistema e pacotes -dev necessários:

$ sudo apt-get update
$ sudo apt-get install build-essential packaging-dev devscripts equivs



Baixando os sources, compilando, empacotando e instalando:

* Se for distro derivada do Ubuntu use o seguinte endereço:
http://archive.ubuntu.com/ubuntu/pool/universe/u/unarr/unarr_1.0.1-1.dsc

$ dget -x -u http://deb.debian.org/debian/pool/main/u/unarr/unarr_1.0.1-1.dsc
$ cd unarr-1.0.1/
$ mk-build-deps -s sudo -i
$ sudo apt-get -f install
$ dpkg-buildpackage -us -uc -b -tc
$ sudo dpkg -i ../libunarr1_1.0.1-1_amd64.deb
$ sudo dpkg -i ../libunarr-dev_1.0.1-1_amd64.deb
$ sudo apt-get -f install


Removendo o meta-pacotes de dependências:

$ sudo apt-get --purge remove unarr-build-deps -y 


Logo completo, já que hoje estou muito bonzinho:

https://pastebin.com/6sszkgfd




8. Re: Erro: A dependência não é contentável: libunarr [RESOLVIDO]

Clodoaldo Braga
MinoCosmik

(usa Linux Mint)

Enviado em 05/05/2019 - 20:03h

Desculpem a ignorância mas eu não sei qual versão do meu debian, rodei o comando cat /etc/*-release e o lsb_release -a no terminal e apareceu mais ou menos isso:
Description: DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19.1
DISTRIB_CODENAME=tessa
DISTRIB_DESCRIPTION="Linux Mint 19.1 Tessa"
ID=linuxmint
ID_LIKE=ubuntu
VERSION_CODENAME=tessa
UBUNTU_CODENAME=bionic


Não sei ao certo oq fazer com os links que vcs mandaram, então tentei executar o comando: sudo apt-get update e sudo apt-get install build-essential packaging-dev devscripts equivs e deu o seguinte erro:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
build-essential : Depende: libc6-dev mas não será instalado ou
libc-dev
Depende: g++ (>= 4:7.2) mas não será instalado
devscripts : Depende: libfile-homedir-perl mas não será instalado
equivs : Depende: debhelper mas não será instalado
packaging-dev : Depende: debhelper mas não será instalado
Depende: dput ou
dput-ng mas não será instalado ou
dupload mas não será instalado
Depende: pbuilder mas não será instalado ou
cowbuilder mas não será instalado ou
sbuild mas não será instalado
Depende: quilt mas não será instalado
yacreader : Depende: libpoppler-qt5-1 (>= 0.24.5) mas não será instalado
Depende: libqt5multimedia5 (>= 5.6.0~beta) mas não será instalado
Depende: libqt5opengl5 (>= 5.0.2) mas não será instalado
Depende: libqt5qml5 (>= 5.0.2) mas não será instalado
Depende: libqt5quick5 (>= 5.0.2) mas não será instalado
Depende: libqt5script5 (>= 5.6.0~beta) mas não será instalado
Depende: libqt5sql5 (>= 5.0.2) mas não será instalado
Depende: libunarr mas não é instalável
Depende: qml-module-qtquick-controls mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).





9. Re: Erro: A dependência não é contentável: libunarr

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 05/05/2019 - 21:42h

A não fica enchendo o tópico de linguiça ta vendo quebro o apt do usuário vem escrever que o sistema do usuário é Debian sendo que é linux mint quanta irresponsabilidade.

Agora siga a lista de comandos:
$ sudo dpkg -r build-essential packaging-dev devscripts equivs
$ sudo dpkg --configure -a ; sudo apt-get install -f
Isso deve corrigir o APT.
Instale o gdebi
$ sudo apt-get install gdebi
Baixe esse arquivo .deb com o comando wget ou com o navegador colocando na sua pasta home.
https://packages.ubuntu.com/disco/amd64/libunarr1/download
Instale com o comando:
$ sudo gdebi ~/libunarr1_1.0.1-1_amd64.deb
Instale novamente o YACReader.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


10. Re: Erro: A dependência não é contentável: libunarr

Clodoaldo Braga
MinoCosmik

(usa Linux Mint)

Enviado em 05/05/2019 - 21:58h

aguamole escreveu:

A não fica enchendo o tópico de linguiça ta vendo quebro o apt do usuário vem escrever que o sistema do usuário é Debian sendo que é linux mint quanta irresponsabilidade.

Agora siga a lista de comandos:
$ sudo dpkg -r build-essential packaging-dev devscripts equivs
$ sudo dpkg --configure -a ; sudo apt-get install -f
Isso deve corrigir o APT.
Instale o gdebi
$ sudo apt-get install gdebi
Baixe esse arquivo .deb com o comando wget ou com o navegador colocando na sua pasta home.
$ wget https://packages.ubuntu.com/disco/amd64/libunarr1/download
Instale com o comando:
$ sudo gdebi ~/libunarr1_1.0.1-1_amd64.deb
Instale novamente o YACReader.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


Oi amigo, eu não entendo muito bem disso. O meu sistema é Linux Mint mas eu instalo pacotes .deb nele normalmente.
No site do software eu escolhi fazer o download do pacote .deb ai mostrou essas opções: testing ou 9.0. Não achei que isso iria confundir algo .
Eu segui o procedimento q vc pediu mas mesmo assim ainda não consegui instalar o pacote .deb que eu baixei, ainda apresenta o mesmo erro.

tars@tars-desktop:~/Downloads$ sudo gdebi libunarr1_1.0.1-1_amd64.deb
[sudo] senha para tars:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done

Decompression library for RAR, TAR, ZIP and 7z archives (runtime)
unarr originated as a port of the RAR extraction features from
The Unarchiver project required for extracting images from comic
book archives (.cbr). It was written as an alternative to
libarchive which didn't have support for parsing filters or solid
compression at the time.
.
This package holds the runtime library.
Você quer instalar o pacote? [s/N]s
A seleccionar pacote anteriormente não seleccionado libunarr1:amd64.
(Lendo banco de dados ... 326841 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar libunarr1_1.0.1-1_amd64.deb ...
A descompactar libunarr1:amd64 (1.0.1-1) ...
Configurando libunarr1:amd64 (1.0.1-1) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...

tars@tars-desktop:~/Downloads$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tessa InRelease
Atingido:2 http://archive.canonical.com/ubuntu bionic InRelease
Atingido:3 https://deb.opera.com/opera-stable stable InRelease
Atingido:4 http://packages.linuxmint.com tessa Release
Atingido:5 http://archive.ubuntu.com/ubuntu bionic InRelease
Obter:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Atingido:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Obter:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Baixados 163 kB em 2s (79,0 kB/s)
Lendo listas de pacotes... Pronto

tars@tars-desktop:~/Downloads$ sudo gdebi yacreader_9.5.0-1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
Este pacote não pode ser desinstalado
Dependency is not satisfiable: libunarr






11. Re: Erro: A dependência não é contentável: libunarr

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 05/05/2019 - 22:12h

https://packages.ubuntu.com/disco/amd64/libunarr-dev/download
instala esse tmb e tenta de novo.
No arquivo de configuração do .deb não diz qual libunarr precisa estar instalado.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


12. Re: Erro: A dependência não é contentável: libunarr

Clodoaldo Braga
MinoCosmik

(usa Linux Mint)

Enviado em 05/05/2019 - 22:15h

aguamole escreveu:

https://packages.ubuntu.com/disco/amd64/libunarr-dev/download
instala esse tmb e tenta de novo.
No arquivo de configuração do .deb não diz qual libunarr precisa estar instalado.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


Ixe , deu a mesma mensagem.

tars@tars-desktop:~/Downloads$ sudo gdebi libunarr-dev_1.0.1-1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done

Decompression library for RAR, TAR, ZIP and 7z archives (devel)
unarr originated as a port of the RAR extraction features from
The Unarchiver project required for extracting images from comic
book archives (.cbr). It was written as an alternative to
libarchive which didn't have support for parsing filters or solid
compression at the time.
.
This package contains development tools: headers and unversioned libraries.
Você quer instalar o pacote? [s/N]s
A seleccionar pacote anteriormente não seleccionado libunarr-dev:amd64.
(Lendo banco de dados ... 326846 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar libunarr-dev_1.0.1-1_amd64.deb ...
A descompactar libunarr-dev:amd64 (1.0.1-1) ...
Configurando libunarr-dev:amd64 (1.0.1-1) ...

tars@tars-desktop:~/Downloads$ sudo apt-get update
Atingido:1 http://archive.canonical.com/ubuntu bionic InRelease
Ign:2 http://packages.linuxmint.com tessa InRelease
Atingido:3 https://deb.opera.com/opera-stable stable InRelease
Atingido:4 http://archive.ubuntu.com/ubuntu bionic InRelease
Obter:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Atingido:6 http://packages.linuxmint.com tessa Release
Atingido:7 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Obter:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Baixados 163 kB em 2s (96,1 kB/s)
Lendo listas de pacotes... Pronto

tars@tars-desktop:~/Downloads$ sudo gdebi yacreader_9.5.0-1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
Este pacote não pode ser desinstalado
Dependency is not satisfiable: libunarr


OBS: Pesquisei no site do YACReader que tem como baixar o Libunarr lá . Qual desses eu escolho: http://i.imgur.com/QbLB07Z.png ?




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts