Apt-get update não funciona no Debian XFCE 10.5.0 [RESOLVIDO]

1. Apt-get update não funciona no Debian XFCE 10.5.0 [RESOLVIDO]

Isaac
isaacan

(usa Debian)

Enviado em 26/08/2020 - 14:24h

Olá para todos! Sou um iniciante do linux e acabei de instalar o Debian XFCE 10.5.0 em dual boot com windows 7! A instalação foi um sucesso, porém estou enfrentando um problema com o comando apt-get update no terminal. Quando eu o executo, resulta no seguinte erro:


# apt-get update
Ign:1 cdrom://[Debian GNU/Linux 10.5.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200801-11:35] buster InRelease
Err:2 cdrom://[Debian GNU/Linux 10.5.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200801-11:35] buster Release
Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs
Lendo listas de pacotes... Pronto
E: The repository 'cdrom://[Debian GNU/Linux 10.5.0 _Buster_ - Official amd64 xfce-CD Binary-1 20200801-11:35] buster Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


Eu realmente não sei o que fazer quanto a isso!

E também, por favor, explique passo a passo pois eu não entendo quase nada de Linux. Desde já agradeço!


  


2. MELHOR RESPOSTA

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 26/08/2020 - 15:21h

Ola,

como voce esta usando Debian Xfce, proceda da seguinte maneira:

no terminal digite o comando sudo mousepad /etc/apt/sources.list

apague todo o conteúdo desse arquivo (sources.list) e copie/cole esse conteúdo:

deb http://deb.debian.org/debian buster main contrib non-free
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb http://deb.debian.org/debian buster-updates main contrib non-free

Depois salve (pelo menu do mousepad: File > Save) as alterações.

No final, digite no terminal os comandos sudo apt update, e depois, sudo apt upgrade

O mousepad é um editor de texto que vem com o Debian Xfce, como o notepad do Windows... Qualquer problema, avise!

Para voce entender, o link sobre o conteúdo que voce copiou/colou:

https://wiki.debian.org/SourcesList



3. Re: Apt-get update não funciona no Debian XFCE 10.5.0 [RESOLVIDO]

Isaac
isaacan

(usa Debian)

Enviado em 26/08/2020 - 15:42h

StanislausK escreveu:

Ola,

como voce esta usando Debian Xfce, proceda da seguinte maneira:

no terminal digite o comando sudo mousepad /etc/apt/sources.list

apague todo o conteúdo desse arquivo (sources.list) e copie/cole esse conteúdo:

deb http://deb.debian.org/debian buster main contrib non-free
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb http://deb.debian.org/debian buster-updates main contrib non-free

Depois salve (pelo menu do mousepad: File > Save) as alterações.

No final, digite no terminal os comandos sudo apt update, e depois, sudo apt upgrade

O mousepad é um editor de texto que vem com o Debian Xfce, como o notepad do Windows... Qualquer problema, avise!

Para voce entender, o link sobre o conteúdo que voce copiou/colou:

https://wiki.debian.org/SourcesList



Realmente funcionou! Muito obrigado, você me ajudou muito! vlw <3






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts