Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

1. Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

Hudeyson
hudeyson

(usa Kali)

Enviado em 12/06/2015 - 21:30h

[email protected]:/home# apt-get install conky-all
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
conky-all : Depends: libaudclient2 (>= 2.3) but it is not going to be installed
Depends: libxmmsclient6 (>= 0.7DrNo) but it is not going to be installed
Depends: libxnvctrl0 but it is not going to be installed
conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is to be installed
Depends: realpath but it is not going to be installed
Depends: conky but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[email protected]:/home# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is installed
Depends: realpath but it is not installed
Depends: conky but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
[email protected]:/home#

apos o acontecimeto acima nao consigo usar o

apt-get upgrade
apt-get dist-upgrade
apt-get -u dist-upgrade

e com isso nao consigo usar o terminal para instalar mais nada.



  


2. MELHOR RESPOSTA

Thiago Henrique Hüpner
Thihup

(usa Manjaro Linux)

Enviado em 13/06/2015 - 10:28h

Tente instalar o VirtualBox, e tente instalar o Conky por lá.

Ou você está com o Sistema desatualizado ou instalou/desinstalou e quebrou o sistema.
Falando nisso, digite cat /etc/apt/sources.list e poste aqui.

Espero ter ajudado

[]'s

T+

--
http://piadasnerds.com/wp-content/uploads/2011/08/grafico_souProgramador.png

3. Re: Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

Eric
Grinder

(usa Slackware)

Enviado em 13/06/2015 - 09:34h


O próprio terminal está te dando tudo que está faltando.
Falta algumas dependências e atualizações de algumas dependências.

Tenta o comando que ele mesmo sugeriu

apt-get -f install 



4. Resposta

Hudeyson
hudeyson

(usa Kali)

Enviado em 13/06/2015 - 09:39h


Meu querido sim jatentei o apt-get -f install no codigo acima tb consta ele e o erro junto


5. Re: Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

Thiago Henrique Hüpner
Thihup

(usa Manjaro Linux)

Enviado em 13/06/2015 - 10:05h

Amigo, tente isto:


sudo apt-get install -f libglib2.0-0


Espero ter ajudado

[]'s

T+

--
http://piadasnerds.com/wp-content/uploads/2011/08/grafico_souProgramador.png


6. Re: Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 13/06/2015 - 10:08h

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
sudo apt-get update
sudo apt-get upgrade



7. Tentando instalar o conky meu apt-get esta dando erro

Hudeyson
hudeyson

(usa Kali)

Enviado em 13/06/2015 - 10:19h

Galera executei o seguintes comandos
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
e esta assim

[email protected]:/home/hudeyson# sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of conky-manager:
conky-manager depends on libglib2.0-0 (>= 2.35.9); however:
Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.
conky-manager depends on realpath; however:
Package realpath is not installed.
conky-manager depends on conky; however:
Package conky is not installed.

dpkg: error processing conky-manager (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
conky-manager
[email protected]:/home/hudeyson# sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is installed
Depends: realpath but it is not installed
Depends: conky but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
[email protected]:/home/hudeyson# sudo apt-get -f remove
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is installed
Depends: realpath but it is not installed
Depends: conky but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies



8. Re: Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

Hudeyson
hudeyson

(usa Kali)

Enviado em 13/06/2015 - 10:21h


e ao tentar executar o

sudo apt-get install -f libglib2.0-0

deu isso

[email protected]:/home/hudeyson# sudo apt-get install -f libglib2.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
conky-manager : Depends: realpath but it is not going to be installed
Depends: conky but it is not going to be installed
libglib2.0-0 : Depends: libffi6 (>= 3.0.4) but it is not going to be installed
Recommends: xdg-user-dirs but it is not going to be installed
Breaks: glib-networking (< 2.33.12) but 2.32.3-1 is to be installed
Breaks: libgnome-desktop-3-2 (< 3.4.2-2) but 3.4.2-1 is to be installed
Breaks: python-gi (< 3.7.2) but 3.2.2-2 is to be installed
libglib2.0-bin : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-5) but 2.42.1-1 is to be installed
libglib2.0-dev : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-5) but 2.42.1-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[email protected]:/home/hudeyson# sudo apt-get install -f libglib2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is to be installed
Depends: realpath but it is not going to be installed
Depends: conky but it is not going to be installed
libglib2.0-dev : Depends: libglib2.0-0 (= 2.42.1-1) but 2.33.12+really2.32.4-5 is to be installed
Depends: python:any (>= 2.6.6-7~)
Depends: libglib2.0-bin (= 2.42.1-1) but 2.33.12+really2.32.4-5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[email protected]:/home/hudeyson# sudo apt-get install -f libglib2.0-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
conky-manager : Depends: libglib2.0-0 (>= 2.35.9) but 2.33.12+really2.32.4-5 is to be installed
Depends: realpath but it is not going to be installed
Depends: conky but it is not going to be installed
libglib2.0-bin : Depends: libelfg0 (>= 0.8.12) but it is not going to be installed
Depends: libglib2.0-0 (= 2.42.1-1) but 2.33.12+really2.32.4-5 is to be installed
libglib2.0-dev : Depends: libglib2.0-bin (= 2.33.12+really2.32.4-5) but 2.42.1-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



9. Tentando instalar o conky meu apt-get esta dando erro

Hudeyson
hudeyson

(usa Kali)

Enviado em 13/06/2015 - 10:26h

sim ja tentei e postei acima o que aconteceu



10. Tentando instalar o conky meu apt-get esta dando erro

Hudeyson
hudeyson

(usa Kali)

Enviado em 13/06/2015 - 10:29h


#

# deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150312-17:50]/ kali contrib main non-free

#deb http://http.kali.org/kali">http://http.kali.org/kali kali main non-free contrib
#deb-src http://http.kali.org/kali">http://http.kali.org/kali kali main non-free contrib

#deb http://security.kali.org/ kali/updates main contrib non-free
#deb-src http://security.kali.org/ kali/updates main contrib non-free

deb http://http.kali.org/ /kali main contrib non-free
deb http://http.kali.org/ /wheezy main contrib non-free
deb http://http.kali.org/kali">http://http.kali.org/kali kali-dev main contrib non-free
deb http://http.kali.org/kali">http://http.kali.org/kali kali-dev main/debian-installer
deb-src http://http.kali.org/kali">http://http.kali.org/kali kali-dev main contrib non-free
deb http://http.kali.org/kali">http://http.kali.org/kali kali main contrib non-free
deb http://http.kali.org/kali">http://http.kali.org/kali kali main/debian-installer
deb-src http://http.kali.org/kali">http://http.kali.org/kali kali main contrib non-free
deb http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free



11. Re: Tentando instalar o conky meu apt-get esta dando erro [RESOLVIDO]

Thiago Henrique Hüpner
Thihup

(usa Manjaro Linux)

Enviado em 13/06/2015 - 10:34h

Então você tem o Kali, isso já ajudou um pouco.

Digite: sudo nano /etc/apt/sources.list

E troque por:


deb http://ftp.br.debian.org/debian/ wheezy main
deb-src http://ftp.br.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.br.debian.org/debian/ wheezy-updates main
deb-src http://ftp.br.debian.org/debian/ wheezy-updates main

# Repositório Kali Linux
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
# Edge repositorie Kali Linux

deb http://repo.kali.org/kali kali-bleeding-edge main
deb-src http://repo.kali.org/kali kali-bleeding-edge main



Digite sudo apt-get update e veja se resolveu algo.

Espero ter ajudado

[]'s

T+

--
http://piadasnerds.com/wp-content/uploads/2011/08/grafico_souProgramador.png


12. Tentando instalar o conky meu apt-get esta dando erro

Hudeyson
hudeyson

(usa Kali)

Enviado em 13/06/2015 - 10:37h


sim ja coloquei o pc para dar update e upgrade e nao esta funcionando

contia com os erros citados acima



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts