Não posso atualizar Manjaro, problemas de dependências

1. Não posso atualizar Manjaro, problemas de dependências

mario del solar
mario del solar

(usa Manjaro Linux)

Enviado em 16/04/2017 - 14:32h

Oi galera
Eu não posso atualizar o Manjaro que eu recém instalei. Diz que é problemas de dependência entendo que por causa da interfaz gráfica. Ao tetar atualizar sai o que segue:
[[email protected] ~]$ sudo pacman -Syu
[sudo] senha para mario:
:: Sincronizando a base de dados de pacotes...
core está atualizado
extra está atualizado
community está atualizado
multilib está atualizado
:: Iniciando atualização completa do sistema...
:: Substituir manjaro-documentation por extra/manjaro-documentation-en? [S/n] s
:: Substituir pacman-mirrorlist por core/pacman-mirrors? [S/n] s
resolvendo dependências...
procurando por pacotes conflitantes...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: lib32-glu: instalando mhwd (0.6.0rc1-4) dependências 'lib32-libgl'

Obrigado!



  


2. Re: Não posso atualizar Manjaro, problemas de dependências

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/04/2017 - 15:09h

o que acontece, se você tentar instalar só a dependencia?


3. Re: Não posso atualizar Manjaro, problemas de dependências

mario del solar
mario del solar

(usa Manjaro Linux)

Enviado em 16/04/2017 - 15:58h

Me desculpe, estou migrando desde ubuntu até o Manjaro e não conheço bem como me mover no mundo arch pacman. Seria algo assim?

sudo pacman -S lib32-libgl
[sudo] senha para mario:
resolvendo dependências...
procurando por pacotes conflitantes...
:: mesa e mhwd estão em conflito (mesa-libgl). Remover mhwd? [s/N] s
atenção: dependência cíclica detectada:
atenção: mesa será instalado antes de sua dependência libglvnd
atenção: dependência cíclica detectada:
atenção: lib32-mesa será instalado antes de sua dependência lib32-libglvnd

Pacotes (17) lib32-expat-2.2.0-1 lib32-libdrm-2.4.79-1
lib32-libpciaccess-0.13.4-1 lib32-libtxc_dxtn-1.0.1-5
lib32-libxdamage-1.1.4-2 lib32-libxml2-2.9.3-1
lib32-libxshmfence-1.2-1 lib32-libxxf86vm-1.1.4-1
lib32-llvm-libs-3.9.1-2 lib32-mesa-17.0.3-1 lib32-ncurses-6.0-2
lib32-readline-7.0-1 lib32-wayland-1.13.0-1
libglvnd-0.2.999+g4ba53457-2 mesa-17.0.3-1
mhwd-0.5.9-3 [remover] lib32-libglvnd-0.2.999+g4ba53457-2

Tamanho total download: 30,73 MiB
Tamanho total instalado: 124,66 MiB
Alteração no tamanho: 87,20 MiB

:: Continuar a instalação? [S/n] s
:: Obtendo pacotes...
mesa-17.0.3-1-x86_64 8,7 MiB 3,02M/s 00:03 [######################] 100%
libglvnd-0.2.999+g4... 180,1 KiB 4,09M/s 00:00 [######################] 100%
lib32-libpciaccess-... 16,7 KiB 5,43M/s 00:00 [######################] 100%
lib32-libdrm-2.4.79... 135,1 KiB 4,40M/s 00:00 [######################] 100%
lib32-libxxf86vm-1.... 8,3 KiB 641K/s 00:00 [######################] 100%
lib32-libxdamage-1.... 4,5 KiB 1130K/s 00:00 [######################] 100%
lib32-libxshmfence-... 3,5 KiB 874K/s 00:00 [######################] 100%
lib32-ncurses-6.0-2... 222,3 KiB 4,34M/s 00:00 [######################] 100%
lib32-llvm-libs-3.9... 12,2 MiB 1517K/s 00:08 [######################] 100%
lib32-expat-2.2.0-1... 55,5 KiB 1388K/s 00:00 [######################] 100%
lib32-readline-7.0-... 126,3 KiB 294K/s 00:00 [######################] 100%
lib32-libxml2-2.9.3... 550,0 KiB 1024K/s 00:01 [######################] 100%
lib32-wayland-1.13.... 45,1 KiB 3,39M/s 00:00 [######################] 100%
lib32-libtxc_dxtn-1... 9,2 KiB 0,00B/s 00:00 [######################] 100%
lib32-mesa-17.0.3-1... 8,4 MiB 1234K/s 00:07 [######################] 100%
lib32-libglvnd-0.2.... 159,0 KiB 4,57M/s 00:00 [######################] 100%
(16/16) verificando chaves no chaveiro [######################] 100%
(16/16) verificando integridade do pacote [######################] 100%
(16/16) carregando arquivos do pacote [######################] 100%
(16/16) verificando conflitos de arquivo [######################] 100%
erro: falha em submeter a transação (arquivos conflitantes)
libglvnd: /usr/lib/libEGL.so existe no sistema de arquivos
libglvnd: /usr/lib/libEGL.so.1 existe no sistema de arquivos
libglvnd: /usr/lib/libEGL.so.1.0.0 existe no sistema de arquivos
libglvnd: /usr/lib/libGL.so existe no sistema de arquivos
libglvnd: /usr/lib/libGL.so.1 existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv1_CM.so existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv1_CM.so.1 existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv2.so existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv2.so.2 existe no sistema de arquivos
libglvnd: /usr/lib/libGLESv2.so.2.0.0 existe no sistema de arquivos
Ocorreram erros e, portanto, nenhum pacote foi atualizado.



4. Re: Não posso atualizar Manjaro, problemas de dependências

Perfil removido
removido

(usa Nenhuma)

Enviado em 20/04/2017 - 18:02h

tente forçar a instalação com o parâmetro
--force
, depois, tente atualizar normalmente
é comum, acontecer isso no arch e nos seus derivados
mas, geralmente é tranquilo de se arrumar, a não ser que seja algum aplicativo de sistema, aí o bicho pega







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts