Problema com Code Blocks [RESOLVIDO]

1. Problema com Code Blocks [RESOLVIDO]

José Fernando Garcia Junior
jfgjunior

(usa Ubuntu)

Enviado em 20/07/2013 - 20:55h

Instalei hoje o allegro 5.0 no meu ubuntu 13.04, ao terminar a instalação configurei o code blocks pra conseguir usar a allegro, até ai tudo certo, mas ao tentar compilar qualquer projeto, usando a allegro ou não, aparece uma mensagem de erro dizendo "It seems that this project has not been built yet.
Do you want to build it now?" clico em yes e nada ocorre, clico em no e aparece "sh: 1: /home/junior/area de trabalho/projeto/bin/Debug/projeto: not found". Alguém tem alguma idéia de como resolver? já tentei ir em propriedades>Build targets mas a main.c já estava marcada em Build targets files. Tentei também instalar o g++ e o build-essential mas os dois já estavam instalados na versão mais atualizada, tentei também desinstalar e instalar o Code Blocks mas nada deu certo!


  


2. Re: Problema com Code Blocks [RESOLVIDO]

ian cléver sales fernandes
ianclever

(usa Arch Linux)

Enviado em 20/07/2013 - 21:01h

bom, ou a pasta/projeto não foi criado mesmo ou está sem permissão de execução, tente dar permissão de execução para ele:

#chmod a+x nome_projeto


mesmo assim se não for então dê permissão geral para ele:

#chmod 777 nome_projeto


se assim não der não sei o que pode ser.


3. Re: Problema com Code Blocks [RESOLVIDO]

José Fernando Garcia Junior
jfgjunior

(usa Ubuntu)

Enviado em 21/07/2013 - 01:35h

Obrigado ianclever mas não resolveu =/ acredito que não seja problema com permissões também pois a pasta Debug onde ele gera o executavel ta com as permissões drwxr-xr-x, se alguém mais tiver alguma idéia!


4. Re: Problema com Code Blocks [RESOLVIDO]

cr0n
_di0

(usa FreeBSD)

Enviado em 21/07/2013 - 02:29h

sh: 1: /home/junior/area de trabalho/projeto/bin/Debug/projeto: not found

isso provavelmente acontece devido ao espaço no nome "area de trabalho", corrija isso ou escolha um outro diretório sem espaços entre os nomes.


5. Re: Problema com Code Blocks [RESOLVIDO]

José Fernando Garcia Junior
jfgjunior

(usa Ubuntu)

Enviado em 21/07/2013 - 09:35h

Tentei aqui em um diretorio sem espaços e o problema continua, acredito que o
"sh: 1: /home/junior/area de trabalho/projeto/bin/Debug/projeto: not found" aparece pois o code blocks não esta gerando executável!

Se alguém quiser ver o XML do projeto, eu acho que esta tudo certo:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<CodeBlocks_project_file>
<FileVersion major="1" minor="6" />
<Project>
<Option title="projeto" />
<Option pch_mode="2" />
<Option compiler="gcc" />
<Build>
<Target title="Debug">
<Option output="bin/Debug/projeto" prefix_auto="1" extension_auto="1" />
<Option object_output="obj/Debug/" />
<Option type="1" />
<Option compiler="gcc" />
<Compiler>
<Add option="-g" />
</Compiler>
</Target>
<Target title="Release">
<Option output="bin/Release/projeto" prefix_auto="1" extension_auto="1" />
<Option object_output="obj/Release/" />
<Option type="1" />
<Option compiler="gcc" />
<Compiler>
<Add option="-O2" />
</Compiler>
<Linker>
<Add option="-s" />
</Linker>
</Target>
</Build>
<Compiler>
<Add option="-Wall" />
</Compiler>
<Unit filename="main.c">
<Option compilerVar="CC" />
</Unit>
<Extensions>
<code_completion />
<debugger />
</Extensions>
</Project>
</CodeBlocks_project_file>


6. Re: Problema com Code Blocks [RESOLVIDO]

José Fernando Garcia Junior
jfgjunior

(usa Ubuntu)

Enviado em 21/07/2013 - 10:38h

Para resolver fui em Settings>Compiler>Reset Defaults
voltou a funcionar normalmente, acredito que devo ter mexido em alguma configuração ao instalar o allegro, obrigado a todos que ajudaram =D


7. Re: Problema com Code Blocks [RESOLVIDO]

Ayron Gabriel
ayronGabriel

(usa Ubuntu)

Enviado em 24/04/2014 - 20:55h

Tive o mesmo problema, o que aconteceu foi que não tinha instalado o Copilador do C++ do GNU, instalando você resolve problema.


8. Problema para compilar com codeblocks

Carlos Leonardo Porto
leobrlinux

(usa Ubuntu)

Enviado em 17/04/2015 - 23:11h


Boa noite, galera. Estava tendo este problema e só uma coisa resolveu. Seguinte:

1 - Instale o Synaptic - Logado como super usuário digite apt-get install synaptic. Depois de instalado, no terminal mesmo digite a palavra synaptic e o programa vai abrir. Em "Filtro rápido" digite "g++", sem as aspas, claro. Logo após clique com o botão direito encima de g++ e clique em "marcar para instalação. Na janela que se abre, clique em "marcar". Aí depois é só aplicar. Abra o seu codeblocks e seja feliz!






Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts