Ambiente gráfico archlinux plasma não inicia

1. Ambiente gráfico archlinux plasma não inicia

Rogério Soares
rgrsoares

(usa Debian)

Enviado em 04/05/2016 - 11:03h

Bom dia!

Estou me aventurando no Arch Linux depois de anos no Linux Debian, na maior parte. Seguindo o seguinte passo a passo (parte inicial para referência para outros), na parte inicial até chegar ao sistema funcionou, caindo no modo texto. Mas a parte gráfica, onde, resumidamente, segui os seguintes passos não carregou automaticamente nem manualmente a interface gráfica (# startkde), só modo texto ainda. Ah, instalei só em uma partição /dev/sda2, em tri-boot com W10 e Kubuntu 16.04.

# pacman -S plasma sddm sddm-kcm
# systemctl enable sddm
# pacman -S nvidia nvidia-utils
# pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils
# reboot

Passos iniciais:
# ping -c 5 google.com
# loadkeys br-abnt2
# fdisk -l
# cfdisk ->dos
# fdisk -l para ver como ficou
# mkfs.ext4 /dev/sda2
# mount /dev/sda2 /mnt
# pacstrap /mnt base base-devel
# genfstab /mnt >> /mnt/etc/fstab
# cat /mnt/etc/fstab
# arch-chroot /mnt /bin/bash
# nano /etc/locale.gen ->descomente en_US.UTF-8 UTF-8 e pt_BR.UTF-8 UTF-8
# locale-gen
# echo LANG=pt_BR.UTF-8 > /etc/locale.conf
# ls /usr/share/zoneinfo
# ln -s /usr/share/zoneinfo/America/Sao_Paulo /etc/localtime
# hwclock --systohc --utc
# passwd ->para definir senha root
# nano /etc/hostname – nome da máquina, adicione archlinux
# cat /etc/hostname para verificar
# adicionar em /etc/hosts o hostname
# systemctl enable dhcpcd
# pacman -S grub os-prober
# grub-install /dev/sda2
# grub-mkconfig -o /boot/grub/grub.cfg
# useradd -m -g users -s /bin/bash meuusuario
# passwd merovingio
# gpasswd -a meuusuario locate, repita para users, audio, video, daemon, dbus, disk, games, rfkill, lp, network, optical, power, scanner, storage, video
# exit
# umount /mnt
# reboot

Será que faltou algo para o kde plasma rodar? Se alguém puder me ajudar agradeço.


  


2. Re: Ambiente gráfico archlinux plasma não inicia

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 04/05/2016 - 13:19h

Para iniciar com startx, é necessário ter o arquivo .xinitrc configurado dentro do diretório home do usuário.

O ideal para você é configurar para iniciar com o sddm, mas não sei informar como fazer isso no Arch. A Wiki do Arch deve ter algo a respeito.


3. Re: Ambiente gráfico archlinux plasma não inicia

Rogério Soares
rgrsoares

(usa Debian)

Enviado em 04/05/2016 - 13:24h

A noite vou dar uma olhada no Wiki então. Desconfio mesmo que não citaram nos inúmeros posts e vídeos que vi alguma configuração. Se mais alguém tiver uma ideia me avise.


4. Re: Ambiente gráfico archlinux plasma não inicia

Bruno Lima
brunnometal

(usa Arch Linux)

Enviado em 04/05/2016 - 16:38h

rgrsoares escreveu:

Bom dia!

Estou me aventurando no Arch Linux depois de anos no Linux Debian, na maior parte. Seguindo o seguinte passo a passo (parte inicial para referência para outros), na parte inicial até chegar ao sistema funcionou, caindo no modo texto. Mas a parte gráfica, onde, resumidamente, segui os seguintes passos não carregou automaticamente nem manualmente a interface gráfica (# startkde), só modo texto ainda. Ah, instalei só em uma partição /dev/sda2, em tri-boot com W10 e Kubuntu 16.04.

# pacman -S plasma sddm sddm-kcm
# systemctl enable sddm
# pacman -S nvidia nvidia-utils
# pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils
# reboot

Passos iniciais:
# ping -c 5 google.com
# loadkeys br-abnt2
# fdisk -l
# cfdisk ->dos
# fdisk -l para ver como ficou
# mkfs.ext4 /dev/sda2
# mount /dev/sda2 /mnt
# pacstrap /mnt base base-devel
# genfstab /mnt >> /mnt/etc/fstab
# cat /mnt/etc/fstab
# arch-chroot /mnt /bin/bash
# nano /etc/locale.gen ->descomente en_US.UTF-8 UTF-8 e pt_BR.UTF-8 UTF-8
# locale-gen
# echo LANG=pt_BR.UTF-8 > /etc/locale.conf
# ls /usr/share/zoneinfo
# ln -s /usr/share/zoneinfo/America/Sao_Paulo /etc/localtime
# hwclock --systohc --utc
# passwd ->para definir senha root
# nano /etc/hostname – nome da máquina, adicione archlinux
# cat /etc/hostname para verificar
# adicionar em /etc/hosts o hostname
# systemctl enable dhcpcd
# pacman -S grub os-prober
# grub-install /dev/sda2
# grub-mkconfig -o /boot/grub/grub.cfg
# useradd -m -g users -s /bin/bash meuusuario
# passwd merovingio
# gpasswd -a meuusuario locate, repita para users, audio, video, daemon, dbus, disk, games, rfkill, lp, network, optical, power, scanner, storage, video
# exit
# umount /mnt
# reboot

Será que faltou algo para o kde plasma rodar? Se alguém puder me ajudar agradeço.


faltou isso:

sudo systemctl enable sddm.service
sudo system start sddm.service

e não systemctl enable sddm


além do mais essa instalação falta alguns detalhes. Por exemplo você ativa o dhcpcd mas não está informando pra qual interface

Você pegou esses passos de onde?









Signed by brunnometal:
------------------------------------------------------------
- User: Bruno Lima
- Nasc: 25/04/1983
- Local: Recife/PE
- Distro Principal: Arch Linux (KDE)
- Distro Experimental: Nenhuma



5. Re: Ambiente gráfico archlinux plasma não inicia

Gustavo Menezes
Weylin

(usa Arch Linux)

Enviado em 04/05/2016 - 16:58h

Faltou o driver, aí no seu caso, só está instalado as libs do nvidia.

pacman -Ss nvidia driver 


Instale de acordo com o seu PC


6. Re: Ambiente gráfico archlinux plasma não inicia

Rogério Soares
rgrsoares

(usa Debian)

Enviado em 04/05/2016 - 18:02h


faltou isso:

sudo systemctl enable sddm.service
sudo system start sddm.service

e não systemctl enable sddm

além do mais essa instalação falta alguns detalhes. Por exemplo você ativa o dhcpcd mas não está informando pra qual interface

Você pegou esses passos de onde?



Peguei de diversas fontes que nem anotei, até mesmo aqui do VOL. Com pressa, acessei a versão Wiki em inglês, agora achei a versão em português. Acredito realmente que algumas coisas não são exatamente assim nesse simplório passo a passo que segui. Pretendo corrigi-las hoje qdo chegar em casa.

Quando solucionar posto aqui como consegui.











7. Re: Ambiente gráfico archlinux plasma não inicia

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 04/05/2016 - 20:37h

No meu Slack com KDE5, meu arquivo .xinitrc está assim:
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
xmodmap $usermodmap
fi

## KDE Frameworks 5 plus Plasma Next:
#export KF5=/opt/kf5
#export PATH=$KF5/bin:$KF5/lib64/qt5/bin:$PATH
#export QML2_IMPORT_PATH=$KF5/lib64/qt5/qml:/usr/lib64/qt5/qml
#export QT_PLUGIN_PATH=$KF5/lib64/qt5/plugins:/usr/lib64/qt5/plugins
#export XDG_CONFIG_DIRS=$KF5/etc/xdg:/etc/xdg:/etc/kde/xdg
#export XDG_DATA_DIRS=$KF5/share:/usr/share:/usr/local/share

#export XDG_DATA_HOME="$HOME/.local5"
#export XDG_CONFIG_HOME="$HOME/.config5"
#export XDG_CACHE_HOME="$HOME/.cache5"
#export KDEHOME="$HOME/.kde5"

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
ck-launch-session startkde
else
startkde
fi



8. Re: Ambiente gráfico archlinux plasma não inicia

Bruno Lima
brunnometal

(usa Arch Linux)

Enviado em 04/05/2016 - 20:55h

ops e vim ver agora que indiquei system start sddm.service

tava de saída e acabei digitando nas pressas

corrigindo: após o sudo systemctl enable sddm.service utiliza
sudo systemctl start sddm.service






Signed by brunnometal:
------------------------------------------------------------
- User: Bruno Lima
- Nasc: 25/04/1983
- Local: Recife/PE
- Distro Principal: Arch Linux (KDE)
- Distro Experimental: Nenhuma



9. Re: Ambiente gráfico archlinux plasma não inicia

Rogério Soares
rgrsoares

(usa Debian)

Enviado em 04/05/2016 - 21:52h


Nem tinha visto o erro rsrsr

Após esses comando q vc passou aparece a mensagem:
Starting version 229
/dev/sda2: clean, (number)/(number) files, (number)/(number) blocks"
e fica nisso com um cursor piscando...





10. Re: Ambiente gráfico archlinux plasma não inicia

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 04/05/2016 - 23:38h

você usa placas de video da nvidia, amd ou intel (se for nvidia instalou certo)? cade a instalação do x?
pacman -S xorg-server xorg-xinit 


exemplo de xinitrc
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
for f in /etc/X11/xinit/xinitrc.d/*; do
[ -x "$f" ] && . "$f"
done
unset f
fi

# exec gnome-session
# exec startkde
# exec startxfce4
# exec awesome
# ...or the Window Manager of your choice


usa conexão direta ou wifi? instalou quis grupos do plasma e quais grupos de aplicações, ou instalou tudo?


11. Re: Ambiente gráfico archlinux plasma não inicia

Rogério Soares
rgrsoares

(usa Debian)

Enviado em 07/05/2016 - 21:23h

Resolvido seguindo os passos desse vídeo: https://www.youtube.com/watch?v=okct6NwqF_Y, principalmente a 2.ª parte onde começa a instalar o xorg.

Pena que estava travando toda hora e tentei instalar o driver da nvidia (sempre é esse driver que faz travar, pelo menos para mim), mas congelou no meio da instalação e não consigo mais acesso ao sistema. Vou reinstalar. Agora será a 5.ª reinstalação, então estou quase decorando o passo-a-passo.

Obrigado pela ajuda de todos.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts