tomcat

1. tomcat

Geraldo José Ferreira Chagas Júnior
gjr_rj

(usa Debian)

Enviado em 20/05/2009 - 18:11h

Olá pessoal, estou com o seguinte problema.

Instalei o tomcat e estou criando uma plicação para teste.

Crio o diretório HelloServletApp, crio o arquivo HelloServletApp.xml, coloco um index.jsp na pasta HelloServletApp e reinicio o tomcat.

então, ao acessar
<url>:<porta>/HelloServletApp o página aparece normalmente. Se for em Tomcat "Web Application Manager" > "List Applications", a aplicação aparece carregada.

Tudo indica que está OK. Então, avançando, resolvo criar um Serveler simples

compilo o códig java criando a classe HelloServlet.class. crio os diretórios
WEB-INF
WEB-INF/classes
copio a HelloServlet.class para dentro de WEB-INF/classes
crio o arquivo WEB-INF/web.xml com o conteúdo abaixo. Reinicio o Tomcat e a aplicação não funciona mais.

Há alguma coisa de errado nesses passos ?

WEB-INF/web.xml
----------------
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>

<!-- Indica ao Tomcat as Servlets da nossa aplicacao -->

<servlet>
<servlet-name>HelloServlet</servlet-name>
<servlet-class>HelloServlet</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>HelloServlet</servlet-name>
<url-pattern>/HelloServlet</url-pattern>
</servlet-mapping>


</web-app>



  


2. amigo

João Marcos Menezes
stremer

(usa Arch Linux)

Enviado em 21/05/2009 - 00:02h

poste o erro...
e tbem o código da servlet para ver se esta correto...
a principio deveria funcionar!
abs






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts