Instalação PHP 5.2 Debian 7 wheezy [RESOLVIDO]

1. Instalação PHP 5.2 Debian 7 wheezy [RESOLVIDO]

Marcelo Alves
marcelloalvess

(usa Debian)

Enviado em 24/06/2014 - 16:54h

Preciso de ajuda, estou precisando utilizar algumas aplicações mais antigas e tenho tentado instalar o php 5.2 no Debian 7 wheezy mais tenho tido dificuldades pois pelo apt-get ou aptitude instala somente o php 5.4, tentei alguns tutoriais que achei para compilar mais nada deu certo, alguém pode me ajudar?


Abraço


  


2. Re: Instalação PHP 5.2 Debian 7 wheezy [RESOLVIDO]

Buckminster
Buckminster

(usa Debian)

Enviado em 24/06/2014 - 18:40h

Qual a dificuldade que tu está tendo?

Siga o que está nesse link:

http://xuniltech.wordpress.com/2013/09/12/install-php-5-2-on-wheezy-debian-7/


3. Re: Instalação PHP 5.2 Debian 7 wheezy [RESOLVIDO]

Marcelo Alves
marcelloalvess

(usa Debian)

Enviado em 25/06/2014 - 09:07h

Buckminster bom dia, eu ja havia tentado com esse tutorial e não tive muito sucesso,

quando eu digito o comando apt-get update depois da atualização tem essa saída

W: Não existem chaves públicas para os seguintes IDs de chaves:
4D270D06F42584E6

quando tento instalar algum pacote tem essa saída

~#dpkg -i libapache2-mod-php5_5.2.6.dfsg.1-1+lenny16_amd64.deb

(Lendo banco de dados ... 25879 ficheiros e directórios actualmente instalados.)
Preparando para substituir libapache2-mod-php5 5.2.6.dfsg.1-1+lenny16 (usando libapache2-mod-php5_5.2.6.dfsg.1-1+lenny16_amd64.deb) ...
Desempacotando substituto libapache2-mod-php5 ...
dpkg: problemas com dependências impedem a configuração de libapache2-mod-php5:
libapache2-mod-php5 depende de libdb4.6; porém:
Pacote libdb4.6 não está instalado.
libapache2-mod-php5 depende de libkrb53 (>= 1.6.dfsg.2); porém:
Pacote libkrb53 não está instalado.
libapache2-mod-php5 depende de libssl0.9.8 (>= 0.9.8f-5); porém:
Pacote libssl0.9.8 não está instalado.
libapache2-mod-php5 depende de apache2-mpm-prefork (>> 2.0.52) | apache2-mpm-itk; porém:
Pacote apache2-mpm-prefork não está instalado.
Pacote apache2-mpm-itk não está instalado.
libapache2-mod-php5 depende de php5-common (= 5.2.6.dfsg.1-1+lenny16); porém:
Pacote php5-common não está instalado.

dpkg: erro ao processar libapache2-mod-php5 (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
libapache2-mod-php5




4. solucao

Celso Aristides Rodrigues de Oliveira
Celso_Linuxer

(usa Linux Mint)

Enviado em 07/05/2015 - 12:32h

marcelloalvess escreveu:

Buckminster bom dia, eu ja havia tentado com esse tutorial e não tive muito sucesso,

quando eu digito o comando apt-get update depois da atualização tem essa saída

W: Não existem chaves públicas para os seguintes IDs de chaves:
4D270D06F42584E6

quando tento instalar algum pacote tem essa saída

~#dpkg -i libapache2-mod-php5_5.2.6.dfsg.1-1+lenny16_amd64.deb

(Lendo banco de dados ... 25879 ficheiros e directórios actualmente instalados.)
Preparando para substituir libapache2-mod-php5 5.2.6.dfsg.1-1+lenny16 (usando libapache2-mod-php5_5.2.6.dfsg.1-1+lenny16_amd64.deb) ...
Desempacotando substituto libapache2-mod-php5 ...
dpkg: problemas com dependências impedem a configuração de libapache2-mod-php5:
libapache2-mod-php5 depende de libdb4.6; porém:
Pacote libdb4.6 não está instalado.
libapache2-mod-php5 depende de libkrb53 (>= 1.6.dfsg.2); porém:
Pacote libkrb53 não está instalado.
libapache2-mod-php5 depende de libssl0.9.8 (>= 0.9.8f-5); porém:
Pacote libssl0.9.8 não está instalado.
libapache2-mod-php5 depende de apache2-mpm-prefork (>> 2.0.52) | apache2-mpm-itk; porém:
Pacote apache2-mpm-prefork não está instalado.
Pacote apache2-mpm-itk não está instalado.
libapache2-mod-php5 depende de php5-common (= 5.2.6.dfsg.1-1+lenny16); porém:
Pacote php5-common não está instalado.

dpkg: erro ao processar libapache2-mod-php5 (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
libapache2-mod-php5




Qual foi a solução







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts