Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

1. Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

Jocsa Vasconcelos Rosendo
jocsarosendo

(usa elementary OS)

Enviado em 27/09/2015 - 00:43h

E ai pessoal!

Devido a faculdade eu precisei criar um servidor LAMP para poder realizar os estudos de PHP passados pelo professor. Um colega de classe me falou pra eu dar uma olhada em uma nova ferramenta de virtualização que é o Vagrant e eu acabei gostando bastante. Nos primeiros dias usei normalmente, tive alguns problemas com o phpmyadmin mas logo encontrei a solução nos foruns. Porém, um outro dia ao levantar o servidor, fui fazer acesso pelo browser e acabei me deparando com o erro 403 Forbidden. Erro completo a baixo:

Forbidden

You don't have permission to access / on this server.
Apache/2.4.7 (Ubuntu) Server at 192.168.33.10 Port 80


Bom, já rodei pra cima e pra baixo no google procurando como resolver esse problema e as muitas das soluções, por eu ser novato com o apache, não entendia como fazer e as que entendia não solucionou meu problema. Desistindo de achar a solução, apaguei tudo em relação ao Vagrant e recomecei do zero a instalação e coloquei a máquina de novo, mas o erro continua. Pensei que fosse algum problema com o meu S.O. e acabei realizando uma restauração do sistema (eu uso o ubuntu 14.04) e mesmo assim não obtive exito. Enfim, não sei mais o que fazer e pelo fato do pouco conhecimento que tenho com o apache, se for mexer sem base, vou acabar dando mais problema.

O que pode ser? Pelo que entendi, o servidor está funcionando corretamente, inclusive o apache, porém estou sem permissão para o acesso pelo browser. O estranho foi que isso aconteceu de um dia para o outro; em um dia funciona e no outro não funciona.

Enfim, estou precisando urgente resolver este problema, estou parado com meus estudos devido a isto e não quero instalar nenhuma ferramenta como wamp e etc, particularmente eu não gosto mesmo, prefiro criar servidores. Desde já agradeço a ajuda.

ps: Não coloquei nenhum log de erros, pois não sei qual colocar, o que vcs pedirem eu vou fazendo, vlw!!


  


2. Re: Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

CASSIO FERRAZ
cassio88

(usa Ubuntu)

Enviado em 27/09/2015 - 04:08h

interessante, erro 403 deveria ser simples de resolver, basta o comando sudo chmod, veja na mensagem 2 do link abaixo:
http://www.vivaolinux.com.br/topico/Apache-Web-Server/sem-acesso-ao-localhostphpmyadmin
Suponho que você usa ubuntu 14 ou 15, então se instalou Apache, PHP, MySQL e PHPMyAdmin pelo synaptic ou pelo apt, ele deve funcionar.
Se não souber sobre synaptic / apt, dá um toque.
Dá um retorno depois dizendo se funcionou




3. Re: Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

Jocsa Vasconcelos Rosendo
jocsarosendo

(usa elementary OS)

Enviado em 27/09/2015 - 14:54h

cassio88 escreveu:

interessante, erro 403 deveria ser simples de resolver, basta o comando sudo chmod, veja na mensagem 2 do link abaixo:
http://www.vivaolinux.com.br/topico/Apache-Web-Server/sem-acesso-ao-localhostphpmyadmin
Suponho que você usa ubuntu 14 ou 15, então se instalou Apache, PHP, MySQL e PHPMyAdmin pelo synaptic ou pelo apt, ele deve funcionar.
Se não souber sobre synaptic / apt, dá um toque.
Dá um retorno depois dizendo se funcionou


Manow, segui os passos lá e nada. Baixei uma outra box e instalei pelo vagrant tudo de novo, desta vez abre a primeira página, que é o index.html; O arquivo index.html aponta, normalmente, para as outras pastas que eu tenho, cada pasta sendo um projeto diferente em php, e nenhuma delas abre. Rodei o comando sudo sudo chmod 777 -R, tanto com o 'www', quanto o nome de cada pasta que tenho e não muda.

Pelo que entendo, são as permissões mesmo. Desta vez a página inicial 'index.html' abre, ao menos isto, mas quando eu acesso outra pelos links criados '<a href"" e etc' dá acesso negado novamente.

A outra box que estou usando é a 'ubuntu-precise64'





4. Re: Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

CASSIO FERRAZ
cassio88

(usa Ubuntu)

Enviado em 27/09/2015 - 16:03h

Ô loco, o caso é mais grave que eu pensei...

Diz algumas coisas:

1) você instalou a versão 14.04 ou 15.04 do Ubuntu?

2) Quando instalou, baixou a imagem iso e a gravou num DVD-R na velocidade mais baixa possível?

3) Synaptic é a versão gráfica do apt. Ao instalar o Apache (se não me engano, versão é 2,2), o Synaptic instala também as dependências (ou seja, os pacotes dos quais o Apache necessita). Se instalou corretamente, abra o firefox e digite:
http://localhost/
deverá aparecer o default, na versão 14 acho que é:
It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet.
Na versão 15, muda, de qualquer modo você vai perceber que o Apache está rodando.
Sem ele, não há como continuar. Até este ponto você conseguiu chegar?




5. Re: Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

Jocsa Vasconcelos Rosendo
jocsarosendo

(usa elementary OS)

Enviado em 27/09/2015 - 16:13h

cassio88 escreveu:

Ô loco, o caso é mais grave que eu pensei...

Diz algumas coisas:

1) você instalou a versão 14.04 ou 15.04 do Ubuntu?

2) Quando instalou, baixou a imagem iso e a gravou num DVD-R na velocidade mais baixa possível?

3) Synaptic é a versão gráfica do apt. Ao instalar o Apache (se não me engano, versão é 2,2), o Synaptic instala também as dependências (ou seja, os pacotes dos quais o Apache necessita). Se instalou corretamente, abra o firefox e digite:
http://localhost/
deverá aparecer o default, na versão 14 acho que é:
It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet.
Na versão 15, muda, de qualquer modo você vai perceber que o Apache está rodando.
Sem ele, não há como continuar. Até este ponto você conseguiu chegar?



Brother, eu uso o ubuntu 14.04. Eu criei um server pelo Vagrant (que usa o virtual box) e instalei o php5, apache2, mysql-server e o phpmyadmin pelo terminal, acessei o servidor via SSH e por lá fiz toda a instalação usando apt-get.

Fico imaginando se os cara fizeram alguma atualização no apache2 e mudou alguma coisa nesse quesito de permissões. Não sei o que fazer, acho que vou instalar um LAMP mesmo por enquanto, menos não gostando...


6. Re: Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

CASSIO FERRAZ
cassio88

(usa Ubuntu)

Enviado em 27/09/2015 - 16:41h


Ôpa, pelo desculpas, pensei que seu nível de conhecimento era bem mais básico.

Há anos eu uso o Ubuntu, fiz instalação local no meu micro, a receita te passei (usar synaptic) roda tranquilo.

Dei um google, vi diversos links, tais como
https://github.com/Varying-Vagrant-Vagrants/VVV/issues/261
https://teamtreehouse.com/community/get-permission-denied-when-creating-odot-rails-app-in-project-di...

Realmente todos têm respostas parecidas, mas não são as mesmas, então vai ter que ser pelo método da tentativa e erro

Como você não partiu para o modo mais simples (localhost na sua máquina local), suponho que seja porque "essa dor de cabeça" faz parte do seu curso...


7. Re: Forbidden 403 - Sem permissao de acesos ao servidor - APACHE2 - Vagrant [RESOLVIDO]

Jocsa Vasconcelos Rosendo
jocsarosendo

(usa elementary OS)

Enviado em 01/10/2015 - 04:15h

cassio88 escreveu:


Ôpa, pelo desculpas, pensei que seu nível de conhecimento era bem mais básico.

Há anos eu uso o Ubuntu, fiz instalação local no meu micro, a receita te passei (usar synaptic) roda tranquilo.

Dei um google, vi diversos links, tais como
https://github.com/Varying-Vagrant-Vagrants/VVV/issues/261
https://teamtreehouse.com/community/get-permission-denied-when-creating-odot-rails-app-in-project-di...

Realmente todos têm respostas parecidas, mas não são as mesmas, então vai ter que ser pelo método da tentativa e erro

Como você não partiu para o modo mais simples (localhost na sua máquina local), suponho que seja porque "essa dor de cabeça" faz parte do seu curso...


E ai cara! Passando pra agradecer a ajuda e informar que consegui resolver o problema mas encontrei outro kkkk. Ao menos um foi resolvido.

Estava dando erro 403 justamente pelo apache não ter permissão de leitura dos arquivos, só que quando eu aplicava o comando 'chmod' não obtia exito pelo fato de estar tentando fazer em uma outra partição do meu hd sem ser a /home - que é esse o outro problema, ou seja, não sei o porque não consigo, talvez seja a montagem dessa outra partição, mas enfim... - criei um workspace no diretório /home e executei de novo o chmod 777 -R 'mais a pasta' e obtive exito.

Espero que essa minha conclusão possa ajudar a mais pessoas.
Se acredita em Deus, que Deus te abençoe, se não, que Ele te abençoe do mesmo jeito! haha! vlw mais uma vez!


8. Passei por isso esses tempos...

Higor da Silva Lopes
ThinKing

(usa Debian)

Enviado em 11/06/2017 - 21:15h

Passei por isso esses tempo...
Olha mano...
Muda sua página padrão do index.html(var/www/html)
Para dentro de um novo diretório no diretório home:
exemplo --> /home/meusite/index.html
depois disso muda todas as configurações do apache2(/etc/apache2);
modifica o arquivo apache2.conf onde estiver escrito
/var/www/ 

para
 /home/meusite/ 

modifica também os arquivos de configuração na pasta
sites-available(000-default.conf e default-ssl.conf) e sites-enabled(000-default.conf)
modificando apenas o caminho do site de
var/www/htm 
para
/home/meusite/ 







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts