Configurar DNS e Dominio Virtual [RESOLVIDO]

1. Configurar DNS e Dominio Virtual [RESOLVIDO]

Juda Benhur
paulistinha

(usa Red Hat)

Enviado em 07/09/2009 - 07:02h

Pessoal,


Mais uma vez, uma pergunta talvez simples para a maioria, mas pra mim, estou apanhando (e muito)...

Tenho um servidor de DNS onde administro os meus dominios na web. Até ae, tudo bem.

Cada site tem seu dns bem configurado, mas agora, tenho que habilitar o apache a responder também pelo nome do domínio sem o "www", por exemplo:

Domínio Web:

teste.com.br -> www.teste.com.br (configurado e funcionando no apache)

Agora, preciso que 'teste.com.br' seja respondido pelo apache quando alguém digitar no browser apenas o dominio, sem o "www".

No Apache, acredito que bastaria eu adicionar a linha com o "ServerAlias" apontando para 'teste.com.br', certo ???

E no DNS, como criar esse registro?

Fiz várias tentativas no DNS e tenho erro quando vou carregar o dns com a nova configuração de zona.


Alguma ajuda?

Muito obrigado.


  


2. Re: Configurar DNS e Dominio Virtual [RESOLVIDO]

Juda Benhur
paulistinha

(usa Red Hat)

Enviado em 07/09/2009 - 09:44h

Pessoal,

Na tentativa de resolver esse problema, fiz conforme o indicado em:
http://www.vivaolinux.com.br/dica/Colocando-um-site-no-ar-sem-o-www/ , e ainda assim, nao tenho sucesso.

Ao carregar o arquivo de zona do DNS, tenho a seguinte mensagem:


"Sep 7 21:36:25 dns1 named[24025]: zone teste.com.br/IN: loading from master file master/teste.com.br failed: CNAME and other data"

No arquivo de zona, tenho:

@ IN CNAME www
www IN CNAME parana.teste.com.br.

Alguma dica???


Grato!



3. Re: Configurar DNS e Dominio Virtual [RESOLVIDO]

Juda Benhur
paulistinha

(usa Red Hat)

Enviado em 08/09/2009 - 04:07h

Pessoal,

Consegui resolver o problema.

Quanto ao DNS, a razão para que não funcionava era porque eu estava usando "CNAME" e o correto, deveria ser apontar para um endereço ip (A). Não sei se em outras versões do bind isso funcionava assim, mas na versão que estou usando, só funcionou deste modo.

Quanto ao Apache, o parametro "ServerAlias" serveria sem problema, mas no meu caso, tenho um problema bem diferente. Mas ainda vou estudá-lo.

Grato a todos que tentaram me ajudar.

Abraços.