duvida no exercicio de matriz

1. duvida no exercicio de matriz

José Augusto Santos de Souza
J4

(usa Debian)

Enviado em 11/09/2011 - 14:37h

boa tarde!
Bom estou com duvida sobre um exercício de um livro de logica
a questão é a seguinte
q) Elaborar um programa que faça a leitura de 20 valores inteiros em uma matriz A de duas dimensões com quatro linha e cinco colunas. Construir uma matriz B de uma dimensão para quatro elementos que seja formada pelo somatorio pelos elementos correspondente de cada linha da matriz A. Construir uma matriz C com uma dimensao de cinco elementos para somatoria dos elementos das cincos colunas. No final mostra B e C.

estou meio perdido nesse algoritmo


  


2. Re: duvida no exercicio de matriz

Guilherme Pedroso
GuiPedr0s0

(usa Ubuntu)

Enviado em 11/09/2011 - 14:54h

Quando precisar tem esse site aqui muito bom para esse tipo de dúvida!
Entre e procure o que você precisa: http://bit.ly/nhoGbT

Como eu sou bonzinho, tem esse aqui também: http://bit.ly/mXqdzT
Ninguém dará a resposta para você aqui!


3. Re: duvida no exercicio de matriz

José Augusto Santos de Souza
J4

(usa Debian)

Enviado em 12/09/2011 - 04:56h

1 - GuiPedr0s0,se você não percebeu aqui no vivaolinux tem área para este tipo de pergunta "vivaolinux->Comunidades->programação->Algoritmos e resoluções de problemas".
2 - muito obrigado pelo 2 link o primeiro é minha pagina inicial


4. uma maneira

Valdelírio da Silva e Silva
valdelirio

(usa Ubuntu)

Enviado em 27/09/2011 - 18:52h

Bem, aí vai em linguagem fortran, mas é fácil de entender e passar para uma outra linguagem.
!Para ler a matriz A (4 por 5) armazenada no arquivo 1:
do i=1,4
do j=1,5
read(1,*)A(i,j)
end do
end do

!Construção do array B de 4 elementos que correspondem a somatória dos elementos de cada linha de A:
do i=1,4
ai = A(i,1)
do j=2,5
B(i) = ai + A(i,j)
ai = B(i)
end do
end do

!Construção do array C de 5 elementos que correspondem a somatória dos elementos de cada coluna de A:
do i=1,5
aj = A(1,j)
do j=2,4
C(i) = aj + A(j,i)
aj = C(i)
end do
end do

Na verdade em fortran (como em outras linguagens) há função intrínsica que realiza somatória (ou produtório) de elementos de uma matriz numa dada dimensão; mas creio que não seja seu propósito aqui.
Abraço


5. Re: duvida no exercicio de matriz

Thiago Luis Moraes
muky

(usa Ubuntu)

Enviado em 05/12/2011 - 04:05h

#Elaborar um programa que faça a leitura de 20 valores inteiros em uma matriz A de duas dimensões com quatro linha e cinco colunas.
#Construir uma matriz B de uma dimensão para quatro elementos que seja formada pelo somatorio pelos elementos correspondente de cada linha da matriz A.
#Construir uma matriz C com uma dimensao de cinco elementos para somatoria dos elementos das cincos colunas.
#No final mostra B e C.

Inicio

//Declaração das variaveis

int mata: matriz (4,5) de inteiro
int vetb:vetor(4) de inteiro
int vetc:vetor(5) de inteiro
somalin,somacol,i,j:inteiro

//Inicialização das variaveis

somalin <-0
somacol <-0

//Leitura

para i=1 ate 4 faça
para j=1 ate 5 faça

escreva("Entre com os elementos da matriz A")
leia(mata(i)(j))

fim para
fim para

//Processo

para i=1 ate 4 faça
vetb(i)<-0

para j=1 ate 5 faça
vetc(j)<-0

somalin<- mata(i)(j) + somalin
vetb(i) <- somalin

somacol <- mata(j)(i) + somacol
vetc(j) <- somacol

fim para
fim para

//Impressao dos resultados

para i=1 ate 4 faça
escreva(vetb)
fim para

para i=1 ate 5 faca
escreva(vetc)
fim para

//Fim

amigo, o certo era construir um vetor para esse somatorio, nao faz sentido criar um matriz para isso entende, nao sei se ta certo espero ter ajudado (y)






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts