Problema misterioso.... [RESOLVIDO]

1. Problema misterioso.... [RESOLVIDO]

Ghroll
Ghroll

(usa Debian)

Enviado em 13/01/2014 - 20:34h

Alguém pode resolver isso?

toda vez que eu dou ctrl+c pra parar o ettercap aparece esse aviso.

eu sou root e sou o único usúario da maquina...

Perhaps iptables or your kernel needs to be upgraded.
iptables v1.4.14: can't initialize iptables table `nat': Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.
iptables v1.4.14: can't initialize iptables table `nat': Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.
iptables v1.4.14: can't initialize iptables table `nat': Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.
iptables v1.4.14: can't initialize iptables table `nat': Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.
iptables v1.4.14: can't initialize iptables table `nat': Permission denied (you must be root)



  


2. Re: Problema misterioso.... [RESOLVIDO]

Buckminster
Buckminster

(usa Debian)

Enviado em 13/01/2014 - 21:34h

"Perhaps iptables or your kernel needs to be upgraded.
iptables v1.4.14: can't initialize iptables table `nat': Permission denied (you must be root)

Talvez o Iptables ou o Kernel precisam de upgrade.
Iptables versão 1.4.14: não foi possível iniciar o Iptables, tabela nat: Permissão negada (você precisa estar como root).

Qual é a versão do teu kernel?


3. Re: Problema misterioso.... [RESOLVIDO]

Ghroll
Ghroll

(usa Debian)

Enviado em 14/01/2014 - 06:17h

É com o comando uname -a que eu vejo?

Tenho 95% de certeza de ter resolvido...pesquisei muito ontem a noite e achei um forum americano onde um cara falava do mesmo problema.

Toda vez que eu encerrava o ettercap no console ele mostrava esse erro.
Então tinha um cara lá mandando editar o ettercap.conf

tipo:

Antes

[privs]
ec_uid = 65534 # nobody is the default
ec_gid = 65534 # nobody is the default

Depois

[privs]
ec_uid = 0 # nobody is the default
ec_gid = 65534 # nobody is the default

Valeu por ter perguntado!!!

fiz vários testes e não tive mais a mensagem que citei no começo.

Qualquer coisa me manda algumas dicas.

Abraço.


4. Re: Problema misterioso.... [RESOLVIDO]

Buckminster
Buckminster

(usa Debian)

Enviado em 14/01/2014 - 15:28h

uname -a

ou

uname -r