Xoom no Ubuntu - Montando a Media interna

Publicado por Juliano Capristo em 23/07/2011

[ Hits: 14.477 ]

Blog: http://about.me/capristo

 


Xoom no Ubuntu - Montando a Media interna



Usando o Tablet da MOTOROLA - XOOM no Ubuntu 11.04

Instale o mtpfs, mtp-tools, libmtp-dbg, libmtp-dev, libmtp8, usando o comando:

sudo apt-get install mtpfs mtp-tools libmtp-dbg libmtp-dev libmtp8

Crie o arquivo de regras para udev, use o comando:

sudo vi /etc/udev/rules.d/51-android.rules

E adicione o seguinte conteúdo:

SUBSYSTEM=="usb", ATTR{idVendor}=="22b8", MODE="0666"
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666"

Crie um ponto de montagem, use o comando:

sudo mkdir /media/xoom

Mude as premissões:

sudo chown user:user /media/xoom

Obs.: Substitua (user) pelo seu usuário no sistema. Adicione uma entrada em /etc/fstab:

sudo vi /etc/fstab

Coloque a linha abaixo no inicio do arquivo:

mtpfs /media/xoom fuse user,noauto,allow_other 0 0

Finalmente, edite o arquivo /etc/fuse.conf e descomente a seguinte linha:

#user_allow_other para user_allow_other

Reinicialize e pronto.

Para montar o XOOM via terminal:

sudo mtpfs /media/xoom -o allow_other

Para Desmontar o XOOM via terminal, use o comando:

# sudo fusermount -u /media/xoom

Seja Livre e use Linux. Apaixonados pela Liberdade by Juliano Capristo Malheiros


Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

PHPMailer - Validação de campos, e-mail e domínio para formulário de contato e envio

Organizando as tralhas

Instalando o Picasa 3 no Linux

Torne-se um usuário oficial!

Alterando permissões em arquivos ou somente nos diretórios

  

Comentários
[1] Comentário enviado por branco003 em 24/07/2011 - 08:35h

Desculpe, mas ao tentar montar a midia está aparecendo o seguinte erro:

Erro ao iniciar arquivo "/media/xoom": Ponto final de transporte não está conectado.

O que devo fazer ?
Obrigado

[2] Comentário enviado por capristo em 24/07/2011 - 22:19h

Boa Noite branco003 olha isso ocorreu porque o XOOM (Tablete) deve esta conectado via cabo antes da montagem...

caso a Montagem é feita sem o Dispositivo estar conectado a maquina o mesmo exibe essa mensagem abaixo...

==========================================================
Não foi possível exibir "/media/xoom".
Erro:Erro ao iniciar arquivo "/media/xoom":POnto final de transporte não está conectado
Por favor selecione outro visualizador e tente novamente.
==========================================================

DICA: Use o comando para forçar a desmontagem do XOOM (O xoom não deve estar conectado para fazer essa operação)

# umount -l /media/xoom

feito isso tente novamente agora com ele conectado ao USB

montar

mtpfs /media/xoom -o allow_other

Desmontar

fusermount -u /media/xoom

Espero ter ajudado... Capristo

[3] Comentário enviado por adilson bts em 07/10/2011 - 11:12h

aqui consegui montar, só que fica muito lento pra abrir as pastas e colei alguns arquivos e quando fui velosno xoom a pasta estava vazia... o que pode ter ocorrido? obrigado !!

[4] Comentário enviado por capristo em 20/10/2011 - 11:45h

Olha Adilson desculpa pela demora... Estava de viagem mais não sei oque pode ter ocorrido viu... Aqui esta funcionando perfeitamente instalei até o novo ubuntu 11.10 e rodo perfeito... a unica diferença foi na hora da desmontagem do xoom pois no 11.10 tem que usar o comando # umount -l /media/xoom (Como super Usuario forçamdo a desmontagem) ainda não identifiquei o porque o fusermount -u /media/xoom não funciona legal no 11.10 mais no 11.04 funciona perfeitamente... Abs

[5] Comentário enviado por bertoluiz em 17/02/2012 - 19:35h

olha, só por esse tuto eu não consigui realizar o procedimento, tive que pegar uma parte desse aqui também: http://www.otubo.net/2011/04/using-mtpfs-as-sotare-device-with.html ; principalmente na hora de escrever essa parte: SUBSYSTEM=="usb", ATTR{idVendor}=="22b8", MODE="0666"
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666" que aqui não dava de jeito nenhum, e usei o do site informado e segui por aqui depois e funcionou direitinho. inclusive, tava olhando, ficou como reconhecido como usb 2.0 em vez de 1.0 ou 1.1 que andei olhando por outros tutos. Mas agradeço a pró-atividade de ajuda os outros nesse requesito.

[6] Comentário enviado por capristo em 18/02/2012 - 10:23h

bertoluiz que bom que deu certo o procedimento... linux é assim uns ajudando a outros... a comunidade agradece.. abs Juliano Capristo

[7] Comentário enviado por removido em 28/06/2012 - 23:26h

muito boa a dica, valeu mesmo, cara!

[8] Comentário enviado por removido em 30/06/2012 - 16:39h

PROBLEMA!
Até consigo acessar os arquivos, mas não consigo transferir mídia, quando vou transferir, ele trava e não há santo que faça destravar....

Motorola Xoom 2
Ubuntu 12.04

[9] Comentário enviado por herlimenezes em 09/07/2012 - 18:37h

Tentei usar o tablet no Fedora 16, segui os passos indicados. Quando tento montar, obtenho a seguinte saída:
==============================================
[herlimenezes@Aires2 ~]$ mtpfs /media/xoom -o allow_other
Listing raw device(s)
No raw devices found.
==============================================
Se eu uso lusub, obtenho a saída:

++++++++++++++++++++++++++++++++++
[root@Aires2 ~]# lsusb
Bus 001 Device 003: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 002 Device 002: ID 03f0:7a04 Hewlett-Packard DeskJet D2460
Bus 002 Device 003: ID 03f0:0a01 Hewlett-Packard ScanJet 2400c
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 22b8:41cf Motorola PCS
Bus 001 Device 005: ID 04ca:0022 Lite-On Technology Corp.
Bus 001 Device 006: ID 2188:0ae1
+++++++++++++++++++++++++++++++++++
Ele "ve" o tablet, não? Como faço para conectar?

abc

Herli Menezes


[10] Comentário enviado por bonilhasilvio em 31/08/2012 - 14:50h

Juliano Capristo, excelente tutorial.
Vou relatar o que fiz, pode ser que ajude outras pessoas.
Tenho um Xoom M604 Motorola Wifi. Conectei com meu computador - Ubuntu 11.10 com KDE (não é Kubuntu).
Segui seu script, mas na linha:
$ sudo apt-get install mtpfs mtp-tools libmtp-dbg libmtp-dev libmtp8
não funcionou, então instalei um a um, ou seja:
$ sudo apt-get install mtpfs
$ sudo apt-get install mtp-tools
$ sudo apt-get install libmtp-dbg
$ sudo apt-get install libmtp-dev
Quando tentei instalar o "libmtp8" o sistema sugeriu o "libmtp-runtime" e o "libmtp-common".
segui a sugestão.
$ sudo apt-get install libmtp-runtime
$ sudo apt-get install libmtp-common
Daí fui até o final do seu script e funcionou beleza.

Dei uma incrementada e criei um arquivo sh para montar e desmontar o Xoom, conforme script abaixo:
(baseado nas dicas Rodrigo - http://www.vivaolinux.com.br/script/Abre-e-Fecha-o-CD-DVD-ROM )

#!/bin/bash

menu()

{
clear
echo
echo "###########################"
echo "# #"
echo "# Melhor conectar o Xoom no carregador #"
echo "# #"
echo "###########################"
echo
echo "[1] montar"
echo "[2] desmontar"
echo "[0] sair"
}

central ()
{
menu
read opcao
while [ $opcao != "s" ];
do
menu
case $opcao in
1) montar;;
2) desmontar;;
0) sair;;
esac
read opcao
done
}

montar ()
{
clear
echo
echo "Xoom montado"
echo
sudo mtpfs /media/xoom -o allow_other
clear
central
}

desmontar ()
{
clear
echo
echo "Xoom desmontado"
echo
sudo fusermount -u /media/xoom
central
}
sair ()
{
clear
exit
}

clear
central
clear


[11] Comentário enviado por Pollianna em 17/05/2014 - 17:16h

Sou nova no linux (ubuntu)Estou tentando remover o xoom, mas ta complicado, aparece isso no terminal:
fusermount failed to unmont / media/xoom invalid argument.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts