Wine - Atualizando para a versão 1.3 no Debian Squeeze

Publicado por Rômulo Mazzuco Grandini em 12/03/2012

[ Hits: 6.201 ]

 


Wine - Atualizando para a versão 1.3 no Debian Squeeze



Após passar algum tempo quebrando a cabeça, venho aqui postar minha solução para esse problema chatinho e, por incrível que pareça ela é bem fácil de ser feita. Meu problema era o seguinte: eu queria instalar o Photoshop CS5 no Wine mas só funcionava com Wine 1.2+ e o padrão do Debian Squeeze 6.0.4 é a anterior.

Sem mais delongas, vamos lá:

Primeiro, adicione estes repositórios no seu sources.list e certifique-se de já utilizar os parâmetros "contrib non-free" nos principais que vem com a instalação.

# gedit /etc/apt/sources.list

Utilizo o gedit do GNOME, mas pode editar com o editor de sua preferência.

deb http://www.lamaresh.net/apt squeeze main
deb http://main.mepis-deb.org/mepiscr/repo/ mepis85cr main

Após adicionar as linhas acima, insira a chave:

# wget -O - http://www.lamaresh.net/apt/key.gpg | apt-key add -

Feito isso, rode um:
# apt-get update

Agora, caso você tenha o Wine instalado, é fundamental que você pare o server dele e purge todos seus arquivos, senão não dará certo, caso ele não esteja instalado, pule para a parte do apt-get build-dep wine.

# wineserver -k
# apt-get purge wine


Se tiver o PlayOnLinux ou algum outro mod para Wine, purge também.

Um problema que tive em atualizar o Wine foi a porrada de dependências que ele pede, que consegui facilitar utilizando o comando:

# apt-get build-dep wine

Vai pedir pra baixar uns 90MB de pacotes, pode baixar sem medo.

Após terminar acima, use:

# apt-get install wine

Ele irá baixar quase 195MB de pacotes, demorará um pouco.

Terminando essa instalação, verá que o atalho para o Wine será criado normalmente. Caso queira conferir utilize:

wine --version

Verás que é a 1.3.27 :)

Fica a dica, espero que ajude a galera, lembrando que somente testei no Debian Squeeze 6.0.4 64 bits!

Abraços!

Outras dicas deste autor

Proxy Autenticado - Atualização automática do Microsoft Security Essentials e Windows Update

Leitura recomendada

Instalação Packet Tracer Cisco v5.3 no Ubuntu Linux 10.10 x86

Instalando o plugin Java6 da Sun no Ubuntu Linux

Como instalar o Google Chrome no Slackware 13.37

Compiz instalado e não funcional? Eis a solução!

Plugin Music para aMSN com XMMS e Amarok

  

Comentários
[1] Comentário enviado por pedropilla em 29/03/2012 - 16:31h

Obrigado amigo!


Os pacotes a seguir têm dependências desencontradas:
wine : Depende: libmpg123-0 (>= 1.6.2) mas não será instalado
Recomenda: ttf-symbol-replacement-wine mas não é instalável
Recomenda: ttf-droid mas não é instalável
Recomenda: winetricks mas não é instalável
E: Pacotes quebrados

[2] Comentário enviado por ch4c4r em 29/03/2012 - 19:09h

Olá, qual a sua versão do Debian? Ela é 32 ou 64 bits? Estranho porque realizei esse procedimento em uns 5 micros e, semana passada realizei no meu e agora ele está instalando direto a versão 1.4.
Aparenta ser algum problema com o apt-get...

Aguardo, abraços!

[3] Comentário enviado por ed-borges em 10/04/2012 - 00:21h

pedropilla, cara busquei instalar o libmpg123-0 mas vi que tinha dependência ,busquei ela o arquivo libltdl3 achei aqui http://planeta.linuxnanet.com/?p=2552 tentei instalar o wine com apt-get venho um monte de atualizações e pacotes dando entender que o arquivo era de virtualização mas o wine rodou no meu debian 6 32bits só não criou o icone deu esta mensagem " /var/lib/dpkg/info/wine.postinst: 56: start: not found" mas cliquei com o botão direito em cima do executável e rodou na buena :)
espero ter ajudado!!!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts