Utilizando o QEMU para instalar e testar distribuições

Publicado por João Henrique de Freitas em 04/07/2004

[ Hits: 13.048 ]

 


Utilizando o QEMU para instalar e testar distribuições



Olá!

Esta dica é para aquelas pessoas que necessitam testar distribuições novas. Estou utilizando o qemu para testar a versão 10 do Slackware da seguinte maneira: de alguma forma não consegui gravar os CDs de instalação, pois a imagem tinha mais de 700MB. Então recorri ao emulador.

Baixei o qemu em:
Instalei os binários e com a seguinte linha de comando criei um arquivo que será usado como "hd virtual":

# dd of=hd.img bs=1024 seek=200000 count=0

Depois iniciei a instalação:

# qemu -hda hd.img -cdrom slackware-10rc1.iso -boot d

A opção "-boot d" quer dizer que irei utilizar a imagem do Slackware como boot inicial.

E pronto, já estou testando a nova distribuição...

Por enquanto é só... O único problema é que fica lento, mas compensa.

at+
Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalando Etcher no Ubuntu 18.04 LTS

Bug na lista de ícones do lxappearance [Resolvido]

Instalação do Sublime no Fedora 31

Descompactando arquivos .RAR no Mandriva Linux 2006

Instalando o Cliente do Mega Cloud no Linux Mint 19

  

Comentários
[1] Comentário enviado por lordello em 06/07/2004 - 22:54h

Excelente esse qemu. Ele tem uma performance melhor se usado com o "User Mode Linux".
Para usuários Gentoo eu recomendo:

# emerge qemu usermode-sources

Tem uma versão do Linux-2.6, mas está bloqueada, para usar:
# mkdir /etc/portage
# echo "sys-kernel / usermode-sources" > /etc/portage/package.umask

[2] Comentário enviado por pinrusty em 08/07/2004 - 19:54h

como q se instala o qemu galera?
bah, nao tem nenhum arkivo de instalacao nos pacotes...

[3] Comentário enviado por pinrusty em 08/07/2004 - 23:21h

alias...
até tem arquivo de configuração, mas no momento que vou dar make, ele da error! =/
lá vai o erro:

-L/usr/lib -Wl,-rpath,/usr/lib -laa -lm -L/usr/X11R6/lib -lX11 -lgpm -lslang -lutil
/usr/lib/gcc-lib/i486-slackware-linux/3.3.4/../../../../i486-slackware-linux/bin/ld: cannot find -lasound
collect2: ld returned 1 exit status
make[1]: *** [qemu-fast] Error 1
make[1]: Leaving directory `/root/pin/qemu/i386'
make: *** [all] Error 1
[email protected]:~/pin/qemu#

[4] Comentário enviado por joaohfreitas em 08/07/2004 - 23:54h

Sobre a instalação do qemu:

Na página do qemu tem os binários já compilados, eu instalei por la.

Mas quando fui compilar os fontes, deu alguns problemas na biblioteca asound. (os descritos acima) e eu não consegui compilar. Alguem tem alguma sugestão?.
at+

[5] Comentário enviado por pinrusty em 08/07/2004 - 23:59h

agora surge mais uma duvida:
como q eu instalo um binário?

[6] Comentário enviado por pinrusty em 09/07/2004 - 10:08h

blz, consegui instalar, agora como q eu rodo o qemu com boot pelo drive de cd (sem ser por imagem) e tb pq está dando um erro tipo:

Serial port redirected to /dev/pts/3

:D

[7] Comentário enviado por joaohfreitas em 09/07/2004 - 23:59h

Bom, de acordo com o site do qemu. Ele não suporta acesso direto ao dispositivos tais como fd0 e cdrom. Mas pode trocar de imagem como se fosse trocar de cdrom. Basta ver no manual do qemu la tem algumas explicações sobre a troca de imagens em quanto o qemu esta rodando.


[8] Comentário enviado por anunakin em 19/07/2004 - 16:59h

Cara como habilita a placa de rede NE2000 do qemu?

[9] Comentário enviado por joaohfreitas em 21/07/2004 - 11:11h

Olá

Pelos testes que andei fazendo vc deve habilitar o modulo tun/tap

É necessário verificar tb se um script de configuração de rede esta em /etc/

Vou verificar melhor essas informações. Eu ja consegui fazer funcionar antes.

Mas no site do qemu tem estas informações

[10] Comentário enviado por Iron Fist em 07/10/2005 - 09:05h

O qemu funciona belezinha na minha maquina, com algumas virgulas claro...
Por exemplo..
Eu testei o kurumin como a linha abaixo:
# qemu -hda hd.img -cdrom kurumin5.0.iso -boot d
mas ele só aceita dar boot se eu fizer isso:
# qemu -cdrom>hd.img kurumin5.0.iso -boot d
Não to entendendo... criei o arquivo de imagem do hd. Mas nao to entendendo.. Detalhe.. tem uma outra coisa.. quando eu entro no kde do kurumin, ele da "crash", isto é, não responde mais.. o Sistema Operacional Emulado continua mexendo e tudo... mas ele nao carrega mais nada.. o que será?
*Detalhe.. Fiquei interessado em fazer a mesma coisa com o rWindows XP, só pra ver a [email protected]
Se Alguem puder me ajudar....



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts