Ubuntu não Loga Após Instalação de Driver Nvidia [Resolvido]

Publicado por Izaias em 24/04/2020

[ Hits: 695 ]

 


Ubuntu não Loga Após Instalação de Driver Nvidia [Resolvido]



Este problema já vinha ocorrendo desde o Ubuntu 19.04, mas até então não tinha encontrado solução que resolvesse.

E só agora, depois de instalar o Ubuntu 20.04 (que está ótimo!) descobri a solução. Solução esta, justamente encontrada para a versão 19.10, no único site que me ajudou de fato. Refinando minha busca, achei a solução:
The problem was with GDM display manager and the Nvidia driver, seems they still do not play well together even in 19.10. I wasn't able to determine the root cause of the problem, however what worked for me was to install lightdm and change the grub command line on startup.

O Ask Ubuntu sempre me salvando!

Há 02 caminhos, um logado ou iniciado (Passo 1) e outro na tela de login (Passo 2). Ambos os passos seguem o mesmo caminho da solução, a diferença é estar logado ou não.

Passo 1

Mesmo não conseguindo logar na tela de login, eu conseguia iniciar o sistema, porque optei por inicialização direta durante minha instalação. Eis:
  1. Durante o boot, na tela do GRUB, sete para iniciar: Recovery Mode
  2. Irá abrir uma tela com diversas opções
  3. Marque a opção: Inicialização Normal
  4. Tecle: Enter

Pronto! O sistema será iniciado diretamente.

NOTA: geralmente, quem tem apenas um sistema instalado nem aparece a tela do GRUB. Após dar boot, vá teclando Esc que a tela do GRUB iniciará.

Passo 2

Para resolver o problema na tela de login, abra o terminal em modo texto: Ctrl+Alt+F2

A partir de agora, a solução é semelhante para ambos os casos acima.

Solução

Vamos editar o arquivo /etc/default/grub. No terminal:

sudo nano /etc/default/grub   (caso esteja na tela de login)
ou:
sudo gedit /etc/default/grub   (caso esteja com o sistema iniciado)

Na linha: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Mude para:

GRUB_CMDLINE_LINUX_DEFAULT="nomodset"

Salve (Ctrl+x), então tecle y e feche (Ctrl+o) caso esteja no nano. Atualize o GRUB:

sudo update-grub

Reinicie:

sudo reboot

E pronto! Veja seu sistema iniciando, com a tela de login (agora normal, pronta para logar) ou no meu caso, com o sistema iniciando direto.
Linux: Ubuntu não Loga Após Instalação de Driver Nvidia [Resolvido]
Viva o Linux!

Outras dicas deste autor

Removendo PPAs graficamante no Ubuntu

TimeShift no Debian 9

Iceweasel - Versão atual no CrunchBang

Chromium no Fedora 15

Removendo Kernels antigos do openSUSE

Leitura recomendada

Executar shutdown com usuário comum em 5 etapas

Wi-Fi no Dell Inspiron N4030 - Configuração no Debian 7

Ubuntu + Windows 8 como dual boot

Configurações de cores do LILO

Criando a imagem dos CDs de instalação no HD

  

Comentários
[1] Comentário enviado por lucasewe em 30/05/2020 - 10:09h

o meu também ocorreu o mesmo problema, no caso, o culpado era a Área de trabalho remota do chrome.
quem estiver com o mesmo problema após a instalação dela segue aqui abaixo a solução.
a única que funcionou pra mim
https://www.youtube.com/watch?v=sG6HmGDMWZU



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts