Ubuntu Feisty Fawn - Cannot Eject Volume

Publicado por Perfil removido em 23/07/2007

[ Hits: 5.267 ]

 


Ubuntu Feisty Fawn - Cannot Eject Volume



Usuários do Ubuntu Feisty Fawn que possuem HDs externos devem ter percebido que só é possível desmontar o dispositivo pelo terminal, uma vez que ao clicar em eject o sistema apresenta o seguinte erro:

Cannot Eject Volume

Para acabar com esse erro basta editar o seguinte arquivo com seu editor de preferência:

$ sudo vim /usr/share/hal/fdi/policy/10osvendor/10-storage-policy.fdi

E alterar a seguinte linha:

<match key="info.category" string="storage">
      <match key="storage.bus" string="usb">
        <merge key="storage.requires_eject" type="bool">true</merge>

No lugar de true, deve ficar false.

Com essa simples troca de palavra você poderá remover normalmente seus dispositivos externos.

Fabiano "Metralha" Fidêncio

Outras dicas deste autor

CentOS 5 - Desabilitando serviços desnecessários

LibreOffice 3.5.3 - Instalação no CentOS 6.x

Firefox: indo além do "about:config"

Etapas do desenvolvimento do kernel

Bootsplash em kernel "não oficial" 2.6.X no Slackware

Leitura recomendada

Bug no Wayland do Fedora 25

Informação do Tempo – Um benchmark no Desktop do elementary OS

Teclas de função no Xfce para comandar o volume

Configuração do sudoers no Linux Debian 4

Boot no openSUSE Tumbleweed demorando demais: erro "A start job is running for Wait for chrony to synchronize system clock" [Resolvido]

  

Comentários
[1] Comentário enviado por mslackv em 16/09/2007 - 00:33h

Valeu pela dica,


Lembrando que essa dica vale para câmeras digitais também (que dá a seguinte mensagem de erro "não foi possível desmontar o volume")!!!!

Toda vez tinha de desligá-la ou desligar o micro se quisesse removê-la com segurança (será que isso não é um bug do ubunutu?).

[2] Comentário enviado por removido em 16/09/2007 - 00:41h

mslackv, mais uma vez nos encontramos. =).

Bom. Acredito eu que seja um bug sim. E acredito também que já tenha sido reportado (muita gente estava reclamando disso). Espero que na 7.10 isso já esteja corrigido.

Bom saber que funciona também com outros dispositivos.

[]'s.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts