Ubuntu 10.04 + Postgresql 8.4 + PgAdmin III- Instalação para iniciantes

Publicado por Marcelo Mota em 24/05/2011

[ Hits: 21.459 ]

 


Ubuntu 10.04 + Postgresql 8.4 + PgAdmin III- Instalação para iniciantes





Instalei o Postgre seguindo algumas dicas aqui no VOL e não consegui acessar o banco de dados. Após várias buscas na Internet sobre a instalação e configuração inicial do Postgresql 8.4 no Lucid, não encontrei nenhuma mais atual que resolvesse o problema. Na verdade só não busquei justamente na fonte principal: o help da comunidade Ubuntu:
Então, resumidamente, os únicos passos necessários para instalação (versão 9.10 acima):

Instalação:

(Pgadmin => interface para administração do Postgresql)

sudo apt-get install postgresql pgadmin3

Alterar a senha do usuario postgres no Banco (senão não conseguirá logar):

sudo -u postgres psql postgres

Digite e confirme a nova senha no prompt que aparecerá após o seguinte comando (não esqueça da barra invertida):

\password postgres

Pronto, já pode conectar ao banco pelo PgAdmin, para uso local.

Bom, esse é o processo inicial. Á medida que for usando vou atualizando essa dica caso necessário (conexão remota, via código, etc...).

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

MicroOLAP - Ferramenta para modelagem em PostgreSQL

PostgreSQL - Bancos com diferentes encodings

Alterando senha inicial do PostgreSQL [Ubuntu]

Modelagem de bancos de dados

Novo site sobre PostgreSQL

  

Comentários
[1] Comentário enviado por afonsosilva em 21/04/2015 - 12:26h

Muito obrigado man isso ajudou muito.

[2] Comentário enviado por gabrielmulle em 01/03/2017 - 00:50h

Uma dúvida, quando tento instalar o pgadmin aparece este erro, alguem sabe como devo prosseguir?
Quando tento instalar também pelo "Software" (gerenciador visual) também não consigo.

sudo apt-get install pgadmin3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pgadmin3 : Depends: libwxbase3.0-0 (>= 3.0.0) but it is not installable
Depends: libwxgtk3.0-0 (>= 3.0.0) but it is not installable
Recommends: pgagent but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Contribuir com comentário