Teclado ABNT2 definitivo no Archlinux

Publicado por Sinésio Neto em 27/08/2011

[ Hits: 72.758 ]

Blog: http://euresumo.wordpress.com

 


Teclado ABNT2 definitivo no Archlinux



Acredito, que assim como eu, aqueles iniciantes que desejam conhecer o Archlinux terão um pouco de dificuldade tanto na instalação como na configuração do mesmo.

E é com intuito de colaborar, facilitando a adaptação à essa bela distro, que crio essa dica, simples mas objetiva.

Assim que instalei pela primeira vez o Archlinux, tive dificuldade de manter o teclado abnt2 definitivo, iniciar o sistema com essa configuração. Encontrei várias soluções, mas nem uma delas me atendeu 100 por cento.

Até que cheguei a essas soluções:

1. Digitar no terminal o comando:

sudo setxkbmap -model abnt2 -layout br -variant abnt2

Mas ela só funciona quando o sistema já esta rodando, e não era o que queria, pois se torna muito cansativo digitar esse comando toda vez que inicio o sistema.

Então vamos a segunda solução.

2. Editar o arquivo /etc/X11/xorg.conf.d/10-evdev.conf, faça:

sudo nano /etc/X11/xorg.conf.d/10-evdev.conf

Acrescente a Seção:

Section “InputClass”
    Identifier “evdev keyboard catchall”
    MatchIsKeyboard “on”
    MatchDevicePath “/dev/input/event*”
    Driver “evdev”
    Option “XkbLayout” “br”
    Option “XkbVariant” “abnt2"
EndSection

Reinicie o sistema

sudo reboot

E pronto. Terá agora seu teclado abnt2 definitivo no Archlinux. ;)

Então, Até a próxima!

Outras dicas deste autor

Instalando Firefox e Flash Player no Debian Lenny

Leitura recomendada

OpenJDK7 64 bits e Banco do Brasil [RESOLVIDO]

Man Pages Coloridas no Debian 6

Instalador Gráfico da ATI

Debian: Erro - Thunar não monta dispositivos com usuário normal após atualização [Resolvido]

Melhorando o Auto Completar dos comandos no Terminal

  

Comentários
[1] Comentário enviado por removido em 27/08/2011 - 08:45h

@sinesioneto,

beleza cara? uso essa opção do setxkbmap diretamente no meu .bashrc (em Debian, Arch e Gentoo) e funciona corretamente sem que eu precise digitar toda vez que inicio meu sistema, porém a sua solução além de mais elegante é mais correta.

valeu! + favoritos.

[2] Comentário enviado por albfneto em 27/08/2011 - 17:19h

essa dica, isso funciona em outras distros também...

[3] Comentário enviado por pliniomatos em 27/08/2011 - 18:07h

Muito bom! Também tive problemas a um tempo atrás (quando abandonei o Mandriva e me apaixonei pelo ArchLinux) - acho que em 2009, mais nada que alguns "tutos da net" não resolvessem! Até que encontrei o LXDE!!! Resumindo, depois de apanhar muito, fiz esse post para ajudar quem tava começando: http://nadahadeclarar.blogspot.com/2011/07/arch-linux-lxde-very-nice.html

[4] Comentário enviado por warlocksn em 28/08/2011 - 12:32h

@edps
tranquilo? ;)
no caso do .bashrc, eu já usei assim, mas pra isso eu precisava iniciar o terminal pra que o comando executasse... dai eu queria uma coisa mais automática, saca?!

e agradeço pelo comentário! vlw

@albfneto
bom saber disso. como eu não conheço outras distros((alem do Debian)ainda), é bom saber, aprendo mais um pouco tbm... hehe

@pliniomatos

Cara, eu enviei essa dica tem algum tempo já, mas só agora ela foi aprovada... mas assim que eu decide migrar pra o LXDE(a três dias atras) eu encontrei esse teu site com esse post e achei muito bom!
parabens!

[5] Comentário enviado por elibotafoguense em 23/03/2014 - 16:38h

Parabens pela dica cara, foi muito util!

[6] Comentário enviado por edvaldoscruz em 11/09/2014 - 14:38h

Indico esse tópico que funciona 100% nesse link: http://ubuntuforum-br.org/index.php?topic=106170.0

[7] Comentário enviado por draggom em 17/03/2016 - 08:28h

Usei essa dica no manjaro xfce e não conseguia iniciar o meu ambiente gráfico, assim que deletei a mensagem no arquivo indicado o sistema voltou ao normal.

[8] Comentário enviado por jcavalcantef em 21/03/2016 - 11:43h

LXDM nao inicia apos copiar e colar o texto acima no arquivo 10-evdev.conf =Z

[9] Comentário enviado por lustful999 em 17/09/2016 - 00:18h

ola infelismente ao modificar o arquivo nano /etc/X11/xorg.conf.d/10-evdev.conf meus sistemas graficos pararam de funcionar so conseguindo logar no gnome wayland... entao tive que excluir o nano /etc/X11/xorg.conf.d/10-evdev.conf para voltar a funcionar... alguem tem uma solucao definitiva para o teclado?

[10] Comentário enviado por Don_Luigi em 31/07/2018 - 23:35h

Então galera, foi mal reviver o tópico, mas para a galera que ta tendo problema com a interface gráfica parando de funcionar depois de alterar o arquivo, eu percebi uma coisa aqui e pode ser o problema.

Se você só copiar o texto ali da seção, colar no seu 10-evdev.conf e salvar, vai dar problema porque as aspas do texto aqui no fórum não estão coerentes. Bastou trocar todas as aspas do formato “ para o formato ". A última aspas utilizada é a correta. Bastou fazer isso aqui e a solução funcionou elegantemente bem. Obrigado pela dica!

[11] Comentário enviado por andrelinuxaju em 07/09/2019 - 10:38h

https://www.vivaolinux.com.br/topico/ArchLinux/Nao-consigo-deixar-o-meu-teclado-pt-br-abnt2-no-Arch

sou iniciante no mundo Linux e tenho o Arch Linux 64 bits rodando no virtualbox com Kde instalado, apesar de durante a instalação ter configurado o teclado br-abnt2 quando logava o teclado estava no padrão inglês. Rodei esse comando num terminal como root e funcionou muito bem. Após reboot estava tudo certinho. A dica do SmithuX foi sensacional.



Contribuir com comentário