Squid: No running copy

Publicado por em 21/05/2007

[ Hits: 9.209 ]

 


Squid: No running copy



Estava com um problema no proxy Squid, consegui resolver e agora quero compartilhar esta solução com vocês.

Para resolver de vez o problema de "no running copy", faça o seguinte, delete o arquivo /var/spool/squid/swap.state, pois este arquivo fica truncado.

Pronto, agora é só reiniciar seu Squid.

Espero que esta dica seja útil para todos!

Outras dicas deste autor

Clarkconnect - Gerencie seu servidor Linux pela web

Leitura recomendada

Resolvendo dependências do Kazaa

Redirecionamento de portas para VNC (Coyote Linux)

Proxy Autenticado - Atualização automática do Microsoft Security Essentials e Windows Update

Quatro boas skins para seu aMSN

Liberar Nota Fiscal Eletrônica (NFe) em ambientes de rede com o Squid3 como proxy

  

Comentários
[1] Comentário enviado por lare em 13/04/2009 - 12:24h

ante de apagar tambem apaque logs
1 - Abra o diretório abaixo:

# cd /var/log/squid/

2 - Remova todos os arquivos do diretório "logs" (cache.log, access.log, etc):

# rm *

3 - Execute o proxy:

# squid

Só isso. Depois disso seu proxy estará no ar novamente.

[2] Comentário enviado por joseslei em 11/09/2009 - 00:30h

Otima dica. Acabei de resolver esse problema em meu servidor. Excluir o arquivo swap.state e dei o comando squid -z, depois /etc/init.d/squid restart




Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts