Screen Tearing (outra vez)

Publicado por Andre (pinduvoz) em 03/05/2020

[ Hits: 1.828 ]

Blog: http://casadopinduvoz.wordpress.com/

 


Screen Tearing (outra vez)



Se você não sabe do que trata esta dica, veja uma outra dica minha, escrita pensando em gerenciadores leves de janelas, para descobrir: Screen Tearing [Resolvido] [Dica]

Agora, se você usa XFCE ou Mate e ainda assim sofre com "screen tearing" no seu notebook com vídeo Intel, nesta dica pode estar a solução, pois funcionou para mim.

Crie uma nova configuração para sua placa de vídeo Intel, o que pode ser feito por um único comando no terminal, a saber:

echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | tee ~/20-intel.conf

Agora confira o arquivo criado, que deve estar na sua pasta de usuário e assim escrito:

cat ~/20-intel.conf

Section "Device"
Identifier "Intel Graphics"
Driver "Intel"
Option "AccelMethod" "sna"
Option "TearFree" "true"
EndSection

Se estiver tudo certo, copie o arquivo criado para o lugar onde ele precisa estar:

sudo cp 20-intel.conf /etc/X11/xorg.conf.d/

É óbvio que se você não tiver o sudo configurado, deve usar o root.

Talvez você precise criar o diretório ou pasta "xorg.conf.d" antes de copiar, assim:

sudo mkdir /etc/X11/xorg.conf.d/

Reinicie e teste.

Em caso de perda do vídeo ao reiniciar (hipótese remota), apague o novo arquivo de configuração após logar em texto, assim:

sudo rm /etc/X11/xorg.conf.d/20-intel.conf

Então você poderá começar de novo, caso tenha errado ao seguir esta dica, ou partir para outra solução se fez tudo certo e ainda assim não funcionou.

Até a próxima.

Outras dicas deste autor

Fundo dos ícones na bandeja do Ubuntu (GNOME 2)

Recoll e de brinde dois ícones Faenza

Configurando o "Audio Preview" do Nautilus no Debian 5.0 (Lenny)

Bug de áudio - Pulseaudio [Resolvido]

KDE 4.10 no openSUSE 12.2

Leitura recomendada

Acelerando o APT!

NTP prático com Linux, Windows 2000 e 2003

Correções em mod_ssl RSA blinding

Como usar o i3 como gerenciador de janelas no KDE plasma

Erro /usr/bin/net-snmp-config: net-snmp-create-v3-user: not found [Resolvido]

  

Comentários
[1] Comentário enviado por pylm em 03/05/2020 - 20:00h

Não precisa do tee ali.

echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' > ~/20-intel.conf

Faz exatamente a mesma coisa.

[2] Comentário enviado por myqueyas em 30/11/2020 - 19:40h

Fala, André!

Tudo bem?

Saberia me dizer se este meu caso é as mesma coisa tratada neste tópico?
https://www.vivaolinux.com.br/topico/UbuntuBR/Erro-grafico-Ubuntu-20041


[3] Comentário enviado por pinduvoz em 30/11/2020 - 20:19h


[2] Comentário enviado por myqueyas em 30/11/2020 - 19:40h

Fala, André!

Tudo bem?

Saberia me dizer se este meu caso é as mesma coisa tratada neste tópico?
https://www.vivaolinux.com.br/topico/UbuntuBR/Erro-grafico-Ubuntu-20041




Não é a mesma coisa e não vai resolver seu caso.

[4] Comentário enviado por myqueyas em 09/12/2020 - 10:31h


[3] Comentário enviado por pinduvoz em 30/11/2020 - 20:19h


[2] Comentário enviado por myqueyas em 30/11/2020 - 19:40h

Fala, André!

Tudo bem?

Saberia me dizer se este meu caso é as mesma coisa tratada neste tópico?
https://www.vivaolinux.com.br/topico/UbuntuBR/Erro-grafico-Ubuntu-20041




Não é a mesma coisa e não vai resolver seu caso.


Opa!
Vlw pelo retorno.

Teria alguma solução para este caso? Ou algum outra coisa que possa guiar melhor minha busca por soluções?





Contribuir com comentário