Samba bugado no Zenwalk?

Publicado por Xerxes em 04/05/2009

[ Hits: 5.351 ]

Blog: https://notabug.org/xerxeslins/dicasgnulinux

 


Samba bugado no Zenwalk?



Obs.: Dica para usuários do Zenwalk 6.0.

Zenwalk Linux 6.0 saiu a pouco tempo. Como muitos sabem, é uma ótima distro, uma das minhas prediletas. Gosto do XFCE que é o ambiente padrão do Zenwalk (embora exista a versão Zenwalk GNOME). Ele vem com OpenOffice, Compiz (nos seus repositórios) e apenas uma aplicação para cada tarefa. É leve e bonita!

Infelizmente nenhuma distro é perfeita (ou nem todos os pacotes são). Há algo errado no pacote do Samba dos repositórios do Zenwalk. Esse problema eu percebi também no Arch Linux.

Após configurar o Samba corretamente, o mesmo não funciona de forma perfeita e apresenta os seguintes problemas:

1 - o usuário não consegue montar os shares das máquinas Windows, embora possa enxergar os servidores.

2 - o usuário não consegue usar a impressora compartilhada por uma máquina Windows.

3 - Lentidão para listar os shares, quando lista.

Quebrei a cabeça achando que havia erro nas minhas configurações. Não entendia porque a impressora não estava funcionando, se a configuração era a mesma utilizada com sucesso no Slackware.

Ao montar os shares do Windows, sem motivo aparente, a conexão era perdia e apresentava a mensagem:

Thunar: Failed to connect to the D-BUS session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

ou então:

ls: impossível abrir a pasta .: Ponto final de transporte não está conectado

Apesar do sistema apresentar essas mensagens, em um momento anterior o Samba estava funcionando, mesmo que lentamente. Na verdade desconheço o motivo desse problema... (caso alguém saiba, por favor comente) inclusive, quando estava no Arch Linux, tive que abandonar o Fusesmbtool e utilizar o Gigolo para montar shares, como pode ser visto aqui:
pois o Fusesmbtool não funcionava mais.

Quando instalei o Zenwalk 6.0, para minha surpresa ele já não tinha mais o Fusesmbtool para montar shares (como nas versões anteriores do Zenwalk), mas tinha o Gigolo! Ou seja, provavelmente o problema com o Fusesmb era conhecido.

Resumindo o problema: no Zenwalk, após atualizar o sistema eu não conseguia mais montar os shares do Windows nem com o Gigolo, nem com o fuse e nem conseguia imprimir.

Solução: inseri o DVD do Slackware e instalei o pacote do Samba dele - já que todos os pacotes do Slackware são compatíveis com o Zenwalk. Reiniciei o sistema e na primeira tentativa consegui imprimir a página de teste do CUPS (que alegria!). Tentei montar os shares com o fuse, mas não tive sucesso. Porém, com o Gigolo funcionou!

Caso esteja passando pelo problema descrito nessa dica, instale o Samba do Slackware no seu Zenwalk ao invés de baixar pelo gerenciador de pacotes. Caso não tenha o DVD do Slackware, baixe o Samba pelo seguinte link:

http://mirrors.unixsol.org/slackware/slackware-12.2/slackware/n/samba-3.2.5-i486-1.tgz

Boa sorte.

Outras dicas deste autor

Deepin Linux - A nova queridinha do momento

Lançado live-cd baseado em Funtoo e em SystemRescue

Aumentando a performance do Compiz

Fresh Player no Ubuntu (Pepper Flash)

Fedora com MATE e Compiz (Spin ou não)

Leitura recomendada

MPlayer - Como utilizar sem bloquear o prompt

Comunidade sidux Linux

Palestra sobre gerenciamento de memória virtual no kernel linux

XV SEMAC - UNESP / São José do Rio Preto-SP

Comando sudo com comentários malcriados

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário