SARG: (html11) - Errinho chato

Publicado por Aldemir Lima em 27/05/2007

[ Hits: 7.955 ]

 


SARG: (html11) - Errinho chato



Olá turma.

Tive um problema quando montei um novo servidor Debian Etch e usei o mesmo arquivo de configuração do SARG.

O erro é o seguinte:

SARG: (html11) Erro no open do arquivo: /var/www/squid-reports/11May2007-11May2007/users

Li até que deveria fazer um downgrade da minha versão do SARG < pois a que eu estaria usando estava com um bug (algo que achei pouco provável).

Bom, resolvi esse problema da seguinte forma:

Edite o arquivo de configuração do SARG (sarg.conf), no caso da Debian: /etc/squid/sarg.conf

Vá até a tag "report_type" e inclua depois de topsites a opção topusers.

A tag original deve estar assim:

report_type topsites sites_users users_sites date_time denied auth_fail
ures site_user_time_date

Mude ela para:

report_type topsites topusers sites_users users_sites date_time denied auth_fail
ures site_user_time_date

Não sou expert em Linux, mas o que pude perceber é que ele gera os relatórios do SARG e esse topusers é o index pra users_sites, então como não está habilitado pra gerar esse HTMLs dá este erro.

Espero ter ajudado e claro, não posso esquecer de agradecer ao amigo vul4, seja lá quem ele for.

Abraço a todos.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Relatório do SARG com o access.log do Dansguardian

Removendo Kernels Antigos do Fedora 33 via Interface Gráfica

Montando Android no Debian automaticamente

Configurando o Samba - howto

Filmes do Linux no XBox

  

Comentários
[1] Comentário enviado por removido em 27/05/2007 - 09:28h

Já tive esse problema. Achei bastante estranho, mas eu resolvi quando e editei o arquivo sarg.conf e comentei a linha:

#output_email [email protected]


[2] Comentário enviado por cenourazul em 27/06/2007 - 18:53h

Literalmente essa dica de acrescentar o "topusers" na linha de report_type funciona...
O sarg estah rodando direitinhooo..

Obrigadoo...

[3] Comentário enviado por rjdiniz em 29/11/2007 - 13:36h

Valeu "Corujito", dica de muita valia... resolveu minha vida pois estava precisando de gerar os relatórios de acesso a internet... e ja não sabia mais como fazer só dava erro...

Raul Júnior (rjdiniz)

[4] Comentário enviado por foster em 11/08/2008 - 13:11h

Muito bom me ajudou pracaramba..... valeu

[5] Comentário enviado por keke em 14/03/2009 - 22:50h

Cara muito bom esse seu comentário, eu tava procurando exatamente sobre esse problema.
Não está dando mais o erro, eu executo o comando sarg, mas quando vou acessar os relatórios não parecem nada, nenhum arquivo, nada em Daily, nada em weekly e nada em Montly.
É assim mesmo, tem que esperar completar o período para ele gerar os arquivos.
Grato,

[6] Comentário enviado por nariz em 04/06/2009 - 09:23h

perfeito amigo !
eu estava com o mesmo problema aqui, e no meu sarg ja havia uma tag comentada com essas opcoes...
só tirei o comentario da linha e comentei a linha errada

[7] Comentário enviado por deuz em 25/05/2010 - 11:58h

Olá amigos, meu problema é semelhante ao vosso, porem na linha que indicou, topusers, ja tem no meu arquivo sarg.conf, e o erro continua, alguem tem mais alguma dica?

grato..



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts