Resolvendo problema com audio no Debian - placa Intel Corporation 82801I

Publicado por Leonardo Damasceno em 15/04/2010

[ Hits: 33.163 ]

Blog: https://techcraic.wordpress.com

 


Resolvendo problema com audio no Debian - placa Intel Corporation 82801I



Bem, hoje quando liguei o notebook o meu som não funcionou. Não tive tempo de verificar os logs, porém dei uma pesquisada rápida na internet sobre problemas semelhantes e especifiquei a minha placa, que é uma Intel Corporation 82801I (ICH9 Family).

Para descobrir qual é a sua placa de rede, utilize o comando lspci, que irá listar os dispositivos PCI da sua máquina, por exemplo:

# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Para resolver o meu "pequeno" problema e voltar a ouvir minhas músicas, editei o arquivo /etc/modprobe.d/alsa-base.conf, adicionando a seguinte linha:

options snd-hda-intel enable_msi=1

Agora dê um reload no Alsa da seguinte maneira:

# alsa reload

Boa sorte. :)

Outras dicas deste autor

Resolvendo o erro: Sub-processo gzip retornou um código de erro (1)

Instalando o Snort no Debian

Modificando o seu localtime

Visualizando mensagem da fila do Postfix

Instalando o OCS Inventory

Leitura recomendada

Monitorando o uso de processador de servidores (locais e remotos) com o Nagios + NRPE

Unity 3D: ícones na "área de notificação"

XMacro - Gravando e reproduzindo ações do teclado/mouse

Abrindo o Xterm no IceWM em qualquer tamanho e lugar

Corrigindo o bug de maximizar vídeos do Youtube no Firefox 3

  

Comentários
[1] Comentário enviado por quartodazona em 07/11/2010 - 16:41h

Olá amigo.
Eu tenho um notebook (PHN 14-A-P223WS da Philco) com a mesma placa de som e também uso Debian 5 Lenny, atualizado e acontece a mesma coisa. Minha placa de som é reconhecida normalmente no sistema. Já entrei no alsa.conf, entre outras mil coisas e fiz isso que você falou, mas continuo sem som. Percebi na net que várias pessoas fizeram o procedimento que você falou e funcionou para elas, mas no meu caso só consegui fazer funcionar após colocar no meu sources.list o seguinte repositório do Debian Packges: deb http://ftp.de.debian.org/debian squeeze main . Então, depois de editar o arquivo, dei um apt-get update e ele me trouxe 527 pacotes para atualizar. Isso mesmo, fiquei 2 horas e meia fazendo download e ele atualizou praticamente todo meu sistema operacional, pois instalou o Kernel 2.6.32-5-686. Vale a pena para quem quer o Debian bem atualizado.

[2] Comentário enviado por ghost-rid3r em 22/02/2011 - 20:28h

Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)


SOLUÇÃO:

Rode um lspci no terminal para certificar que o hardware:

#lspci

Depois faça:

#cat /proc/asound/card0/codec#* | grep Codec

Codec: Realtek ID 270
Codec: Intel G45 DEVCTG

Observe o Realtek ID 270. Isso significa que é um codec desconhecido, pois o ideal seria algo do tipo Realtek ALCxxx (Realtek ALC260, por exemplo).
Faça:

#apt-get install apt-build build-essential module-assistant linux-headers-2.6


#m-a prepare

#m-a update

Vai abrir o module assistant. Dentro dele, especifique para compilar e instalar o alsa-base (é só ir em SELECT, ALSA, BUILD e depois INSTALL).

#gedit /etc/modprobe.d/alsa-base.conf

Nessa linha ao final dela add o seguinte:

options snd-hda-intel enable_msi=1

Salve o arquivo, reinicie o computador e veja se deu certo.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts