Resolvendo o problema do "erro ao carregar BASIC" no OpenOffice.org no Linux

Publicado por Perfil removido em 06/08/2010

[ Hits: 8.544 ]

 


Resolvendo o problema do "erro ao carregar BASIC" no OpenOffice.org no Linux



Esse é um probleminha a princípio bobo, mas que pode ter outras consequências um pouco mais desagradáveis, que vão de simples mensagens de erro incomodando na inicialização até a impossibilidade de executar scripts ou mesmo de salvar seus documentos no OpenOffice.org, ou seja, perder todo o seu trabalho.

Pesquisando sobre o erro notei que vários usuários mais desavisados vêm sofrendo com isso desde os tempos das versões 1.x, tanto no Windows (desculpe pelo "palavrão") como no Linux, mas este erro a princípio não é culpa da do OpenOffice.org, mas sim do usuário que deliberadamente, ou sem prestar atenção, excluiu os arquivos de configuração do OpenOffice.org - foi o que eu fiz, uso a versão 3.2 e tudo sempre funcionou muito bem, mas na nóia por limpar meu espaço em disco de arquivos desnecessários, usei o KleanSweep e mandei um monte de arquivos pras "cucuias", inclusive muita coisa que eu não deveria apagar, até mesmo meu Projeto SolBT (sorte que os fontes estão no meu SVN do SourceForge).

Eis o erro, na hora que eu abria qualquer aplicativo da suíte OpenOffice.org recebia duas mensagens como esta, o que já estava me incomodando muito:
Linux: Resolvendo o problema do 'erro ao carregar BASIC' no OpenOffice no Linux
A primeira reclamava do "erro ao tentar carregar o BASIC do documento" apontando o arquivo "dialog.xlc" como causa, e a que aparecia logo em seguida reclamava do mesmo erro, só que com o arquivo "dialog.xli" - e é claro que iria dar falha geral, pois estes arquivos foram apagados.

Bem, nas minhas pesquisas eu não encontrei a solução direta em nenhum fórum, até que uma luz celestial me iluminou, eu juntei as pecinhas, pesquisei pelos referidos arquivos no meu sistema, fui até o diretório "/usr/lib/openoffice/basis3.2/share/basic/" e lá encontrei um arquivo "dialog.xlc" do qual eu tanto precisava.

Achei só o primeiro arquivo mesmo, e resolvi copiá-lo pra pasta onde deveriam estar meus arquivos de configuração do OpenOffice na minha pasta de usuário em "~/.openoffice.org/3/user/basic/" e pronto, tudo voltou ao normal, fiz meus testes, tudo está funcionando - e creio que este método também serve em caso de perda de outros arquivos de configuração, digo isso comparando a falta de outros arquivos nas mesmas pastas conforme os relatos de outros usuário, e já que vários arquivos colocados na pasta pessoal de configuração são cópias do que está nessa pasta principal, deve funcionar.

Original em:
Outras dicas deste autor

Firefox + Thunderbird: FireMonger

Alterando o wallpaper rapidamente no Kurumin

Ubuntu 6.06 LTS - Problemas com resolução de tela e mouse

Instalando o novo GNS3 no Linux

Recuperando ISOs corrompidas com torrent

Leitura recomendada

OpenOffice 3: Instalando o corretor ortográfico e gramatical

Instalando e/ou atualizando o BrOffice no Debian Linux e derivados

Como abrir arquivos .docx, .xlsx, .pptx no OpenOffice ou BROffice

OpenOffice - Salvando figuras em textos da web

OpenOffice.org - copiar e colar texto e imagem da internet

  

Comentários
[1] Comentário enviado por jairus em 24/10/2011 - 11:59h

Bom dia !!!


Usei a dica e deu certo.

Parabéns !!!


Jairus Lopes
Rio de Janeiro

[2] Comentário enviado por xandecavalcante em 09/05/2014 - 19:36h

4 anos após ter sido postada, a solução ainda funciona perfeitamente. Obrigado, Pedro.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts