Resolvendo bug do Flash Player 10 no Mozilla

Publicado por andre uebe em 02/03/2009

[ Hits: 11.681 ]

Blog: http://resa.net.br

 


Resolvendo bug do Flash Player 10 no Mozilla



Recentemente tive que reinstalar o sistema (Ubuntu 8.04) e, como de costume, executei o comando:

sudo apt-get install flashplugin-nonfree

para instalar o Flash Player. A questão é que a versão que foi instalada é a 10 (atualmente lançada) que, simplesmente, não funciona no Mozilla. O problema é que ao tentar executar qualquer mídia no Mozilla, é retornado que o plugin flash não está instalado e, ao tentar instalá-lo, avisa que está instalado!?!

Ou seja, a versão flash player 10 não funciona corretamente e não deve ser instalada via apt-get, pois será instalada a versão 10. Portanto, vamos à solução.

1) Assegure-se de desinstalar quaisquer plugins de flash possivelmente instalados, executando no terminal (Aplicações --> Acessórios --> Terminal, no Gnome):

sudo apt-get remove --purge flashplugin-nonfree swfdec-mozilla libflash-mozplugin gnash

2) A seguir baixe a VERSÃO 09 do Flash Player, disponível em (existem outros locais disponíveis, este é apenas um dos espelhos):

http://www.filewatcher.com/m/install_flash_player_9_linux.tar.gz.2608602.0.0.html

ou diretamente através do terminal:

wget ftp://ftp.urc.ac.ru/pub/OS/FreeBSD/distfiles/flashplugin/9.0r48/install_flash_player_9_linux.tar.gz

3) Descompacte o arquivo:

tar -xvz /install_flash_player_9_linux.tar.gz

4) Entre no diretório criado:

cd install_flash_player_9_linux

5) Feche todos os navegadores (browser) de internet.

6) Execute o instalador:

./flashplayer-installer

7) Confirme os passos e, pronto!

Assista suas mídias em flash sem problemas!

Outras dicas deste autor

Árvore genealógica - Gramps e Genoom

Criando fotos com efeito "Olho-de-Peixe" no GIMP

Distro de música - Projeto Musix - Execute MIDI sem dor de cabeça

Código Fonte do Tribal Trouble liberado

Cinerella - Pacote deb para edição de vídeo

Leitura recomendada

Torne-se um DJ - TerminatorX

Ktoon, anima em 2D e exporta para .SWF

Programando macros para o OpenOffice.org

Resolvendo problema de conexão ao Windows Live Messenger com Pidgin

Popcorn Time no LMDE (Debian) sem PPA

  

Comentários
[1] Comentário enviado por nfermat em 03/03/2009 - 11:40h

Tem certeza que o flash 10 não funciona?
Interessante, eu uso o flash 10 e mais
muitos sites não funcionam se vc não tiver
o 10.

Provavelmente a origem desse flash 10 que
vc pegou esta corrompida.

[2] Comentário enviado por andreuebe em 03/03/2009 - 19:21h

nfermat

O problema relatado aconteceu no Ubuntu 8.04 ao se tentar instalar o pacote: flashplugin-nonfree

Como depois de instalado verifiquei que a versão era a 10, deduzi que foi a atualização do pacote feita (talvez especificamente no Ubuntu). Daí que instalei a versão 9 e passou a funcionar (em vez de ficar congelado o player).

Assim, resolví reportar o caso como dica e orientação apra quem, porventura, esteja com problemas similares.


Abraçao

Andre

[3] Comentário enviado por andreuebe em 15/03/2009 - 19:11h

Se após os procedimentos não funcionar, veja se existe um link simbolico na pasta:

/home/<seu usuário>/.mozilla/

digitando:

ls -la /home/<seu usuário>/.mozilla/

onde deve aparecer:

lrwxrwxrwx 1 <seu usuario> <seu usuario> 59 2008-03-15 12:42 plugins -> /usr/java/jre-1.5.0_01/plugin/i386/ns7/libjavaplugin_oji.so

delete este link:

rm /home/<seu usuário>/.mozilla/plugin

e crie um diretório:

mkdir /home/<seu usuário>/.mozilla/plugin

E repita a instalação.

É melhor instalar o flahs como usuario local e não como sudo.

Abs

Andre


Obs.: <seu usuario> = nome do usuario logado no sistema




[4] Comentário enviado por docetrago em 27/03/2009 - 17:01h

Olha só o que acontece aqui :
Eu copiei o arquivo libflashplayer.so para pasta /usr/lib/firefox-3.0/plugins e reiniciei o FF. Deu certo. Só que depois fechei o FF e ao abrir novamente, o problema continuou. Aí fiz outro teste : apaguei o arquivo e fiz tudo de novo. Abri o FF, deu certo. Então, toda vez que eu for usar o FF terei de ficar copiando o plugin. Alguém sabe me dizer o que tem de ser feito para que o plugin seja permanentemente reconhecido, sem que eu tenha de apagar e copiar toda vez ? Uso FF 3.0, e Kurumin NG 8.04. Grato pela ajuda !

[5] Comentário enviado por guilhermeecg em 06/11/2011 - 00:50h

ai pessoal beleza
entao eu tava com esse problema mas e bem simples pra resolver, é que a versao do adobe flash player q vc instalou nao é para o mozilla firefox entao vo mostrar como faz.
É so entrar nesse site

http://www.softonic.com.br/s/adobe-flash-player-versao-9.0

é pela pagina da versao 9 mais é a 11 entao entra ai nesse site e só instalar a versao para o FIRIFOX tem uma outra la que é para o explorer, é bem simples é so instalar normalmente

valeu galera



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts