Porta paralela /dev/lp0 não aparece

Publicado por Fábio em 16/02/2007

[ Hits: 16.890 ]

 


Porta paralela /dev/lp0 não aparece



Palavras chaves: paralel port, porta paralela, /dev/lp0, /dev/lp1, /dev/lp2, bash: /dev/lp0: No such device or address, bash: /dev/lp1: No such device or address, bash: /dev/lp2: No such device or address, modprobe, lsmod, parport_pc, parport, parport0: PC-style at 0x378 [PCSPP,TRISTATE]
lp0: using parport0 (polling). lp0: console ready a porta lp0 não aparece no cups porta da impressora não aparece

Primeiramente verifique se a porta paralela na BIOS do seu micro está marcada como enable, é possível que esteja marcada como disabled, aí não vai funcionar de jeito nenhum. Em um micro PC normal basta reiniciar o computador e pressionar a tecla DELETE enquanto o micro inicia, uma tela modo texto irá aparecer (essa é a tela de configuração da BIOS), procure pela opção de periféricos em algum dos menus (geralmente estará em inglês) e então verifique se a opção da porta paralela está como enabled, caso não esteja, mude para enabled e salve as alterações na BIOS, reinicie o micro e verifique se tudo está ok.

Caso não resolva, é provável que o módulo responsável pelas portas paralelas não estejam carregadas, para isto basta digitar:

# modprobe parport
# modprobe parport_pc


Caso a segunda opção seja a responsável pelo funcionamento, adicione em /etc/rc.d/rc.local no final do arquivo as duas linhas digitadas acima para que ao iniciar o sistema os módulos sejam carregados.

Outras dicas deste autor

Problema na Transmissão da Declaração de Imposto de Renda (PF) pelo Aplicativo IRPF [Resolvido]

Pendrive queimou?

Gerando estatísticas de acesso ao web server com awstats em arquivos html estáticos

Tim.com.br não funciona no firefox

Claro.com.br não funciona no Firefox (solução alternativa)

Leitura recomendada

Migrando todos os pacotes DEB de uma instalação para outra

Ubuntu 11 - Tocando DVD que não toca

VirtualBox no Devuan pelo site oficial

Placa de TV pixelView BT878 - módulo bttv sem áudio

[Resolvido] Running inside an X server requires Xephyr to be installed but it cannot be found

  

Comentários
[1] Comentário enviado por PaMpLoNa em 17/02/2007 - 13:35h

Comentário: o modprobe é mais "inteligente" que o insmod, basta carregar o módulo parport_pc que os outros de quem ele depende como parport são carregados, neste caso são apenas dois módulos, mas quando se precisa carregar vários módulos saber disso é mais útil.

[2] Comentário enviado por fba em 03/04/2007 - 11:35h

interessante, valeu pela contribuição ;)



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts