PPPoE over wireless no Ubuntu

Publicado por @dilasmartins em 04/11/2011

[ Hits: 5.834 ]

Blog: http://twitter.com/#!/dilasmartins

 


PPPoE over wireless no Ubuntu



Trabalho em uma Faculdade e disponibilizamos Internet para os alunos via Wireless usando autenticação PPPoE. Quanto a notebooks usando qualquer versão do Windows é tranquilo. No Slackware que uso no meu note, também sem problemas. O grande problema era no Ubuntu e derivados do Debian.

Eu configurava usando o pppoeconf e achava que estava tudo ok, pois estava acessando a Internet. Porém quando reiniciava o sistema aí estava o grande problema, o NetworkManager não encontrava mais a interface wireless. Pesquisei em vários locais ate achar uma solução. Compilei um passo a passo e espero que ajude quem passa pelo mesmo problema.

1. Conectar na rede wireless usando o NetworkManager.

2. Abrir um terminal e configurar o pppoe:

sudo pppoeconf

Obs.: como trata-se de wireless eu prefiro não conectar na inicialização.

3. Executar:

(para/versões do Ubuntu anteriores a 11):

sudo gedit /etc/NetworkManager/nm-system-settings.conf

(para a versão 11 em diante):

sudo gedit /etc/NetworkManager/NetworkManager.conf

Nesse arquivo, mude a opção:

managed=false

Para:

auto lo
iface lo inet loopback

Obs.: o pppoeconf adiciona algumas linhas mencionando a placa de rede wireless, por isso o NetworkManager não consegue conectar-se após o primeiro reboot.

5. Executar:

sudo reboot

6. Quando o sistema iniciar, conecte novamente na rede wireless e use o comando:

sudo pon dsl-provider

Para discar para o provedor.

Talvez seja necessário configurar a rota manualmente, usando o comando:

# route

Mas os parâmetros vão variar de acordo com a configuração do seu provedor.

Abraço!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Solucionando problema de resolução máxima de 640x480 no Ubuntu e similares

Driver de vídeo VESA em 1280x800

Dois painéis de configuração do sistema no Linux Mint? [Resolvido]

Porta paralela não criada no boot do Debian 7

Desativando popups "O sistema detectou um problema no aplicativo" no Ubuntu

  

Comentários
[1] Comentário enviado por rogeriojlle em 04/11/2011 - 13:43h

pode dar a dica de como foi implementado o servidor ppoe?

[2] Comentário enviado por dilasmartins em 04/11/2011 - 13:48h

Não fui eu que implementei o server, mas posso adiantar que é um Mikrotik e tbm temos um OpenBSD como servidor externo, mas em uma rápida pesquisa achei isso aqui http://www.vivaolinux.com.br/dica/Configurando-um-PPPOE-Server
Abraço...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts