O que fazer depois de instalar o Debian 8

Publicado por Perfil removido em 30/09/2015

[ Hits: 70.669 ]

 


O que fazer depois de instalar o Debian 8



Olá a todos, como vão? Bom, meio que atrasado não? O motivo pelo qual resolvi fazer este pequeno tutorial sobre o Debian 8, é que vejo que o que existe na internet em relação a ele como pacotes de repositórios, java, atualizações e outras coisas, estão muito confusas e com dicas não "experimentadas".

Isso deixa qualquer um com raiva, estresse e o faz abandonar o S.O. partindo pra outra, muitas as vezes, o "janelas".

Veja que não é nenhum "bicho de sete cabeças". Basta ter paciência e boa vontade para deixar seu Debian 8 bem mais prático, fácil e pronto para o trabalho do dia-a-dia.

Então, "arregace as mangas":

1) Habilitando os Repositórios tão necessários:

su -

# gedit /etc/apt/sources.list #=>Ou o editor pluma (nativo do Mate)

E depois insira os repositórios básicos:

deb http://ftp.br.debian.org/debian jessie main contrib non-free
deb-src http://ftp.br.debian.org/debian jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://ftp.br.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.br.debian.org/debian/ jessie-updates main contrib non-free

#Multimedia
deb http://www.deb-multimedia.org jessie main non-free
deb-src http://www.deb-multimedia.org jessie main non-free

#BackPorts
deb http://ftp.br.debian.org/debian/ jessie-backports main contrib non-free

Bom, salve e feche o arquivo. De volta a janela do terminal dê os seguintes comandos para inserção da chave keyring e atualizar os mesmos. OBSERVE que ele vai te avisar que a chave NÃO foi encontrada no primeiro 'apt-get update' abaixo. NORMAL, não se preocupe, continue com os comandos:

# apt-get update
# apt-get install deb-multimedia-keyring
# apt-get update


Agora, na sequência, atualize seu sistema:

# apt-get upgrade
# apt-get dist-upgrade


Obs.: Feche o terminal. Reinicie o sistema para que as atualizações entrem em vigor.

2) Pacotes e Aplicações Necessárias ao seu Debian 8.

Instalando o SUDO e adicionando USUÁRIO.

# apt-get install sudo
# adduser <Nome_do_Usuario> sudo
# sudo apt-get update
#=> Ainda dentro do root.

Obs. Feche o terminal e novamente reinicie o sistema.

Para instalar o Lightspark basta executar o seguinte comando:

sudo apt-get install lightspark

Java JDK.

Para utilizar a versão alternativa mantida pela comunidade livre, faça:

sudo apt-get install openjdk-7-jdk openjdk-7-jre icedtea-7-plugin

Java Oracle 8.

Para instalar a máquina Java "Oficial" é necessário a adição de um repositório não-oficial, faça:

$ su -
# echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" | tee -a /etc/apt/sources.list
# echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" | tee -a /etc/apt/sources.list
# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
# apt-get update


Por fim, a instalação do Java 8:

# apt-get install oracle-java8-installer

A instalação do VLC, mplayer e gxine fará o Debian capaz de rodar a maioria dos formatos de vídeo. Para ler a grande maioria de formatos de vídeo e áudio, faça:

sudo apt-get install ffmpeg mencoder smplayer vlc gxine gstreamer0.10-plugins-ugly libdvdcss2 libdvbpsi9 libdvdread4 libdvdnav4 lsdvd lame easytag soundconverter asunder libdca0 libmad0 mpg123 mpg321 twolame easymp3gain-data

3) Deixando o Debian 8 em Português.

O sistema, em root:

# dpkg-reconfigure locales

Depois, marque as opções com a barra de espaço:

en_US.ISO8859-1
en_US.UTF-8
pt_BR.ISO8859-1
pt_BR.UTF-8

Feito isso, quando lhe perguntar qual o idioma padrão, escolha pt_BR.ISO8859-1.

O Iceweasel, Icedove e o LibreOffice em português do Brasil. Feche-os e faça:

$ sudo apt-get install iceweasel-l10n-pt-br
$ sudo apt-get install icedove-l10n-pt-br
$ sudo apt-get install libreoffice-l10n-pt-br


Obs.: Tudo testado na versão Debian 8 MATE.

Enfim, é isso. Espero que com isso, não precise mais buscar ajuda em fóruns descontinuados ou desatualizados.

Abraços,
Jbaf 2015

Outras dicas deste autor

Instalando a última versão do KDE no Kubuntu

Baixando atualizações para seu Mandrake/Mandriva

Gnome-RDP no Ubuntu Edgy

Como "instalar" programas descompacte-e-use

Java 8 Oracle no Fedora 21 - Esse funciona!

Leitura recomendada

Turbinando seu Nautilus

Squid no CentOS - Parte 2: Autenticação

Resolvendo erro ao iniciar o KDE no Slackware 13.37

Instalando driver NVIDIA no Debian 9

Adicionando rotas persistentes no SuSE

  

Comentários
[1] Comentário enviado por sergeimartao em 08/10/2015 - 13:28h

Muito importante para quem esta começando no Debian, já tivesse problemas quando não sabia dessas configurações básicas. Vlw

[2] Comentário enviado por removido em 08/10/2015 - 20:35h


[1] Comentário enviado por sergeimartao em 08/10/2015 - 13:28h

Muito importante para quem esta começando no Debian, já tivesse problemas quando não sabia dessas configurações básicas. Vlw


Boa noite,

Valeu !!

[3] Comentário enviado por edps em 19/10/2015 - 17:13h


Uma pergunta e uma sugestão:

A pergunta:

esse lightspark é melhor que o flashplugin-non-free (ô desgracera lerda e pesada meu)!

A sugestão:

em vez de usar os não tão compatíveis pacotes open-source ou usar o pacote da PPA, talvez empacotar o seu JAVA da Oracle possa ser uma solução (2º método):

https://edpsblog.wordpress.com/2015/03/23/how-to-2-formas-de-instalacao-do-oracle-java-8-no-debian/

No mais, sua dica está ótima.

[4] Comentário enviado por Toni Caval em 23/11/2015 - 18:41h

Excelente tutorial amigo. Depois de vários dias pesquisando, cheguei a esta página. Sou iniciante, e foi bem difícil encontrar algo com um passo a passo tão detalhado. Obrigado


[5] Comentário enviado por clodoaldops em 24/11/2015 - 22:28h

Very Good!
Se rendeu ao Debian-MATE, né?

[6] Comentário enviado por removido em 25/11/2015 - 02:21h


[5] Comentário enviado por clodoaldops em 24/11/2015 - 22:28h

Very Good!
Se rendeu ao Debian-MATE, né?


Bom dia,

Pois é, muito bom mesmo!! Valeu!!

[7] Comentário enviado por tiago4171 em 09/03/2016 - 17:56h

Acabei de testar no meu Debian.
Ficou sussa
VOCÊ É O CARA!!!

[8] Comentário enviado por _Aprendiz_ em 08/06/2016 - 08:38h

Não consigo fazer apt-get update. Ele da erro e não baixa nada. Pode me ajudar?

[9] Comentário enviado por removido em 08/06/2016 - 10:47h


[8] Comentário enviado por _Aprendiz_ em 08/06/2016 - 08:38h

Não consigo fazer apt-get update. Ele da erro e não baixa nada. Pode me ajudar?



Olá , você precisa substituir sua sources.list por essa que coloquei no tópico. Agora, saiba que esta é uma lista de repositórios básicos. Se quer instalar algo mais, alguma PPA particular para usar algum aplicativo, você precisa saber se é válido ou se já não foi descontinuado. Usando estas de cima, comprovadamente, não dará erro.

Abraços!!

[10] Comentário enviado por _Aprendiz_ em 08/06/2016 - 11:01h

Olá , você precisa substituir sua sources.list por essa que coloquei no tópico. Agora, saiba que esta é uma lista de repositórios básicos. Se quer instalar algo mais, alguma PPA particular para usar algum aplicativo, você precisa saber se é válido ou se já não foi descontinuado. Usando estas de cima, comprovadamente, não dará erro.

Abraços!!



Já substitui conforme pediu no tutorial, mas estou querendo dizer que mesmo assim não está dando certo. Pode me ajudar?


[11] Comentário enviado por _Aprendiz_ em 08/06/2016 - 11:26h

Segue os erros!


Err http://security.debian.org jessie/updates InRelease

Err http://www.deb-multimedia.org jessie InRelease

Err http://www.deb-multimedia.org jessie Release.gpg
Não foi possível resolver 'www.deb-multimedia.org'
Err http://security.debian.org jessie/updates Release.gpg
Não foi possível resolver 'security.debian.org'
Err http://ftp.br.debian.org jessie InRelease

Err http://ftp.br.debian.org jessie-updates InRelease

Err http://ftp.br.debian.org jessie-backports InRelease

Err http://ftp.br.debian.org jessie Release.gpg
Não foi possível resolver 'ftp.br.debian.org'
Err http://ftp.br.debian.org jessie-updates Release.gpg
Não foi possível resolver 'ftp.br.debian.org'
Err http://ftp.br.debian.org jessie-backports Release.gpg
Não foi possível resolver 'ftp.br.debian.org'
Lendo listas de pacotes... Pronto
W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/jessie/InRelease

W: Falhou ao buscar http://security.debian.org/dists/jessie/updates/InRelease

W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/jessie-updates/InRelease

W: Falhou ao buscar http://www.deb-multimedia.org/dists/jessie/InRelease

W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/jessie-backports/InRelease

W: Falhou ao buscar http://security.debian.org/dists/jessie/updates/Release.gpg Não foi possível resolver 'security.debian.org'

W: Falhou ao buscar http://www.deb-multimedia.org/dists/jessie/Release.gpg Não foi possível resolver 'www.deb-multimedia.org'

W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/jessie/Release.gpg Não foi possível resolver 'ftp.br.debian.org'

W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/jessie-updates/Release.gpg Não foi possível resolver 'ftp.br.debian.org'

W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/jessie-backports/Release.gpg Não foi possível resolver 'ftp.br.debian.org'

W: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.

[12] Comentário enviado por joaofenomeno em 02/07/2016 - 12:28h

No meu,apareceu o seguinte erro:
Troca de mídia: por favor, insira o disco nomeado
'Debian GNU/Linux 8.5.0 _Jessie_ - Official i386 DVD Binary-1 20160604-14:09'

Me ajude,pfv.

[13] Comentário enviado por L_USER em 06/07/2016 - 06:12h


[12] Comentário enviado por joaofenomeno em 02/07/2016 - 12:28h

No meu,apareceu o seguinte erro:
Troca de mídia: por favor, insira o disco nomeado
'Debian GNU/Linux 8.5.0 _Jessie_ - Official i386 DVD Binary-1 20160604-14:09'

Me ajude,pfv.


Isso não é um erro, o Debian tem um sistema de repositório offline.
Caso não queira usar esse recurso, basta simplesmente desativar o cd/dvd 1 na sua
sources.list, registrado durante a instalação do sistema.
No terminal de o comando abaixo, e comente a linha referente ao cd/dvd com um # no inicio:
su
nano /etc/apt/sources.list

A linha que deve ser comentada é essa.
deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 CD Binary-1...]/ jessie main
Ficando assim:
#deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 CD Binary-1...]/ jessie main
Salve com Ctrl + O e tecle enter e feche com Ctrl + x
Atualize o apt-get.
Pronto a mensagem não vai mais te atrapalhar xD

[14] Comentário enviado por Exearg em 02/09/2016 - 18:48h

Essas dicas, por acaso, servem para o Debian 7?

[15] Comentário enviado por higopsy em 05/09/2016 - 10:23h

Estou seguindo as dicas do post, grato.

[16] Comentário enviado por removido em 12/12/2016 - 20:46h

É uma falha de segurança fazer isso:

# adduser <Nome_do_Usuario> sudo


O locales padrão é o pt_BR.UTF-8 atualmente pela comunidade ISO.


Arquivo /etc/apt/sources.list

#BackPorts
deb http://ftp.br.debian.org/debian/ jessie-backports main contrib non-free

O repositório tem as versões mais novas dos programas.
Os backports são pacotes recompilados do canal de desenvolvimento testing e, em alguns casos, do canal unstable.
Esta desabilitado por segurança, devemos ter algum cuidado.

Como preservar a integridade e a estabilidade da sua instalação Debian.

https://elias.praciano.com/tag/backports/



Na questão do java baixe no site oficial

https://www.java.com/pt_BR/

[17] Comentário enviado por Neskhayr em 07/01/2017 - 02:38h

Cara, muito obrigado!
Que tópico sensacional.

Simples, didático e muito, muito útil.
Favoritado!

[18] Comentário enviado por removido em 16/01/2017 - 19:42h

Falha de segurança:

2) Pacotes e Aplicações Necessárias ao seu Debian 8.

Instalando o SUDO e adicionando USUÁRIO.

# apt-get install sudo
# adduser <Nome_do_Usuario> sudo <= Nunca usa isso

NUNCA DEVE ADICIONAR O SEU USUÁRIO AO GRUPO SUDO.

O pacote sudo não é necessário.

[19] Comentário enviado por homemsemnome em 17/01/2017 - 13:37h

[Atenção: Leia o post até o final antes de mais nada!]

Eu segui este tutorial há cerca de um ano atrás e o mesmo foi muito útil para mim. Mas só um adendo para a galera: o Iceweasel agora foi substituído pelo Firefox. Nos repositórios do Debian stable está disponível a versão firefox-esr do Firefox, que é uma espécie de versão "congelada" do Firefox visando uma maior estabilidade/segurança. Contudo, caso você queira utilizar a versão mais recente do Firefox, importe-a via backport.

Segue o passo a passo.

Adicione (como root) o backport oficial do Firefox na sua sources.list (você pode utilizar um editor de textos qualquer para isso também):

# echo "deb http://mozilla.debian.net/ jessie-backports firefox-release" >> /etc/apt/sources.list

Agora atualize o sistema e note que irá aparecer uma mensagem de erro dizendo que falta uma chave criptográfica GPG. Normal. Já iremos corrigir isso.

# apt-get update

A instalação do pacote abaixo irá automaticamente cuidar da chave GPG.

# apt-get install pkg-mozilla-archive-keyring

Pronto, agora basta ativar o backport do Firefox e instalá-lo. Ele já virá em português também.

# apt-get install -t jessie-backports firefox firefox-l10n-pt-br

Fonte:
https://mozilla.debian.net/

Atualização do dia 21/03/2017: o backport do Firefox no Debian stable não está funcionando mais. Só temos a versão ESR do Firefox agora. Ela está disponível nos repositórios oficiais mesmo.

WARNING: Jessie backports of Firefox release, beta and aurora are gone because of the upcoming requirement of rust to build them, which is not available in Jessie. Please update your apt sources to use Firefox ESR instead.

https://mozilla.debian.net/


Atualização do dia 06/07/2017: acabei descobrindo que para se instalar o Firefox mais recente basta entrar no site do mesmo e descompactá-lo no sistema. Pensei que não fossem possível por conta das bibliotecas do sistema e tal, mas dá sim. É bem simples o negócio. Não precisa de backport nem nada.

http://www.edivaldobrito.com.br/firefox-no-linux-manualmente/

[20] Comentário enviado por codgolivre em 08/02/2017 - 16:38h

parabens pelo artigo acabei de instalar o debian 8 pq minha maqui e muit fraca... seguindo orientação aqui do vol optei po esse os ... estava dificil configurar e baixar um codec de video... mas com esse tutorial deixei minha maquina especial....muito obrigado...

[21] Comentário enviado por homemsemnome em 18/02/2017 - 23:37h

Então negada, eu dei uma dica acima de como se instalar o Firefox, mas recentemente eu venho experimentando o Chromium e o desempenho do mesmo está me surpreendendo -- principalmente porque o consumo de memória RAM dele é bem semelhante ao do Firefox. Então nada mais justo do que sugeri-lo aqui. O mesmo se encontra nos repositórios oficiais do Debian stable. Ele é de código aberto. =)

# apt install chromium chromium-l10n

fonte:
https://wiki.debian.org/Chromium

[22] Comentário enviado por removido em 19/02/2017 - 07:01h


[21] Comentário enviado por homemsemnome em 18/02/2017 - 23:37h

Então negada, eu dei uma dica acima de como se instalar o Firefox, mas recentemente eu venho experimentando o Chromium e o desempenho do mesmo está me surpreendendo -- principalmente porque o consumo de memória RAM dele é bem semelhante ao do Firefox. Então nada mais justo do que sugeri-lo aqui. O mesmo se encontra nos repositórios oficiais do Debian stable. Ele é de código aberto. =)

# apt install chromium chromium-l10n

fonte:
https://wiki.debian.org/Chromium


Bom dia,

Obrigado pela contribuição, de fato, hoje está assim entre estes dois browsers. Já utilizei muito o chromium no passado. ^^)

[23] Comentário enviado por removido em 23/03/2017 - 22:53h

Boa noite...
então... estou utilizando o Debian testing com o mate e não estou conseguindo instalar o lightspark.
será que ele não estar disponivel para essa versão do debian ??

[24] Comentário enviado por removido em 28/03/2017 - 11:18h

Atualmente a versão do Debian é jessie altera para stable assim o seu Debian fica sempre na versão estável.

nano /etc/apt/sources.list


NUNCA INSTALA NADA DE REPOSITÓRIO DE TERCEIRO NO SISTEMA (ppa e outros). Sempre use os repositórios oficiais da sua distro.

Nunca use repositório do Ubuntu no Debian.

-------------------------------------------------------------------------------------------------------------------
Java Oracle 8.

Para instalar a máquina Java "Oficial" é necessário a adição de um repositório não-oficial, faça:

# echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" | tee -a /etc/apt/sources.list
# echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" | tee -a /etc/apt/sources.list
# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886

-------------------------------------------------------------------------------------------------------------------

Para instalar o Java use o site: https://www.java.com/pt_BR/download/linux_manual.jsp

Eu tenho Java?
https://www.java.com/pt_BR/download/installed8.jsp


A partir do Firefox Versão 52 (programada para março de 2017), o Firefox limitou o suporte a plug-ins; portanto, não executará o Java.


Firefox 52.0.1 com suporte ao Netflix (Módulos DRM)
http://www.edivaldobrito.com.br/netflix-finalmente-adicionou-suporte-para-o-firefox-no-linux/



Inicialmente usa só os repositórios oficiais do Debian (main) e retira o contrib e non-free do arquivo /etc/apt/sources.list só adiciona conforme sua necessidade.

O repositório BackPorts e Multimedia não é obrigatório (opcional) e depende de cada pessoa.

Os repositórios non-free tem pacotes com componentes proprietários.

Os repositórios multimedia não é mais necessários.

[25] Comentário enviado por removido em 28/03/2017 - 12:03h


[23] Comentário enviado por luanpereira89 em 23/03/2017 - 22:53h

Boa noite...
então... estou utilizando o Debian testing com o mate e não estou conseguindo instalar o lightspark.
será que ele não estar disponivel para essa versão do debian ??


No debian 8 tem o pacote lightspark.

[26] Comentário enviado por carbon em 14/05/2017 - 04:54h

Antes de até mesmo ligar na rede ...

UM BOM firewall ! Mas bom mesmo.

[27] Comentário enviado por silveiraluis em 21/05/2017 - 17:08h

Sou iniciante no mundo Linux e suas informações me ajudaram muito Jessé!

Obrigado e Parabéns!

[28] Comentário enviado por duzinho-78 em 14/08/2017 - 05:17h

Muito bom! Valeeuu! A dica do
"apt-get install deb-multimedia-keyring" foi muito útil pra mim
Abraço,
Acho que é pro som funcionar né? Pois tinha instalado o Debian Jessie antes e não funcionava o som. Desta vez foi e com ambiente MATE...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts