Modem 3G modelo E173s no Linux

Publicado por Josue de Jesus Santos em 31/01/2012

[ Hits: 14.090 ]

Blog: https://github.com/josuejsantos

 


Modem 3G modelo E173s no Linux



Venho por meio dessa dica simples, mostrar como instalar o modem E173s no Linux, que é vendido como E173, testado e aprovado nas seguintes distros: Slackware, Sabayon, OpenSuse, Gentoo, Arch Linux, Ubuntu.

Pois bem. O modem Huawei E173 vendido pela operadora da Vivo na realidade é o modelo E173S, que não é reconhecido automaticamente pelo Slackware.

Como configurar no Slackware:

1 - Crie o arquivo "/etc/usb_modeswitch.d/12d1:1c0b"

Obs.: Se não possuir o diretório, crie-o.

# nano /etc/usb_modeswitch.d/12d1:1c0b

2 - Coloque o conteúdo abaixo e salve o arquivo:

###########
# Huawei E173s

DefaultVendor= 0x12d1
DefaultProduct= 0x1c0b

TargetVendor= 0x12d1
TargetProduct= 0x1c05

CheckSuccess=20

MessageEndpoint= 0x0f
MessageContent= "55534243123456780000000000000011062000000100000000000000000000"


3 - Modifique o arquivo "/lib/udev/rules.d/40-usb_modeswitch.rules"

Obs.: No Sabayon, Gentoo, OpenSuse, comente a linha referente ao modelo E173.

# nano /lib/udev/rules.d/40-usb_modeswitch.rules

4 - Adicione as linhas abaixo e salve o arquivo:

#Huawei E173s
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1c0b", RUN+="usb_modeswitch '%b/%k'"


5 - Suba o modulo

# modprobe usbserial vendor=0x12d1 product=0x1c0b

Pronto!

Agora conecte o modem, espere um pouco, abra a janela de edição das conexões de rede e adicione uma conexão "Banda Larga Móvel".

O modem deve ser reconhecido e deve aparecer na primeira janela, depois basta configurar o APN, usuário e senha. Ou use o Wvidial, que por sinal é excelente.

Se for Vivo, estes valores são:

APN: zap.vivo.com.br
Usuário: vivo
Senha: vivo


Baseado no post:

Outras dicas deste autor

Systemd - Failed to start Squid caching proxy

Instalando o Webmin no FreeBSD

Instalando o VMWare Tools no FreeBSD 10.2 I386

Leitura recomendada

Flash Player no Google Chrome

Adicionando plugin Gecko Media Player ao Firefox

Testando o novo Firefox (Minefield) e compatibilizando quase todas as extensões

Token GD Safesign no Ubuntu 12.04 LTS

Instalando o SRWare Iron (Google Chrome) no Linux

  

Comentários
[1] Comentário enviado por julio_hoffimann em 31/01/2012 - 15:04h

Ótima dica Josué!

Abraço!

[2] Comentário enviado por JJSantos em 02/02/2012 - 21:55h

Vlw, Julio.

[3] Comentário enviado por aleanderson em 04/04/2012 - 16:40h

Fala abençoado!!
estou com este problema que vc postou..
Mais estou aprendendo a mexer no linux tem pouco tempo, então, eu fique com duvidas no 3, 4 e 5 itens, tem como ser possivel colocar mais detalhado o que vc quis dizer.
desde já agradeço.

[4] Comentário enviado por JJSantos em 12/04/2012 - 23:15h

Qual a sua duvida Aleandeson?
O item 3 é referente e edição do arquivo 40-usb_modeswitch.rules, o comentar é adicionar o sinal # na frente da linha que comentei acima...
Você conseguiu abrir tal arquivo?
O item 4 é referente a linha correta a que o sistema deve ler quando o modem for conectado ou seja como o modelo correto é E173s, porem o sistema o reconhecia como E173 ficando impossibilitado sua utilização.
Qual sua distro?
O item 5 referente ao modulo você descobre com a saída do comando lsusb em shell, de posse dessa informação sobe-se o modulo.
Você sabe o modelo correto do seu modem?

[5] Comentário enviado por JJSantos em 12/04/2012 - 23:17h

Eu estou sem pc esses dias..
Poste as informações referentes ao modelo do seu modem, sua distro, para que eu possa te ajudar..

[6] Comentário enviado por gostodisso em 08/03/2013 - 09:19h



gostodisso escreveu:

OLHA VOU CRIAR UM DITADO POPULAR AQUI NO VOL: enquanto muitos aqui no viva o linux se acham os superiores sabem tudo experiente em varias distro linux e responde perguntas só para ganhar pontos no forum e não conseguiram nem se quer me ajuda.

R: Fica frio. Lembre-se temos vida! Não ficamos 24 hrs na frente do computador.
Lembre-se ajudamos por boa vontade, e pelo simples prazer de compartilhar o conhecimento, mesmo que ele não seja tão grande assim. Ficaria surpreso, mais aprendo aqui muito mais do ensino. E só tenho agradecer as pessoas que percebem que o conhecimento algo para ser partilhado e não guardador em caixa.

"...Aí Pessoal, valeu mesmo a ajuda de todos. Agora já estou acessando o VOL pelo Ubuntu após ter resolvido o problema do modem com um pouco de leitura por toda a rede cheguei a um resultado que vou postar aqui, pois se no futuro pode ser útil pra mais alguém...." gravem o nome do fera : estagiariojack olha o poster.
http://www.vivaolinux.com.br/topico/Iniciantes-no-Linux/Configurar-Modem-3G

R: Que bom que conseguiu, fico feliz por não ter desistido na primeira adversidade, nem sempre conseguimos o queremos, porém todos tem ao menos o direito de tentar, então não espere a resposta cair no seu colo, mexa-se busque a solução.


Dá uma lida querido: http://www.vivaolinux.com.br/dica/Modem-3G-modelo-E173s-no-Linux/

Até

Josué


O problema que esse artigo só correspodem a esse modem, não resolve meu problema, debian 6.0.6 64bits, modelo do modem Huawei E303:
[email protected]: [776.764268] usb 1-2 new high speed USB device using ehci_hcd and address 3
[77.897898] usb 1-2: new USB device found idvendor=12s1, idprodutc=14fe
sr1: scsi drive.

qual a solução

[7] Comentário enviado por gostodisso em 08/03/2013 - 09:20h

O problema que esse artigo só correspodem a esse modem, não resolve meu problema, debian 6.0.6 64bits, modelo do modem Huawei E303:
[email protected]: [776.764268] usb 1-2 new high speed USB device using ehci_hcd and address 3
[77.897898] usb 1-2: new USB device found idvendor=12d1, idprodutc=14fe '''''''corrigindo idvendor''
sr1: scsi drive.

[8] Comentário enviado por JJSantos em 09/03/2013 - 18:29h


[7] Comentário enviado por gostodisso em 08/03/2013 - 09:20h:

O problema que esse artigo só correspodem a esse modem, não resolve meu problema, debian 6.0.6 64bits, modelo do modem Huawei E303:
[email protected]: [776.764268] usb 1-2 new high speed USB device using ehci_hcd and address 3
[77.897898] usb 1-2: new USB device found idvendor=12d1, idprodutc=14fe '''''''corrigindo idvendor''
sr1: scsi drive.


Lógico eu só tinha esse modem. Porém o mesmo serve de base para vários outros!
Terá que adaptar a sua necessidade;-)

[9] Comentário enviado por removido em 06/02/2017 - 23:25h


Hoje é só:

apt-get update && apt-get install -y wvdial

wvdialconf


Configurar o /etc/wvdial.conf

wvdial






Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts