Java Oracle + Plugin Firefox no Antergos (Arch Linux)

Publicado por Carlos A. P. Cunha em 09/08/2016

[ Hits: 1.680 ]

 


Java Oracle + Plugin Firefox no Antergos (Arch Linux)



Opa! Dica rápida e útil para quem precisa do Java da Oracle no seu Linux Antergos, que é baseado em Arch Linux (assim como o Manjaro).

1. Baixe a versão mais atual do Java no Site da Oracle:
Atualmente na versão 1.8.0_91.

2. Descompacte o Java, no meu caso, vou alocar no /opt:

sudo tar -xzvf jre1.8.0_91.tar.gz -C /opt

3. Caso já tenha alguma versão do Java (oracle ou não), remova o link existente:

sudo unlink /usr/bin/java

4. Crie o link para o sistema:

sudo ln -s /opt/jre1.8.0_91/bin/java /usr/bin/java

5. Valide sua versão, digitando:

java -version
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)


Terá a saída acima.

Pronto, Java para o Sistema já está ok, agora vamos ao Firefox.

6. Logado como usuário comum (não root):

$ mkdir ~/.mozilla/plugins/
$ ln -s /opt/jre1.8.0_91/lib/amd64/libnpjp2.so ~/.mozilla/plugins/libnpjp2.so


Reinicie o Firefox.

7. Acesse o site abaixo e teste se ocorreu tudo OK.
Testado em:
  • Operating System: Antergos
  • Kernel: Linux 4.6.4-1-ARCH
  • Architecture: x86-64
  • Firefox 47

Abraço.

Outras dicas deste autor

Acessar site do Itaú (Banco) de qualquer Linux [2016]

Criptografando Shell Script

Samba 4 - Desabilitando suporte a impressoras (CUPS)

Skype no Antergos (Arch Linux)

VSFTPD - Criando diretório de usuário automaticamente

Leitura recomendada

Instalar Firefox 6.0.2 no Mandriva 2010.2

Wicd network manager

Ganhe um livro sobre Linux

Quem precisa de Pidgin?!

Ferramenta de tradução rápida em seu Firefox

  

Comentários
[1] Comentário enviado por wicos em 29/09/2016 - 19:14h

Obrigado por compartilhar.
Apenas troquei a versão pela atual e funcionando perfeitamente.
Um adendo na hora de baixar o pacote verifique se seu sistema é de 32bits ou 64bits.
Caso não lembre o comando é o $ uname -a.
No site do java tem os links "Linux" de 32bits e 'Linux x64", de 64bits.

[2] Comentário enviado por Carlos_Cunha em 29/09/2016 - 21:56h


[1] Comentário enviado por wicos em 29/09/2016 - 19:14h

Obrigado por compartilhar.
Apenas troquei a versão pela atual e funcionando perfeitamente.
Um adendo na hora de baixar o pacote verifique se seu sistema é de 32bits ou 64bits.
Caso não lembre o comando é o $ uname -a.
No site do java tem os links "Linux" de 32bits e 'Linux x64", de 64bits.


Obrigado amigo.
Como faz tanto tempo que não uso sistema 32 Bits que nem e lembrei disso hehe



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts