Instalar o compiz-fusion completo e sem conflito no Debian 5 Lenny

Publicado por Glauber GF em 27/04/2009

[ Hits: 18.048 ]

Blog: http://www.vivaolinux.com.br/~mcnd2

 


Instalar o compiz-fusion completo e sem conflito no Debian 5 Lenny



Essa dica é para todos que quando vêem um computador com o Linux instalado e os efeitos 3D rodando ficam encantados, mas quando resolvem instalá-lo é claro que o mesmo não vem como default por ter de instalar sua placa de vídeo. Fica aí uma dica não muito nova mais de grande valor.

Depois de ter instalado sua placa de vídeo 3D e tudo estar funcionando, vamos instalar o compiz-fusion (efeitos 3D no desktop) no Debian 5 Lenny.

Obs.: Para deixar tudo no "compiz -fusion" funcionando perfeitamente, desinstale o beryl e o emerald caso você tenha instalado-os.

Vamos instalar o compiz completo com o comando abaixo, com todos os plugins instalados e até os extras.

# apt-get install compiz compizconfig-settings-manager compizconfig-backend-gconf compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-fusion-bcop

Pronto! O compiz-fusion está instalado. Caso os efeitos não estejam funcionando, verifique se sua placa 3D está ativada. Execute o comando abaixo:

# glxgears
# glxinfo | grep render


Se estiver tudo correto deverá aparecer a mensagem: "direct rendering: Yes".

Agora execute o comando para rodar o compiz sem conflitos etc:

# compiz -replace&

Pronto! Desktop 3D Now.

Valeu, até a próxima...

Referências:
Outras dicas deste autor

Deixando o Firefox e Thunderbird do LMDE em português do Brasil

Informação do Tempo – Um benchmark no Desktop do elementary OS

I-Sofa - Uma TV no seu computador

Configurar Modem 3G Vivo Huewai e156 no Metamorphose Linux

Grub com 3 sistemas operacionais e 2 HDs diferentes

Leitura recomendada

Acelerando downloads com facilidade em Firefox e SwiftWeasel

Jogo Free-Spades: Espadas para Linux

Synfig - alternativa gratuita ao Flash

GNS3 (Graphical Network Simulator) no Fedora 19

Monitorando o tráfego da sua rede com vnstat

  

Comentários
[1] Comentário enviado por albertguedes em 27/04/2009 - 20:15h

Faltou dizer pra turma instalar o "fusion-icon"

$ aptitude install fusion-icon

com ele fica muito melhor de controlar o compiz.

Mas legal, valeu.

[2] Comentário enviado por mcnd2 em 27/04/2009 - 22:03h

Bem lembrado "albertquedes" de complementar com o "fusion-icon" (controlador do compiz muito bom).

Vlw...

[3] Comentário enviado por neto_itape em 15/07/2011 - 10:47h

Segui os passos como descrito acima, mas não funcionou após baixar e configurar ele retornos os seguintes erros:

Processando gatilhos para man-db ...
Processando gatilhos para gconf2 ...
Configurando compiz-gtk (0.8.4-4) ...
Configurando compiz-gnome (0.8.4-4) ...
Configurando compiz (0.8.4-4) ...
Configurando compiz-fusion-bcop (0.8.4-1) ...
Configurando compiz-fusion-plugins-extra (0.8.4-2) ...
Configurando compiz-fusion-plugins-main (0.8.4-2+b1) ...
Configurando compizconfig-backend-gconf (0.8.4-1) ...

[email protected]:/home/netoitape# Aviso do gerenciador de janelas: Janela WM_TRANSIENT_FOR inválida 0x160002a especifica
[email protected]:/home/netoitape# compiz -replace&
[3] 5473
[email protected]:/home/netoitape# compiz (core) - Warn: Unknown option '-replace'

compiz (core) - Warn: SmcOpenConnection failed: None of the authentication protocols specified are supported
compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

[email protected]:/home/netoitape# compiz
compiz (core) - Warn: SmcOpenConnection failed: None of the authentication protocols specified are supported
Backend : gconf
Integration : true
Profile : default
Adding plugins
Initializing core options...done
Initializing move options...done
Initializing resize options...done
Initializing place options...done
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug!
Initializing decoration options...done
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported! This is an application bug!

[4] Comentário enviado por mcnd2 em 15/07/2011 - 18:37h

@neto...,

Qual é a versão do Debian que está usando. É o 5 (lenny) ou 6 (squeeze)? De qualquer forma a instalação é similar.

Então, primeiro você tem que ter instalado sua placa de video com suporte a 3D e testar o seu funcionamento.

Depois você instale o compiz e execute conforme descrito e faça sua configuração conforme este artigo:

http://www.vivaolinux.com.br/artigo/Configuracao-do-Compiz-Fusion-pos-instalacao/

Espero que te ajude.
Abraço.

[5] Comentário enviado por neto_itape em 18/07/2011 - 16:32h

então estou usando a 6 (squeeze), mas apartir do momento que executo o comando

# glxgears
# glxinfo | grep render

Se estiver tudo correto deverá aparecer a mensagem: "direct rendering: Yes".

não é que está instalada certa a placa? vio sou novo no mundo linux então me desculpa se estou deixando algum detalhe para tras.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts