Instalando o WebMod - plugin de Counter-Strike

Publicado por Eduardo Mendes em 25/02/2007

[ Hits: 58.461 ]

Blog: http://www.bsdmail.com

 


Instalando o WebMod - plugin de Counter-Strike



WebMod é um plugin de Counter-Strike utilizado para mostrar/administrar as informações do seu servidor, nele é possível definir o "MapCycle", adicionar/remover admins, alterar o .conf do servidor, kikar, banir, etc. É um utilitário simples, porém muito eficiente para a administração do servidor.

Exemplo: http://200.170.171.26:27023/

WebMod:
http://www.djeyl.net/webstats/dlcount.php?id=dJeyL&url=/files/w-0.48.zip

OBS.: Todos os comandos foram feitos com o usuário root, é necessário ter o a última versão do metamod instalado.

Baixe o WebMod:

# wget http://www.djeyl.net/webstats/dlcount.php?id=dJeyL&url=/files/w-0.48.zip

Mova o w-0.48.zip para a pasta "cstrike" do seu servidor:

# mv w-0.48.zip /pasta/cs/cstrike

Entre na pasta e extraia o .zip:

# cd /pasta/cs/cstrike
# unzip w-0.48.zip


Entre na pasta do metamod e edite o arquivo plugins.ini:

# cd /pasta/cs/cstrike/addons/metamod
# vi plugins.ini


Adicione a seguinte linha no arquivo:

~ linux addons/w/dlls/w_mm_i386.so

Salve o arquivo e reinicie/starte o seu servidor, para acessar utilize:

http://ip:porta

A senha para login é a senha do rcon, definida no server.cfg.

Abraços

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Como escrever dicas e artigos para o VOL?

Instalando Point Linux

Trabalhando com dois monitores e duas placas de áudio ao mesmo tempo

Checando dependências de pacotes em Debian Linux e derivados

Transmission - Gerenciar torrent via web em servidor

  

Comentários
[1] Comentário enviado por rafaelzk em 06/10/2007 - 13:02h

Boa Tarde,

Tenho o server Dedicado porem nao esta dando certo.

Fiz exatamente o explicado e nao esta habilitando o WEBMOD.

Estou usando Admin MOD 2.50.60 + METAMOD 1.19 que roda normalmente. menos o WEBMOD.

Se tiver algo para acrescentar podem postar aki.
Obrigado,
Rafael

[2] Comentário enviado por Érico Schuch em 04/12/2007 - 21:13h

o mesmo está acontecendo comigo.
Segui as orientações de http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=6170
Li toda a página do webmod ... mas não vai de maneira nenhuma.
Alguem tiver uma dica, posta ai. Valeu

[3] Comentário enviado por those em 13/12/2007 - 18:35h

o que acontece, detalhem os erros que fica mais facil explicar.

[4] Comentário enviado por felipeh91 em 17/12/2007 - 19:56h

o "~" na frente do "linux addons/w/dlls/w_mm_i386.so"

ta certo?

[5] Comentário enviado por felipeh91 em 20/12/2007 - 21:17h

O Webmod simplesmente não roda... eu uso Red Hat, e da erro na hora de carregar na lista de plugins...



meta list
Currently loaded plugins:
description stat pend file vers src load unlod
[ 1] <w_mm_i386.so> badf load w_mm_i386.so v - ini - -
[ 2] AMX Mod X RUN - amxmodx_mm_i386. v1.8.0.3 ini Start ANY
[ 3] Fun RUN - fun_amxx_i386.so v1.76 pl2 ANY ANY
[ 4] CStrike RUN - cstrike_amxx_i38 v1.76 pl2 ANY ANY
[ 5] CSX RUN - csx_amxx_i386.so v1.76c pl2 ANY ANY
5 plugins, 4 running

[6] Comentário enviado por Érico Schuch em 20/12/2007 - 22:35h

Rodou !
Refiz toda a instalação seguindo http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=6170
e então instalei como descrito no artigo.
Veja meu arquivo plugins.ini :
linux addons/adminmod/dlls/admin_MM_i386.so
linux addons/statsme/dlls/statsme_mm_i386.so
linux addons/w/dlls/w_mm_i386.so

Parei de executar como root e executei tudo com um usuário comum. Inclusive a instalação e até mesmo o servidor. Agora está muito bom.
Rodo o servidor com ./hlds_run -game cstrike +sv_lan 1 +ip 10.33.213.12 -heapsize 100000 -nomaster +maxplayers 12 +map de_dust -debug &
Em um servidor com somente 128 de memória. Coloco 12 jogadores sem problemas. E é um ADM de 1Ghz. Obrigado pelas dicas !
PS: É um Conectiva 10 que estava jogado no canto que agora faz a alegria do pessoal do escritório nos intervalos.

[7] Comentário enviado por xxpanicoxx em 23/01/2008 - 22:34h

pessoal preciso muito de ajuda, meu webmod nao fais logon, tpw eu consigo abrei o webmod e tals ver as pessoas conectadas no server mais nao consigo fazer login para trocar de mapa e tals tpw mexer nas configurações, eu so consigo visualizar a pagina inicial, quando aperto apra fazer login ele bolta para a pagina inicial e fica nesse loop, por favor quem puder me ajudar, ja atualizai o meta mod pra versa 1.19 e nada, pesso muito a ajuda de voces pois vou fazer um camp de cs e estou com o server pronto mais nao consigo ageitar o web mod. agradeço muito a quem puder me ajudar. muito obrigado

[8] Comentário enviado por xxpanicoxx em 23/01/2008 - 22:38h

opa so corrigindo eu atualizei da versao 1.17.2 para 1.17.4

[9] Comentário enviado por 206source em 01/08/2008 - 11:54h

tinha que excluir esse artigo =P
webmod so pra nego owna teu servidor. inda mais se for sv windows.

[10] Comentário enviado por killer_val em 14/09/2008 - 16:56h

nao consigui instalar tb ja fiz de tudo uso como root no ubuntu
badf load

[11] Comentário enviado por those em 15/09/2008 - 08:22h

206source consegue owna o server sendo webmod no linux? acho que essa falha
é pra servidores windows viu. Como ERA o caso dos servidores do "Server Striker".

o que acontece Killer? qual mensagem.

[12] Comentário enviado por killer_val em 15/09/2008 - 09:15h

<w_mm_i386.so> badf load w_mm_i386.so v - ini - -
dando essa mensagen coloquei certinho a pasta w dentro da pasta addons e ativei no metamod no linux
e mesmo assim nao deu certo baixei do sei baixei de outro site o a versao 0.49e nada
fui no server.cfg e coloquei essa linha
webmod_pass "senha' E NADA

[13] Comentário enviado por those em 15/09/2008 - 10:11h

bom, pesqueisando aqui, o problema não é no webmod
e sim alguma lib que você não tem instalado.

Talvez te ajude.
http://djeyl.net/forum/index.php?showtopic=47847

[14] Comentário enviado por killer_val em 15/09/2008 - 13:41h

cara li e nao entendi esse site os meus plugins esta assim veja
ently loaded plugins:
description stat pend file vers src load unlod
[ 1] AMX Mod X RUN - amxmodx_mm_i386. v1.8.0.3 ini Start ANY
[ 2] HL-Booster RUN - booster_mm.so v1.36 ini Chlvl Pause
[ 3] HLGuard RUN - hlguard_mm_optim v1.8 ini Chlvl Chlvl
[ 4] <w_mm_i386.so> badf load w_mm_i386.so v - ini - -
[ 5] sxei RUN - sxei_mm_i386.so v6.0.1.7 ini ANY ANY
[ 6] ClanMod RUN - clanmod_mm_i586. v1.82b1 ini Pause Pause
[ 7] STATSME RUN - statsme_mm_i386. v2.8.3 ini Chlvl Chlvl
[ 8] Fun RUN - fun_amxx_i386.so v1.8.0.3 pl1 ANY ANY
[ 9] Engine RUN - engine_amxx_i386 v1.8.0.3 pl1 ANY ANY
[10] FakeMeta RUN - fakemeta_amxx_i3 v1.8.0.3 pl1 ANY ANY
[11] CStrike RUN - cstrike_amxx_i38 v1.76 pl1 ANY ANY
[12] CSX RUN - csx_amxx_i386.so v1.8.0.3 pl1 ANY ANY
[13] Ham Sandwich RUN - hamsandwich_amxx v1.8.0.3 pl1 ANY ANY
13 plugins, 12 running

[15] Comentário enviado por killer_val em 17/09/2008 - 09:05h

nada cara

[16] Comentário enviado por killer_val em 19/09/2008 - 09:33h

refiz tudo novamente e nada deu certo ate reinstalei o ubuntu mesmo erro

[17] Comentário enviado por killer_val em 24/09/2008 - 16:59h

deu certo o problema e so entrar aqui que tem o arquivo e so substituir por aquele que tem no w/dlls por este neste link
http://djeyl.net/forum/index.php?act=Attach&type=post&id=342888

[18] Comentário enviado por killer_val em 24/09/2008 - 17:07h

eu uso o linux ubunto e deu certinho e so substituir e ja era seja feliz kkk

[19] Comentário enviado por fuzionbrasil em 19/01/2009 - 22:32h

ola eduardo e possivel eu criar o webmod com o windows xp?
me responde por favor
obrigado e ate mais

[20] Comentário enviado por those em 20/01/2009 - 09:17h

creio que sim, pois é um "serviço WEB",
basta você ter o apache devidamente configurado
( não sei quanto ao IIS como se comportaria pois nunca fiz o teste).

[21] Comentário enviado por killer_val em 04/12/2009 - 23:04h

Para o arquivo linux baixem esse arquivo no meu site
www.killerbrasil.com.br/programas/w.zip">http://www.killerbrasil.com.br/programas/w.zip

pacote completo tanto para 32 e 64 bits

valeu baixem e aproveitem
qualquer coisa mande
e-mail: [email protected]
site www.killerbrasil.com.br
gratooo...

www.killerbrasil.com.br/programas/w.zip">http://www.killerbrasil.com.br/programas/w.zip

[22] Comentário enviado por lucask14 em 22/12/2009 - 19:24h

Olá , estou com um problema . O problema é o seguinte , eu instalei ele normal pego ele certinho mas ta acho com algum erro ou eu nao to conseguindo instalar . Ele quando voce clica "Rcon Login" ele recarrega a pagina mas nao pega . Por favor alguem me ajuda .
MSN : [email protected]

[23] Comentário enviado por killer_val em 23/12/2009 - 20:06h

No seu server.cfg adicione essa linha
rcon_password "suasenha"
a senha que vc colocar ai e o que vc vai entrar no Webmod qualquer manda e-mail
[email protected]



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts