Instalando o Cairo-Dock no Debian

Publicado por Linck Pavelski em 02/12/2011

[ Hits: 19.289 ]

 


Instalando o Cairo-Dock no Debian



Force o 'APT' a usar os repositórios dos desenvolvedores, e não os oficiais do Debian.

Para isso basta criar um arquivo "/etc/apt/preferences.d/cairo-dock".

Torne-se 'root' e execute:

# nano /etc/apt/preferences.d/cairo-dock

Copie e cole o conteúdo abaixo:

  Package: cairo-dock*
  Pin: origin download.tuxfamily.org
  Pin-Priority: 501


Depois salve e feche o Nano.

Agora vamos à instalação em si.

Ainda como 'root', adicione a GPG Key:

# wget -q http://download.tuxfamily.org/glxdock/repository/cairo-dock.gpg -O- | sudo apt-key add -

Abra sua 'sources.list' com o comando abaixo:

# nano /etc/apt/sources.list

E adicione as linhas:

### Cairo Dock Repository ###
deb http://download.tuxfamily.org/glxdock/repository/debian stable cairo-dock


Salve e feche a 'sources.list' e depois execute os comandos:

# apt-get update
# apt-get install cairo-dock cairo-dock-plug-ins


Pronto o Cairo-Dock está instalado!

Para iniciá-lo automaticamente, clique em: Sistema -> Preferências -> Aplicativos de Sessão.

Clique em adicionar e digite o conteúdo abaixo nos campos:
  • Nome: Cairo Dock
  • Comando: cairo-dock
  • Comentário: Barra de tarefas animada

Agora sempre que iniciar o Debian, o Cairo-Dock iniciará automaticamente.

Fonte:
Screen:
Paz e luz a todos.

Outras dicas deste autor

Instalando placa wireless Ralink 3090 no Debian 6 (Squeeze)

Remover os ícones lixeira, home, etc da área de trabalho no Debian

Leitura recomendada

Instalando fontes básicas para o Wine

Instalando uma placa de rede PCI Express Agere ET131x - Slackware 12

Vim como IDE de Múltiplas Linguagens - Inclusive AEL (Asterisk)

Biblivre 3 não reconhece o Postgres [Resolvido]

Samba 4 no Fedora 25

  

Comentários
[1] Comentário enviado por removido em 03/12/2011 - 11:38h

dica interesssante mas...

se a versão desse repositório for maior que a dos repositórios Debian não precisaria disso, pois seria daí que os pacotes seriam baixados.

a menos que lá em /etc/apt.conf você definisse a release padrão como squeeze, aí sim seria necessário essa alteração proposta por você.

em todo caso é uma boa dica, até porque esse pacote 'cairo-dock-plug-ins' não existe no repositório do Squeeze e o Cairo-Dock e seus plugins estão na seguinte versão: (2.1.3.10-3 Debian:6.0.3/stable [i386])

um abraço.

[2] Comentário enviado por linck_pavelski em 05/12/2011 - 09:48h

Sempre aprendendo!!!!

Obrigado!!

[3] Comentário enviado por sdmauro em 29/05/2013 - 10:39h

Ola bom dia,
não consegui instalar o cario-dock no Debian wheezy.

Mostra esse erro...

# apt-get install cairo-dock cairo-dock-plug-ins
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
cairo-dock-plug-ins : Depende: libdb4.7 mas não é instalável
Depende: libdbusmenu-glib1 (>= 0.3.3) mas não é instalável
Depende: libdbusmenu-gtk1 (>= 0.3.3) mas não é instalável
Depende: libetpan13 (>= 0.54) mas não é instalável
Depende: libindicator0 (>= 0.3.6) mas não é instalável
Depende: libwebkit-1.0-2 (>= 1.1.1) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Ja tentei instalar os pacotes separados mas não é possível.

Sem plugins mostra isso...

# apt-get install cairo-dock
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
cairo-dock : Depende: cairo-dock-plug-ins (>= 3.1.98) mas não será instalado
Depende: cairo-dock-plug-ins-dbus-interface-python (>= 3.1.98) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


[4] Comentário enviado por viniciusafs em 21/03/2017 - 12:32h

Valeu pela dica!
Mas se Alguém estiver com o Debian lendo isso, e só da um apt-get install cairo-dock e funciona.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts