Instalando driver proprietário da ATI no Ubuntu 9.04 para placas Legacy

Publicado por Marco em 16/08/2009

[ Hits: 14.111 ]

 


Instalando driver proprietário da ATI no Ubuntu 9.04 para placas Legacy



Depois de várias googladas, finalmente consegui resolver o meu problema, já que o driver open source radeon não chega perto da performance esperada e não tem o 3d. Então vamos lá.

Antes de tudo, isto é um "work-around/gambi/nojeira" para fazer o Ubuntu 9.04, ou pelo menos parte dele, suportar o driver proprietário da ATI.

O início do problema: o Ubuntu 9.04 vem com o xorg-server 1.6 e a ATI não libera mais drivers para os radeon, apenas para o radeon hd. Resolveremos isto instalando o xorg-server 1.5.

1) faça uma cópia do seu sources.list atual:

sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak

2) troque todas as palavras "jaunty" para "intrepid" (famoso replace all):

sudo gedit /etc/apt/sources.list

3) atualize seus pacotes (ou seria desatualize)

sudo apt-get update

4) remova o maldito xorg-server 1.6 e seus amigos incompatíveis:

sudo apt-get autoremove xserver-xorg gnome-session fast-user-switch-applet

5) instale os pacotes que funcionam!

sudo apt-get install xserver-xorg fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx libdrm2=2.3.1-0build1 gnome-session fast-user-switch-applet=2.24.0-0ubuntu6

6) se vamos querer manter o Ubuntu 9.04, não podemos atualizar os pacotes acima, para isso instale o wajig:

sudo apt-get install wajig

7) mandando o sistema não atualizar os pacotes:

sudo wajig hold xserver-xorg fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx libdrm2 gnome-session fast-user-switch-applet

8) recoloque o seu sources.list do jaunty de volta:

sudo cp /etc/apt/sources.list.bak /etc/apt/sources.list

9) para garantir que não foram removidas algumas coisas necessárias:

sudo apt-get install xorg gnome-core

10) reinicie o sistema e seja feliz...

glxgears

De 70fps pulei para 1700fps. Será que deu alguma diferença????

Espero que isto seja útil para vocês!

Outras dicas deste autor

Corrigindo erro do ADEPT no KUbuntu

Leitura recomendada

Configurando o Unity 2D

Instalação do Ocomon - 2.0-RC6.1 - Helpdesk de suporte e controle de inventário

Lançado o fórum Mageia no Brasil

Bentoo Linux (distro brasileira)

O Gimp, você sabia que...

  

Comentários
[1] Comentário enviado por marcops em 16/08/2009 - 22:20h

Galera esqueci de por o item
9.5)
aticonfig --initial
aticonfig --overlay-type=Xv


Grande abraço espero que seja util para voces

[2] Comentário enviado por dcbasso em 17/08/2009 - 09:20h

Caro colega, será que funciona com uma ATI RADEON X1200 (Integrated ATI Radeon X1250-based graphics), vem on-board na placa mãe da Asus: M2A-VM HDMI.

Mais detalhes em: http://usa.asus.com/products.aspx?l1=3&l2=101&l3=496&l4=0&model=1568&modelmenu=2

Eu já tentei instalar 3x, sendo uma o driver open, e toda vez depois que instalo e reinicio a imagem não volta, e o micro trava...
Será que funciona com ela este tutorial?

Abraçoss

[3] Comentário enviado por dcbasso em 17/08/2009 - 11:21h

Ninguem?

[4] Comentário enviado por marcops em 18/08/2009 - 09:39h

funciona sim, minha placa é uma ATI Radeon X1150 integrada, e funcionou perfeitamente, ela é justamente para este tipo de placa que virou legacy no xorg 1.6

[5] Comentário enviado por eududa em 28/08/2009 - 13:43h

boa dica essa!
tenho um notebook toshiba A215 - s4757, com o jaunty, e tive muitos problemas com a resolução do vídeo, piscando a tela e tudo mais...
deu muito certo esse downgrade, eu não instalei o wajig pra bloquear, simplesmente fui no synaptie e busquei os pacotes e travei a atualização dos mesmos, adicionando bloqueio aofglrx-amdccle;fglrx-modaliases;xserver-sorg-core..
reiniciei a máquina e tudo blz...

[6] Comentário enviado por andre.berenguel em 30/08/2009 - 21:55h

Tenho uma Radeon 9550 offboard, ou seja, legacy :(

Tentei fazer o downgrade aqui no meu Kubuntu, mas só deu certo até uma certa parte.
A inicialização do kdm ocorria normalmente, porém ao efetuar o login, a máquina trava e tem que reiniciar.
Instalei o fluxbox do repositorio do intrepid e consegui rodar. Ficou instável e não deu suporte a glx.
O jeito foi voltar pro xserver-xorg-core 1.6.0 do Jaunty.

Será que tem alguma maneira mais "Jaunty" de se realizar esse downgrade??


Pro kubuntu, tive que ignorar os pacotes gnome-session e fast-user-switch-applet. Será que há equivalentes a esses no kde e que também devem ser "downgradeados"?



[7] Comentário enviado por valtincomp em 04/09/2009 - 16:16h

Caro amigo, vc poderia me informar esse procedimento funcionaria no Kubuntu 9.04?
tenho uma ati radeon hd 3200.

[8] Comentário enviado por ygalves em 07/09/2009 - 13:54h

Olá! Estava tentando este procedimento a algum tempo, mas você me adiantou muitos passos. Obrigado mesmo. Porém ainda continuo com um problema. Talvez seja por conta da desatualização do gnome-session, os botões de desligar, como a tela de finalizar a sessão sumiram. Alguma idéia? Contudo, parabéns pela boa dica.

[9] Comentário enviado por marcops em 07/09/2009 - 21:52h

sim por causa da desatuialização do gnome-session acaba perdento estes detalhes, infelizmente ainda nao achei como contornar isto, assim que conseguir posto a resposta aqui,

sobre o kubuntu, provavelmente vai ter que fazer downgrade de alguns pacotes, mas nao sei quais, assim que descobrir vou postar, ;)

[10] Comentário enviado por erickcf em 28/09/2009 - 20:59h

Já fiz o teste com o Ubuntu 9.04 e 8.04 e nada ainda com a minha ATI X1200 vou fazer um teste amanhã e se funcionar irei postar aqui.

[11] Comentário enviado por bernardoferri em 29/09/2009 - 12:27h

ola pessoal
em primeiro lugar parabens pela dica

porem , ao tentar executar o passo
" 5) instale os pacotes que funcionam!

$ sudo apt-get install xserver-xorg fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx libdrm2=2.3.1-0build1 gnome-session fast-user-switch-applet=2.24.0-0ubuntu6 "

recebo o erro
E: Versão '2.3.1=0build1' para 'libdrm2' não foi encontrada.


o que posso estar fazendo de errado ??
achei que fosse o 0 de 0build1 , ja troquei pra 0 e pra O e nada de funcionar ... o que pode ser ???

[12] Comentário enviado por gfenrrir em 16/12/2009 - 10:30h



Cara o que acontece para mim é isso:
sudo apt-get install xserver-xorg fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx libdrm2=2.3.1-0build1 gnome-session fast-user-switch-applet=2.24.0-0ubuntu6
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da “Incoming”.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
fast-user-switch-applet: Depende: gdm mas não será instalado
E: Pacotes quebrados

Depois disso não vai tento instalar o fast-user-switch-appet mas fala que está indisponivel no repositorio

Alguma solução?

Abraços =)

[13] Comentário enviado por samuel.vorpagel em 12/06/2010 - 10:08h

Desculpe se for uma pergunta boba

no comando


2) troque todas as palavras "jaunty" para "intrepid" (famoso replace all):

$ sudo gedit /etc/apt/sources.list

fiz e abrio o gedit

deb http://packages.linuxmint.com/ isadora main upstream import backport romeo
deb-src http://packages.linuxmint.com/ isadora main upstream import backport romeo #Added by software-properties
deb http://packages.linuxmint.com/ isadora-lxde main upstream import
deb http://archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ lucid partner
deb http://packages.medibuntu.org/ lucid free non-free

deb http://archive.getdeb.net/ubuntu lucid-getdeb apps
deb http://archive.getdeb.net/ubuntu lucid-getdeb games

ai queria saber como eu faço esse comando para mudar o "jaunty" para "intrepid" ?

obrigado se puderem me ajudar

obs. uso o linux Mint 9 lxde



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts