Instalando aMSN 0.96

Publicado por Paulo Volpato em 20/11/2006

[ Hits: 47.867 ]

 


Instalando aMSN 0.96




Antes de começar a instalar o aMSN você precisa dos pacotes TCL e TK em seus sistema Linux. Caso não tenha baixa ele ai nesse links:
Já baixou ele? Então vamos instalar!

Instalando o TCL:

$ tar -zxvf tcl8.4.5-src.tar.gz
$ cd tcl8.4.5
$ cd unix
$ ./configure
$ make
# make install
# exit
Instalando o TK:

$ tar -zxvf tk8.4.5-src.tar.gz
$ cd tk8.4.5
$ cd unix
$ ./configure
$ make
# make install
# exit


Feito tudo isso vamos instalar o aMSN 0.96.

Baixe o aMSN 0.96 nesse link:
Instalando o aMSN 0.96:

$ tar zxvf amsn-0.96.tar.gz
$ cd amsn-0.95
$ ./configure
$ make
# make install
# exit
$ ./amsn


Depois ele pede pra escolher qual módulo do seu Linux, aí depende do seu sabor e já vai poder usar seu aMSN livremente.

Lembrando que:
  • $ = Prompt de usuário comum;
  • # = Prompt de superusuário (root).

Para entrar como superusuário é só digitar "su", dar um enter e digitar a senha do root.

Qualquer duvida é só perguntar.
Valeu!

ÐarkAge

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Pje e o Código Aberto - Previsão em Lei

Como deixar o Waterfox em português

Autenticação ADSL residencial por 1 real por mês

Corrigindo erro do Firefox no Debian (libgtk-x11-2.0.so.0)

Emulador x86 em Javascript rodando GNU/Linux. Falta o que agora?

  

Comentários
[1] Comentário enviado por SlimBAAL em 20/11/2006 - 22:29h

bom, estou com uma duvida.

instalei o tcl como o descrito acima e deu tudo certo.
mais quando fui instalar o tk, apareceu a seguinte mensagem:

{standard input}: Assembler messages:
{standard input}:697: Error: symbol `dy' is already defined
{standard input}:703: Error: symbol `dx' is already defined
{standard input}:750: Error: symbol `q' is already defined
{standard input}:756: Error: symbol `p' is already defined
{standard input}:762: Error: symbol `q' is already defined
{standard input}:768: Error: symbol `q' is already defined
make: ** [tk3d.o] Erro 1

oq pode ser?

[2] Comentário enviado por tenchi em 21/11/2006 - 18:06h

Uma alternativa para deixar o amsn mais "bonitinho" é usar em vez do tcl e tk 8.4, usar o 8.5, que tem suporte a antialiasing... As fontes ficam muuito melhores...

[3] Comentário enviado por SlimBAAL em 22/11/2006 - 12:45h

mesmo tentando instalar o tk 8.5 ocorre o mesmo erro.

alguem pode me ajudar?

[4] Comentário enviado por lub em 25/11/2006 - 15:24h

Valeu DarkAge...
Deu tudo certo e consegui instalar e rodar numa boa!
Parabens ai pela dica!

[5] Comentário enviado por felipoter em 27/11/2006 - 14:10h

instalei o tcl mas o tk na hora do comando make naum foi
o q eu devo fazer?

[6] Comentário enviado por felipoter em 27/11/2006 - 14:26h

Comentário enviado por lub em 25/11/2006 - 15:24h:

Valeu DarkAge...
Deu tudo certo e consegui instalar e rodar numa boa!
Parabens ai pela dica!
vc mudo alguma coisa do q o darkAge disse???

[7] Comentário enviado por felipoter em 27/11/2006 - 14:55h

o meu tbm eh esse erro
but never defined
/home/kurumin/tk8.4.5/generic/tk3d.c:38: warning: `ShiftLine' declared `static'but never defined
{standard input}: Assembler messages:
{standard input}:697: Error: symbol `dy' is already defined
{standard input}:703: Error: symbol `dx' is already defined
{standard input}:750: Error: symbol `q' is already defined
{standard input}:756: Error: symbol `p' is already defined
{standard input}:762: Error: symbol `q' is already defined
{standard input}:768: Error: symbol `q' is already defined
make: ** [tk3d.o] Erro 1
[email protected]:~/tk8.4.5/unix$
me respondam plz

[8] Comentário enviado por DarkAge em 30/11/2006 - 15:27h

desculpe a demora, tinha esquecido a senha

verifica se vocês tem o gcc 3.4.3, se for 3.2.3 instala a 3.4.3

para verificar

# less /proc/version

[9] Comentário enviado por pimpocvl em 01/12/2006 - 14:26h

Olha eu tbem estou com o mesmo problema quando vou tentar instalar o TK, a minha versao do gcc e 3.4.5 ([email protected]lage.com.br)

[10] Comentário enviado por patriciacechet em 02/12/2006 - 15:08h

Bom...eu gostaria de saber como vcs conseguiram instalar esse amsn...eu não estou conseguindo fazer isso....
sempre da alguma coisa errada sei la ;s
vou deixar meu e-mail aki pra vcs me responderem...ok?
[email protected] Obrigada e por favor me ajudem...hehe...
Bjos!

[11] Comentário enviado por ludolfs em 03/12/2006 - 14:00h

Boa tarde
Quando executo ./configure aparece a seguinte mensagem no final "checking system version (for dynamic loading)... ./configure: line 7068: syntax error near unexpected token `)'
./configure: line 7068: ` OSF*)'
Meu gcc 4.1.2
obrigado

[12] Comentário enviado por luizff em 05/12/2006 - 00:58h

Olá.
Gostaria de instalar o aMSN 0.96 mais sempre aparece este erro ao executar o comando ./configure | Veja.
checking for prefix by checking for wish... /usr/bin/wish
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
[[email protected] amsn-0.96]$
agradeço muito se puderem me ajudar.
Obrigado.


[13] Comentário enviado por peixelahma em 20/12/2006 - 17:50h

Kra, tentei instalar o amsn seguindo seu tutorial:
Porem, nao deu certo. Logo depois que dou o ./configure pra instalar o amsn aprece uma msg q parece q é erro:

checking tcl build dir .... warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory

configure: error: Unable to find Tcl directory or Tcl package is not tcl-dev

Não tive problemas pra instalar o tcl e tk, segui certinho a ordem do tutorial. O meu gcc é 3.3.5 a versão. Bom, descompactei tudo dentro da pasta: ~/Programas/amsn

O que será que deu errado ?

[14] Comentário enviado por paulopugin em 16/01/2007 - 15:09h

segui todos os passos,
mas quando fui instalar o amsn deu o seguinte erro


[[email protected] amsn-0.96]# ./configure
checking for prefix by checking for wish... /usr/bin/wish
configure: error: Your current Tcl/Tk installation has a version number of 8.3. The minimal version required for aMSN to run is Tcl/Tk 8.4

[15] Comentário enviado por ranyele em 28/01/2007 - 12:35h

Ola pessoal, segui todos os passos mais da esse erro na hora de executar. O TCL e Tk estao instalados direitinho

./amsn
./amsn: line 3: exec: wish: not found

OS: Fedora Core 5

Muito obrigado

[16] Comentário enviado por evilrick em 10/02/2007 - 13:12h

Olá pessoal estou tendo um problema ao tentar compilar o amsn 0.96:
Quando eu tento dar make ele me retorna essa mensagem:

make
make: Nada a ser feito para `build'.

E se eu tento abrir o amsn ele me retorna uma janela com uma mensagem dizendo para compilar.

"You can't load TkCximage, this is now needed to run AMSN. Please compile amsn first, instructions on how to compile are located in the file INSTALL."

O que é que eu faço?
Alguém poderia me ajudar?

aqui está o resultado do ./configure:
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking tcl build dir... using tcl library in /usr/local/lib
checking tk build dir... using tk library in /usr/lib
checking for main in -lstdc++... yes
checking how to run the C preprocessor... gcc -E
checking for X... libraries /usr/X11R6/lib, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... no
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for png_read_info in -lpng... yes
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for jpeg_CreateDecompress in -ljpeg... yes
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking jerror.h usability... yes
checking jerror.h presence... yes
checking for jerror.h... yes
checking for ftello... yes
checking for fseeko... yes
checking for getpt... yes
checking for strcasestr... yes
checking for memmem... yes
checking for dlopen... no
checking for pthread_create in -lpthread... yes
checking if mmx should be used... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating utils/linux/capture/config.h
config.status: utils/linux/capture/config.h is unchanged

compile time options summary
============================

X11 : yes
Tcl : 8.5
TK : 8.5
DEBUG : no
STATIC : no

[17] Comentário enviado por gabrielsimas em 17/02/2007 - 12:22h

Senhores,
quando tentei instalar também recebi a mensagem de erro, mas utilizando a dica do amigo DarkAge, atualizei para a versão 8.5 e funcionou. O link para a versão da tcl e tk segue abaixo:
http://www.tcl.tk/software/tcltk/choose.html

Depois é só seguir as instruções do artigo.
Amigos, agora um truque:
quando digitamos make a tela fica totalmente poluída com intruções e afins sendo mostradas e roladas.
Para acabar com isso, digite make -s que ele só nos mostrará as mensagens de erro.

abraços.

LGNS

[18] Comentário enviado por Kushima em 24/02/2007 - 02:26h

e ae pessoal

bom, na hora que fui digitar ./amsn ele deu a seguinte mensagem:

falha de segmentação.

espero q possam me ajudar,

abraço

[19] Comentário enviado por garetiro em 01/03/2007 - 14:28h

para vcs que queiram fazer o download do amsn 0.96 vai la nesse site http://amsn.sourceforge.net , E escolha a opção fazer download e baixe como nome no final PACKAGE..

Qualquer coisa so mim perguntar eu tenho as fotus de como ensinar instalar o amsn 0.96...

Grato:
Gabriel Freitas (((Santo Antônio do Retiro)))

[20] Comentário enviado por will°° em 04/03/2007 - 23:56h

Naum consigo instalar o amsn
cara eu baixei o tk e o tcl mas oq eu faço agora?
eu li todos os posts
mas tipow
ond eu faço todos aqueles comandos?
tipow
eu quando clico no amsn aparece um erro
eh esse aki oh

Could not find 'TCL Scripting Language'. Try using the native package manager for Gentoo (emerge) to install a package with similar name to 'tcl'.

Erro: Não foi possível preparar o pacote AMSN MSN client.

desculpe minha nbisse mas me ajude
vlw!!

[21] Comentário enviado por linus black em 25/03/2007 - 22:24h

eu tambem estou com problemas eu uso o debian
o mesmo problema que aconteseu com os companheiros acima

[22] Comentário enviado por linus black em 26/03/2007 - 18:51h

cara consegui instalar no slackware 10.2 sem erro no debian n'ao rolou mai mesmo assim obrigado!!!!

[23] Comentário enviado por urick em 08/04/2007 - 17:21h

ai, o mew deu esse erro abaixo, alguem pode me ajudar?

checking for ranlib... ranlib
checking if 64bit support is requested... no
checking if 64bit Sparc VIS support is requested... no
checking system version (for dynamic loading)... ./configure: line 7068: syntax error near unexpected token `)'
./configure: line 7068: ` OSF*)'

Vlw

[24] Comentário enviado por claro.vanessa em 13/04/2007 - 21:48h

Gente!!!

Naum consigo instalar nada direito no linux, ... tm essa coisa d compactar e descompactar..... q eu nunk sei pra q serve.
E esses comandos?
Ond eu coloco isso?
Tm algum lugar q eu aprenda o básico do básico... to a horas tentando instalar o amsn e nada ... =[

Valew

Vanessa

[25] Comentário enviado por vodailha em 27/04/2007 - 16:52h

Olá, sou novo aqui no site, e de cara quero parabeniza-los por prover tanto conteúdo.
Estou com um problema, estou tentando instalar os aplicativos listado nesta dica. Porém não estou conseguindo instalar nenhum dos programas: TLC, amsn. Sempre ocorre o erro:
Grupo:/home/wjunior/downloads/tcl8.4.5/unix # ./configure
loading cache ./config.cache
checking whether to use symlinks for manpages... no
checking compression for manpages... no
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
Grupo:/home/wjunior/downloads/tcl8.4.5/unix #

Acontece o mesmo quando tento instalar o amsn, obrigado

[26] Comentário enviado por kranyo em 12/07/2007 - 11:27h

é o seguinte...
queria que alguém me explicasse por que não tem nenhum makefile nesses dois arquivos que esse kra mandou baixar...
quando executo o make tanto pro tcl qnto pro tk da um erro la...

preciso de ajuda...

vlew!!!

[27] Comentário enviado por removido em 18/09/2007 - 13:30h

Pra quem teve este erro:

checking system version (for dynamic loading)... ./configure: line 7068: syntax error near unexpected token `)'
./configure: line 7068: ` OSF*)'

é necessário apagar a aspa simples que está na linha
system=AIX-`uname -v`.`uname -r' que fica um pouco antes la linha 7068 do arquivo configure.

Ana

[28] Comentário enviado por predador em 14/10/2007 - 17:37h

cara eu t com o seguinte problema. Eu baixei os aquivos q vc falou o TCL e o TK. Mas quando eu vou dar o camando "tar" no TCL aparece o seguinte:
"tar: tcl8.4.5-src.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed fron previous erros"
Se puder m ajudar aiii.
valeuu

[29] Comentário enviado por paulopugin em 15/10/2007 - 14:24h

Tenho outra dica, que eu peguei acho que até aqui no VOL, dai incrementei mais um esquema e ficou ok, acho que está dica funciona em todos, testei no Kurumin e no Suse
baixe o aMSN0.97RC1.tar.bz2 no link http://sourceforge.net/project/showfiles.php?group_id=54091

feito isso apenas para ficar mais organizado nosso sistema vamos move-lo para a pasta de binarios
#mv amsn-0.97RC1.tar.bz2 /usr/local/
#cd /usr/local/
#tar -jxvf amsn-0.97RC1.tar.bz2
#cd amsn-0.97RC1

agora vamos resolver o problema das pendencias dele:
#apt-get update
#apt-get install tcl8.4-dev
#apt-get install tk8.4-dev
#apt-get install libpng12-dev
#apt-get install libjpeg62-dev
###no Suse eu não usei o -dev
dpois basta instalar normalmente:
#./configure
#make
#make install

teste agora
se o msn der o erro "Erro ao instalar módulo TLS::Couldn't get
http://switch.dl.sourceforge.net/sourceforge/amsn/tls.1.4.1-linux-ppc.tar.gz"
Baixe o tcl só para indicar ao amsn onde ele está

descompacte dentro da pasta /usr/src/tls-1.5
depois vá no msn e escolha

msn>Conta>Preferências>Avançado>Outros, lá aponte para a pasta /usr/src/:

depois disto deve funcionar normalmente

[30] Comentário enviado por paula.cantanhede em 24/01/2008 - 13:15h

Olá ÐarkAge,

Vou perguntar algo sem cabemento, mas não tem outra alternativa...

Quando você começa a explicar os passos da instalação dos dois programas necessários para a instalação do amsn, tudo bem, consegui baixar no meu pc.

Mas quando vc fala que é hora de instalar e lista uma programação, eu não sei pra onde vai.... onde agente escreve aqueles comandos????

Vocês poderiam me ajudar nesse ponto, me explicando o bê-a-bá????

Sou totalmente leiga em relação ao linux, estou me deparando pela primeira vez com ele, hoje...

Obrigada.

Paula Cantanhede

[31] Comentário enviado por paulopugin em 24/01/2008 - 14:32h

Paula,
Aperta Alt+F2, na telinha que abrir digita konsole, e tecla enter.
Vai abrir algo parecido com o MS-DOS, nesta tela você digita os comandos que o Dark Age passou.
Tu sabe a senha do usuario root? qual distribuição tu usa?

[32] Comentário enviado por paula.cantanhede em 24/01/2008 - 14:57h

Olá Paulo, vc é um amor!!!

Obrigado pelo auxilio...

Quando eu coloquei a palavra konsole, apareceu a seguinte mensagem:

Não foi possível abrir o local 'file:///konsole'
O local ou arquivo não foi encontrado.

Eu tenho sim a senha do usuário root, mas a distribuição???
Seria ubuntu???

Desculpe não conheço os termos utilizados no linux...

Beijos!

Paula Cantanhede

[33] Comentário enviado por paula.cantanhede em 24/01/2008 - 15:03h

Oi Paulo!
Vc bem que poderia me enviar o seu telefone, né?
Mande para o meu e-mail: [email protected]
Agente poderia conversar logo sobre esse assunto, de quebra ficariamos amigos e vc me daria umas aulinhas sobre linux.
O que vc acha?
Bjs
Paula

[34] Comentário enviado por paulo.cesar em 21/06/2008 - 16:28h

Ola pessoal...

fui instalar o amsn seguindo estes passos e me deparei com o seguinte erro...

[email protected]:~/tcl8.4.5/unix# ./configure
loading cache ./config.cache
checking whether to use symlinks for manpages... no
checking compression for manpages... no
checking for gcc... gcc.3.4
checking whether the C compiler (gcc.3.4 ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.


como devo tratá=lo para conseguir concluir a instalção...


obrigado

[35] Comentário enviado por rogertaylor69 em 26/04/2009 - 21:00h

Pelo amor de Deus alguem me ajude! Instalei o Ubuntun, mais ainda to apanhando aqui, caramba e muito dificil instalar alguma coisa no linux, muito complicado, o windows e so execultar e pronto, mais no linux e dureza em! Nao sei nem onde gigitos esses comandos, se e no tal de terminal ou sei la onde. Quero aprender, mais ta dificil, se alguem poder dar umas dicas, agradeço!

[36] Comentário enviado por TIERGG18 em 24/12/2009 - 23:45h

A VERDADE DOS FATOS É QUE ESSE SISTEMA LINUX E SIMILARES SAO TODOS UMA PORCARIA. TUDO PRECISA DE COMANDOS DO TEMPO DO DOS! QUE É ISSO?
APESAR DO RWINDOWS SER RWINDOWS, MAS A INTERFACE, FUNCIONAMENTO DÁ DE DEZ A ZERO NESSA PORCARIA DE LINUX! MEU AVÓ SEMPRE DISSE: TUDO QUE É DE GRAÇA DEVEMOS DESCONFIAR. VEJO Q ELE ESTÁ CERTISSIMO! QUE ATRASO E PERDA DE TEMPO DIGITAR COMANDOS E MAIS COMANDO PRA NO FINAL NAO FUNCIONAR M... NENHUMA! FUI....
NAO É ATOA QUE O RWINDOWS É O MAIS USADO NO MUNDO...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts