Instalando Atheros AR5007EG no (K)Ubuntu/Debian sem complicações

Publicado por Paulo H. Gomes Alves em 21/05/2008

[ Hits: 13.732 ]

Blog: http://paulinholinux.blogspot.com/

 


Instalando Atheros AR5007EG no (K)Ubuntu/Debian sem complicações



Este é meu segundo artigo na comunidade Linux e destina-se a pessoas que utilizam a placa wireless Atheros AR5007EG e estão com dificuldades para realizar sua instalação no (K)Ubuntu/Debian.

Introdução

E aí pessoal...

Bom, não sou o que se pode chamar de cara perito em Linux, sei também que ainda estou longe disso, mas toda vez que sinto que posso somar para a comunidade com certeza não meço esforços.

Este passo-a-passo foi testado apenas no (K)Ubuntu/Debian, ainda não tive tempo e testá-lo em outras distros, mas creio que o procedimento seja o mesmo.

Então vamos ao que realmente interessa :)

Bem vindo ao futuro, Seja livre use L I N U X !!!!

Instalando Atheros AR5007EG no (K)Ubuntu/Debian sem complicações

Antes de prosseguir verifique se o pacote build-essential está instalado, se caso não tiver, realize a instalação do mesmo através do comando:

# apt-get install build-essential

Primeiramente, vamos baixar o pacote madwifi-ng-r2756+ar5007.tar.gz do site e salvá-lo na sua pasta /opt. Ainda como root siga os passos a seguir:

# cd madwifi-ng-r2756+ar5007
# make clean
# make
# make install


Reinicie e veja se os módulos estão sendo carregados senão carregue com:

# modprobe ath_pci
# modprobe wlan_scan_sta


Para que os módulos sempre iniciem ao carregar o sistema digite os seguintes comandos:

# echo "wlan" >> /etc/modules
# echo "ath_hal" >> /etc/modules
# echo "ath_pci" >> /etc/modules
# echo "wlan_scan_sta" >> /etc/modules


Após realizar estes passos simples a sua placa wireless já estará funcionando, basta agora você ir em Sistema / Administração / Rede e realizar a configuração do seu AP.

Conclusão

Espero que tenham gostado, e que este artigo seja de alguma forma útil a comunidade.

Muito obrigado pela oportunidade de ajudar algumas pessoas.

OBS: Este passo-a-passo funcionou perfeitamente em meu sistema, não posso garantir que vá funcionar com o seu.

Muito obrigado a todos da lista ubuntu-br@lists.ubuntu.com por todas as dúvidas que sanaram.

Paulo H. Gomes Alves
3SGT MNT COM - 14GAC
paulinholinux [arroba] yahoo [ponto] com [ponto] br

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Como recuperar o Grub do seu Ubuntu

Configurando Samba e colocando algumas permissões para usuários

VNC entre Windows e Linux com Hamachi e Haguichi

FreeNX - Evolução remota

Instalando o kiba-dock (atualizado)

  

Comentários
[1] Comentário enviado por paulinholinux em 22/05/2008 - 10:10h

Galera faltou um detalhe, o link do site para baixar o pacote madwifi-ng-r2756+ar5007.tar.gz


http://snapshots.madwifi.org/special/madwifi-ng-r2756+ar5007.tar.gz

Bom acho que é isso ... boa navegação a todos :D

PaulinhoLinux

3SGT PAULO MNT COM

[2] Comentário enviado por aureliosaraiva em 23/05/2008 - 11:29h

ele funciona em AMD64

[3] Comentário enviado por paulinholinux em 24/05/2008 - 07:45h

aurelio eu ainda não tive a oportunidade de testar em sistemas AMD64, mas na primeira oportunidade gostaria de realizar este teste.

[4] Comentário enviado por mazzucco em 24/05/2008 - 17:49h

?comentario=Maravilha... perdi muitas horas tentando fazer o wireless fucionar no meu ubuntu, não consegui e acabei desistindo, essa semana recebi um email do dicas-L indicando este tutorial, depois de meses sem conexão wireless no meu note, resolvi dar uma olhada e tentar mais uma vez e finalmente funcionou :)

valew

mazzucco

[5] Comentário enviado por paulinholinux em 25/05/2008 - 12:29h

e ai mazzucco, blzzz ....

muito obrigado pela dica e fico feliz por saber que com essa dica consegui ajudar alguém a resolver um problema (que estava tendo) instalação deste modelo de Atheros.

um abraço e até +

PaulinhoLinux

[6] Comentário enviado por hcbjunior em 06/06/2008 - 23:30h

Ola Paulinho, tudo bem!!
Bom, como muitos amigos da comunidade tive dor de cabeça com essa placa, e me parece que voce finalmente achou a solução..., eu quero saber entao exatamente qual linux voce usou, versao e tudo mais.

Obrigado, abraço.

[7] Comentário enviado por paulinholinux em 07/06/2008 - 19:46h

Olá hcbjunior ....

Eu utilizei para este teste o Ubuntu e Kubuntu 7.04, 7.10, 8.04, (acho que deverá funcionar tbem no Xubuntu e Edubuntu, por serem distros próximas, mas ainda não tive a oportunidade de testar)

Tbem realizei meus testes com o Debian 4.0 etch

em outras distros ainda não realizei o teste.

Muito Obrigado pelo comentário !!

PaulinhoLinux
(Yabadabadooo)

[8] Comentário enviado por dantusbr em 17/07/2008 - 13:12h

Parabéns meu amigo! Estive em encrencas sérias devido ao meu laptop, um acer aspire 5315-2290 com 2Gb RAM. O módulo APIC é problematico. Desabilitei o APM e o APIC no boot. Meu calcanhar de aquiles era o módulo wi-fi. Atheros sofre do mal de win-modem (iearc!), mas com sua dica e o driver com patch madwifi, meus problemas acabaram.

[9] Comentário enviado por admtempos em 01/10/2008 - 11:56h

muito bom este post ante eu nao estava conseguinto usar ele mais aogra ja estou conseguim

uma duvida quem sabe usar o kismet com este drive poderia me ajudar

[10] Comentário enviado por jeferbd em 15/08/2009 - 18:58h

seguindo estes passos
ao executarocomando lspci, começou a ser identificada a placa correta????

estou com um acer aspire one de 11.6" com esta placa de rede
ja fiz e refiz estes passos e outros tutoriais parecidos
nao esta funcionando
a placa em si identifica as redes e tudo
porem nao conecta

[11] Comentário enviado por paulinholinux em 15/08/2009 - 20:04h

Olá jeferbd ...

Não possuo mais o notebook da acer (de quando escrevi esse artigo), então fica um pouco difícil de te ajudar a resolver este problema. Na data que fiz esta instalação não me lembro da versão do kernel que estava instalado em meu Ubuntu, mas te aconselho a instalar o Kubuntu, Ubuntu ou Debian 4 (qdo fiz esta instalação ainda não tinham lançado a versão 5 por isso não sei se funciona na versão 5), e seguir os passos novamente sem atualizar a sua distro.
Se com essa dica funcionar, tente atualizar a sua distro e observar seu funcionamento.

Até mais

PaulinhoLinux



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts