Impressora Canon Pixma IP1800 no Linux

Publicado por Perfil removido em 13/04/2010

[ Hits: 8.999 ]

 


Impressora Canon Pixma IP1800 no Linux



Recentemente um usuário solicitou apoio para instalar sua Canon Pixma IP1800 no Linux, pacote *.deb, mas as dependências eram inconciliáveis nas distros atuais.

Seguem abaixo os drivers reempacotados em *.deb, que funcionam no Ubuntu Karmic sem conflito de dependências. Basta instalar com um "sudo dpkg -i pacote1 pacote2".

A seguir, faça na ordem:

$ cd /usr/lib
$ ls -la libtiff


Deve aparecer um resultado próximo a este:

lrwxrwxrwx 1 root root     16 2010-04-03 14:22 libtiff.so.4 -> libtiff.so.4.2.1
-rw-r--r-- 1 root root 358384 2009-07-14 09:59 libtiff.so.4.2.1

Veja que "libtiff.so.4" é um link simbólico para "libtiff.so.4.2.1". Vamos criar um para a libtiff.so.3 que o driver desta Canon utiliza:

$ sudo ln -s libtiff.so.4.2.1 libtiff.so.3

Agora instale o pacote abaixo, no terminal e conectado na internet:

$ sudo apt-get install libpng3

Terminado todo este processo, basta apenas configurar sua impressora segundo o procedimento padrão para sua distro.

Para quem usa GNU/Linux com pacotes *.rpm, seguem os mesmos drivers que deverão ser instalados da seguinte forma, também no terminal:

$ sudo rpm -ivh pacote1 pacote2

O procedimento da libtiff também deverá ser realizado, incluso a instalação dalibpng3 de acordo com o procedimento padrão da sua distro.

Pacotes *.deb:
Pacotes *.rpm:
Até a próxima dica!!!
;-)

Referência: http://twixar.com/vpwg

Outras dicas deste autor

Fazendo o Firefox mostrar as imagens do Orkut

Usando o tar.xz + várias threads e compactação extrema

NCFTP - Upload recursivo via FTP em apenas uma linha

Problema com Codecs e Plugins de Áudio e Vídeo - Debian/derivadas + Fedora

Problema de vídeo ao instalar o Debian 5 em notebook intelbras i21

Leitura recomendada

Overclock de maneira rápida e prática pelo nvclock (texto)

Pendrive montando automaticamente no Fedora Core 7

Fazendo o scanner GOTEC funcionar no Ubuntu

Nvidia 64 TV OUT no Slackware 12.0

Quickcam Express - configurando módulo (Ubuntu 9.10)

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts