Escolhendo o driver nVidia apropriado para sua placa

Publicado por marcus v gonçalves em 20/06/2007

[ Hits: 24.640 ]

 


Escolhendo o driver nVidia apropriado para sua placa



Essa dica é mais voltada para usuários do SuSE, mas se enquadra para outras distribuições.

Para essa atualização, quando você utilizar o YaST ou indo ao site da nvidia se depara com as opções:

Graphics Drivers

.......... Tanto em 32 como em 64 bits

Latest Version: 100.14.09
Latest Legacy GPU version (1.0-71xx series): 1.0-7185
Latest Legacy GPU version (1.0-96xx series): 1.0-9639

Pronto formou-se uma dúvida, pois é impossível instalar a versão 100.14.09, 1.0-7185 ou 1.0-9639 (nvidia-gfxG01-kmp-bigsmp-100.14.09, x11-video-nvidia e nvidia-gfx-kmp na indicação do YaST) por motivo de conflito entre elas.

Olhando detalhadamente o readme dá pra ver que a versão 100.14.09 é mais adequada para as placas:
  • GeForce 8600 GTS
  • GeForce 8600 GT
  • GeForce 8600M GT
  • GeForce 8600M GS
  • GeForce 8500 GT
  • GeForce 8400 GS
  • GeForce 8400M GT
  • GeForce 8400M GS
  • GeForce 8400M G
  • GeForce 8300 GS
  • Quadro FX 1600M
  • Quadro FX 570M
  • Quadro FX 360M
  • Quadro NVS 320M
  • Quadro NVS 140M
  • Quadro NVS 135M
  • Quadro NVS 130M
  • Quadro FX 4600 G-Sync and Quadro FX 5600 G-Sync boards

Se você possui uma das placas:

GeForce2 MX/MX 400
GeForce2 MX 100/200
GeForce2 Go
Quadro2 MXR/EX/Go
GeForce4 MX 460
GeForce4 MX 440
GeForce4 MX 420
GeForce4 MX 440-SE
GeForce4 440 Go
GeForce4 420 Go
GeForce4 420 Go 32M
GeForce4 460 Go
Quadro4 550 XGL
GeForce4 440 Go 64M
Quadro NVS
Quadro4 500 GoGL
GeForce4 410 Go 16M
GeForce4 MX 440 with AGP8X
GeForce4 MX 440SE with AGP8X
GeForce4 MX 420 with AGP8X
GeForce4 MX 4000
Quadro4 580 XGL
Quadro NVS 280 SD
Quadro4 380 XGL
Quadro NVS 50 PCI
GeForce2 Integrated GPU
GeForce4 MX Integrated GPU
GeForce3
GeForce3 Ti 200
GeForce3 Ti 500
Quadro DCC
GeForce4 Ti 4600
GeForce4 Ti 4400
GeForce4 Ti 4200
Quadro4 900 XGL
Quadro4 750 XGL
Quadro4 700 XGL
GeForce4 Ti 4800
GeForce4 Ti 4200 with AGP8X
GeForce4 Ti 4800 SE
GeForce4 4200 Go
Quadro4 980 XGL
Quadro4 780 XGL
Quadro4 700 GoGL

O driver mais indicado é 1.0-9639 (x11-video-nvidia e nvidia-gfx-kmp-default na indicação do YaST).

Não que o primeiro não possa ser instalado se você possui o segundo grupo de placas (eu só iniciei o download e parei), mas para evitar falhas ou problemas e ocupar menos o HD pela diferença do tamanho do arquivo, instale o apropriado para sua placa.

OBS: Para placas mais "antigas" como:

RIVA TNT
RIVA TNT2/TNT2 Pro
RIVA TNT2 Ultra
Vanta/Vanta LT
RIVA TNT2 Model 64/Model 64 Pro
Aladdin TNT2
GeForce 256
GeForce DDR
Quadro
GeForce2 GTS/GeForce2 Pro
GeForce2 Ti
GeForce2 Ultra
Quadro2 Pro

O driver é o 1.0-7185 (x11-video-nvidia e nvidia-gfx-kmp-default na indicação do YaST).

Espero que seja útil a alguém. Se for interessante vote aí!

Outras dicas deste autor

Novo YaST - Para os amantes do SuSE Linux

SuSE rodando KDE em 256MB

Visualizar imagens noGwenwiew (separado do konqueror)

Kpackage - Instalando pacotes no Conectiva Linux 10

Opera em português-BR

Leitura recomendada

Blog e repositório de pacotes deb para amd64

Editor HTML BlueGriffon com dicionário Português do Brasil

Multimídia no Debian & Ubuntu

Lançamento Famelix 2.1 - Release Candidate 2

Instalando o KDE 3.4 no Debian Sarge/Testing

  

Comentários
[1] Comentário enviado por marck em 17/07/2007 - 22:53h

aeiou. abcdefghijklmnopqrstuvxwyz

[2] Comentário enviado por Blades em 28/08/2007 - 08:25h

Bom dia

(Desculpandome pelo meu portugues), voces talvez tenham uma ideia para resolver o problema seguinte:
Achando o vosso problema resolvido quisera perguntar o que e possivel
fazer com a configuracao seguinte:

O meu compi e um 32 bits em funcao com o opensuse 10.2
carta grafica RIVA TNT2 Model 64 Pro
O meu kernel e o 2.6.18.8-0.3-bigsmp

Em este caso parece que o driver requerido com a particularidade de ser um driver "old legacy" = para placas mais antigas , este driver si de verdade ele existe pareceme que teria o problema adicional devendo ele logicamente que ter um "kernel flavour" adecuado ao kernel...? (bigsmp)

Alguem sabe como resolver?
Que estilo de driver e necessario e onde o encontrar?




[3] Comentário enviado por marck em 29/08/2007 - 00:56h

olá, Blades da uma olhada no site da nvidia http://www.nvidia.com/object/linux_display_ia32_1.0-9639.html lá vc encontra o how to. Quanto ao kernell flavour, após configurar o yast com os repositorios nvidia, ele te mostrará as opções de drivers. sendo que o mais indicado para vc é a Version: 1.0-9639.
abraço

[4] Comentário enviado por removido em 06/09/2007 - 14:47h

Valeu Marcus!!

Funcionou na minha Geforce4 MX 4000

Vou colocar como eu fiz pois não sabia instalar.

no terminal:
# /etc/init.d/kdm stop

no modo texto executei:
# sh NVIDIA-Linux-x86-1.0-9639-pkg1.run

Segui as telas e após a instalação reiniciei o pc.

[5] Comentário enviado por tnalvo em 02/04/2008 - 21:07h

Olá estou com um grande problema...se alguem puder ajudar eu agradeço...bom eu instalei uma geforce 8400gs e meu pc começou a ter problemas no bot inicial e athe travar do nada...se for um problema de driver...qual seria o certo de eu instalar no windows xp professional??
Valew

[6] Comentário enviado por albfneto em 09/06/2008 - 11:54h

Olha, o post éantigo, dois meses, mas, a sua 8400 devia funcionar com o driver nvidia novo!
qualquer versão atual do site nvidia!
os problemas com nvidia, comuns, são em Linux, não em windows, em windows, todas as versões novas funcionam!
em Linux, as placas antigas, como a 5200, não funcionam bem com drivers nvidia novos, versão 100 ou mais, mas funcionam melhor com dowgrade para drivers mais antigos.
Mas em Windows? , em XP ou vista, poderia usar até o driver mais recente.
Se já não o fez, contacte o suporte tecnico do site da NVIDIA.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts