Erro do Lynx acessando Google: Bad Request

Publicado por Fábio Berbert de Paula em 17/09/2006

[ Hits: 13.783 ]

Blog: https://youtube.com/c/cotidianohackeado

 


Erro do Lynx acessando Google: Bad Request



Estou usando o Ubuntu Dapper e, para minha surpresa, ao tentar acessar o Google através lynx (browser modo texto), me deparei com a seguinte mensagem de erro:

Google Error
HTTP/1.0 400 Bad Request


A princípio achei que era o Google bloqueando o acesso do browser por achar que o tipo de requisição enviada era suspeito, conforme texto descrito na página de explicação do bad request, porém ao pesquisar um pouco mais sobre o assunto, descobri que trata-se de um bug no pacote lynx 2.8.5 para Ubuntu e Debian, vide URL abaixo:
Para solucionar o problema acessei o site do lynx e baixei sua última release. Desinstalei o lynx (apt-get remove lynx) e compilei e instalei o código-fonte obtido. Pronto, problema resolvido!

Vou levar em conta que você já conhece o processo básico de download e instalação de um programa a partir de seu código-fonte (./configure && make && make install). O foco dessa dica é a causa do problema com o Google.

Um abraço,
Fábio

Outras dicas deste autor

Listar processos por consumo de memória

Instalando suporte a flash no Mozilla

Arduino - Porta serial acessível a todos os usuários

Jogando Xadrez através da Internet com o Linux

Apagando linhas em branco no vim

Leitura recomendada

Lista de portas utilizadas pelos programas

Internet Giro Embratel no Linux

SqStat com Squid 3.3.6 monitorando usuários

Acesso a Internet via proxy em servidor GNU/Linux - Configuração via linha de comando

Firefox não abre após atualizar sua distribuição GNU/Linux

  

Comentários
[1] Comentário enviado por User-kuruma em 17/09/2006 - 13:22h

Ao compilar o lynx está dando o seguinte erro:
checking for screen type... curses
checking for extra include directories... no
checking if we have identified curses headers... none
configure: error: No curses header-files found

[2] Comentário enviado por removido em 18/09/2006 - 00:27h

User-kuruma, instale o ncurses-devel.
No Fedora é esse nome, veja o nome na tua distro caso o pacote não for encontrado.
Abs

[3] Comentário enviado por removido em 26/02/2009 - 15:14h

Vou te contar... nunca mais vou usar esse lynx. Agora só o w3m.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts