Erro: NT_STATUS_OBJECT_NAME_NOT_FOUND - Samba 4.3.9 no Ubuntu Server 16.04 [Resolvido]

Publicado por Raul Kelvin Inacio Ramos em 10/07/2016

[ Hits: 6.370 ]

 


Erro: NT_STATUS_OBJECT_NAME_NOT_FOUND - Samba 4.3.9 no Ubuntu Server 16.04 [Resolvido]



Olá, esta dica é destinada à administradores de redes que utilizam Samba 4.3.9 no Ubuntu como servidor PDC.

Utilizando o Ubuntu-server 16.04 LTS e o Samba 4.3.9-Ubuntu, notei que após as configurações necessárias para que ele fizesse o papel de Domain Controller eu obtive o erro:

NT_STATUS_OBJECT_NAME_NOT_FOUND
Realizei uma pesquisa na WEB, porém como sou responsável por outras atividades, só descobri a solução após algumas semanas, vou compartilhar aqui a solução.

Para resolvermos este problema devemos instalar algumas bibliotecas, mas só depois que o servidor estiver devidamente configurado, com IP FIXO, e o smb.conf OK. Digite os comandos abaixo no terminal e reinicie o seu servidor:

sudo apt-get install -y winbind libpam-winbind libnss-winbind

Após receber a confirmação que os três foram instalados corretamente digite:

sudo reboot now

Pronto, problema resolvido! Para testar instale o smbclient:

sudo apt-get install smbclient

Testando:

sudo smbclient -L localhost -U Administrator

Digite a senha e veja que o retorno, serão os compartilhamentos que estão no smb.conf.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalação e configuração do Grafana/Zabbix no Debian 9

Como mudar o nome da interface de rede padrão do Ubuntu

Navegue na web com privacidade, segurança e anonimato

Como copiar arquivos do Windows para o Linux

Bloqueio funcional do Tor Browser

  

Comentários
[1] Comentário enviado por pregnolato em 09/09/2016 - 14:14h

Este procedimento funciona parcialmente (sudo apt-get install -y winbind libpam-winbind libnss-winbind
), pois todos os mecanismos SSO de integração com demais sistemas da empresa, param de funcionar e o winbind não corrige isso.

Notamos também que ainda persiste a dificuldade de colocar máquinas no domínio.

Algum achou uma solução para isso sem ter que fazer o downgrade no samba?

[2] Comentário enviado por claytonnog em 15/04/2017 - 23:13h

Consegui resolver, obrigado.



Contribuir com comentário