Descobrindo se seu winmodem é compatível com o Linux

Publicado por Perfil removido em 26/07/2006

[ Hits: 9.176 ]

 


Descobrindo se seu winmodem é compatível com o Linux



Existe um modo bem prático de saber se seu modem é compatível com o Linux. Vamos usar um script chamado "scanModem.gz". Ele pode ser baixado em:
Baixado o mesmo, descompacte-o via terminal ou usando algum utilitário como "ark" (se estiver usando o KDE). No primeiro caso:

$ gunzip sacanModem.gz
(ou gzip -d scanModem.gz)

No segundo, basta clicar sobre ele e escolher onde salvar o conteúdo:


Este script vai checar seu hardware com o comando lspci e depois vai gerar os arquivos-texto denominados "ModemData.txt", "ModemData.txt.2" e "ModemDriverCompiling.txt".

Leia-os cuidadosamente para que obtenha as informações necessárias sobre o driver apropriado e o endereço onde obtê-lo.

O arquivo-texto ModemDriverCompiling.txt explicará como compilar o driver para seu modem, já que a forma de fazê-lo depende da como aquele foi escrito.

Mas, no geral, os tutoriais existentes aqui no VOL darão conta do recado. Quando eu usava winmodem (arghhhhhhhhh.....) nunca precisei fazer malabarismos para instalá-los.

Bem, deixando de lero-lero, mostro abaixo o texto que aparecerá se seu modem for compatível (fragmento):

===================================================
Providing detail for device at PCI_bus 00:0b.0gzip -d scanModem.gz
with vendor-ID:device-ID
----:----
Class 0780: 11c1:0440 Communication controller: Lucent Microelectronics 56k WinModem (rev 01)
SubSystem 11c1:0440 Lucent Microelectronics LT WinModem 56k Data+Fax+Voice+Dsvd
Flags: bus master, medium devsel, latency 0, IRQ 19
Memory at dfffff00 (32-bit, non-prefetchable) [size=256]
I/O ports at ec00 [size=8]
The modem has a supported Lucent/Agere DSP (digital signal processing) chipset
with primary PCI_ID: 11c1:0440
DSP=1
Please read ModemData.txt, ModemDriverCompiling.txt, ModemTesting.txt, ModemGeneral.txt
Only send ModemData.txt to [email protected] , if necessary
====================================================

A frase "The modem has a supported Lucent/Agere DSP (digital signal processing) chipset with primary PCI_ID: 11c1:0440 DSP=1" esclarece que o modem tem um chip compatível com o Linux.

Até a próxima dica...

Outras dicas deste autor

Placa de vídeo Intel i915 no BackTrack - Conflito resolvido

Configurando o Gnome-Openbox no Ubuntu 8.10 Linux

Terminal bash com arquivos coloridos

Carregando o "config" para recompilar o kernel

Como fazer uma introdução de vídeo no OpenShot - Vídeo aula

Leitura recomendada

Use e abuse do seu Gradiente Vibe

lshw - Obtendo informações de hardware

Instalando webcam no Debian Etch 4.0

HD SAMSUNG SATA2 = ATA3.0 ERROR: DRDY ERROR

Modem Huawei E192 no Slackware 64 - Current

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário