Conflito Java ao instalar LibreOffice no Arch Linux [Resolvido]

Publicado por Xerxes em 28/04/2014

[ Hits: 4.118 ]

 


Conflito Java ao instalar LibreOffice no Arch Linux [Resolvido]



Ao tentar instalar o LibreOffice no Arch Linux, com o comando:

sudo pacman -S libreoffice

E escolher instalar tudo (padrão), me deparei com o seguinte conflito:

 :: jre7-openjdk e jre estão em conflito (java-runtime). Remover jre? [s/N]
 erro: conflito de pacotes não solucionável detectado
 erro: falha ao preparar a transação (dependências conflitantes)
 :: jre7-openjdk e jre estão em conflito (java-runtime=7)


Eu não queria remover o jre, então, "googlei" e achei a resposta.

Na hora da instalação, ao invés de instalar tudo (padrão,) escolha todas as opções, excluindo 10 e 11.

 :: Existem 12 membros no grupo libreoffice:
 :: Repositório extra
    1) libreoffice-base  2) libreoffice-calc  3) libreoffice-common
    4) libreoffice-draw  5) libreoffice-gnome  6) libreoffice-impress
    7) libreoffice-kde4  8) libreoffice-math
    9) libreoffice-postgresql-connector  10) libreoffice-sdk
    11) libreoffice-sdk-doc  12) libreoffice-writer


Digite uma seleção (padrão=todos): 1 2 3 4 5 6 7 8 9 12


Isso resolve o problema.
Abraço.

Outras dicas deste autor

Aprenda como instalar o Watchtower Library no Sabayon Linux

VirtualBox no Slackware

Steam no Linux Mint - Erro: Couldn't set up Steam data - please contact technical support [Resolvido]

Erro na compilação do LLVM no Gentoo [Resolvido]

Autostart no GNOME

Leitura recomendada

Atualizando o Pubuntu para versão 9.04

Configurando mouses com 5 botões e rodinha no X

Compartilhando internet e pastas no Ubuntu 10.4

Removendo o som de discagem do wvdial

Bloqueando máquinas pelo endereço MAC da placa de rede

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts