Configurando um ambiente LAMP (acrônimo para Linux, Apache, MySQL e PHP) no Ubuntu 10.04

Publicado por Perfil removido em 01/07/2010

[ Hits: 15.615 ]

 


Configurando um ambiente LAMP (acrônimo para Linux, Apache, MySQL e PHP) no Ubuntu 10.04



LAMP é um acrônimo para Linux, Apache, MySQL e PHP (a letra P também faz referência às linguagens de programação Perl e Python).

A combinação dessas tecnologias se torna a solução perfeita para quem deseja montar um servidor WEB a baixo custo. Nesta dica mostrarei como realizar a sua instalação via interface gráfica ou linha de comando. Será necessário ter direitos administrativos sobre o sistema para realizar os passos abaixo.

Instalação via interface gráfica Gnome

1. Acesse o menu Sistema &#gt; Administração &#gt; Gerenciador de pacotes Synaptic.

2. Na janela que for aberta, digite a sua senha (a mesma que você utilizou para se logar no sistema).

3. Na janela do gerenciador de pacotes Synaptic, procure e marque para instalação os seguintes pacotes:
  • apache2
  • mysql-server-5.1
  • php5
  • php5-mysql
  • php5-gd

4. Clique no botão Aplicar para iniciar a instalação.

5. Durante a instalação será solicitada a senha do usuário root do MySQL, digite uma senha de sua preferência.
Linux: Configurando um ambiente LAMP (acrônimo para Linux, Apache, MySQL e PHP) no Ubuntu 10.04
6. Pronto! Instalação completa. Agora temos que configurar as permissões da pasta www do servidor Apache para o seu usuário criar e modificar arquivos.

7. Aperte a combinação de teclas Alt + F2.

8. Na janela que for aberta, digite "gksudo nautilus".

9. Será aberto o gerenciador de arquivos padrão do Gnome, o Nautilus.

10. No painel lateral esquerdo, dê um clique com o botão esquerdo do mouse na opção Sistema de arquivos.

11. No painel lateral direito, dê um duplo clique com o botão esquerdo do mouse na pasta var.

12. Com o botão direito do mouse, clique na pasta www e, no menu que for aberto, clique em Propriedades.

13. Na janela que for aberta, clique na aba Permissões.

14. Na caixa de seleção de Grupos, selecione o grupo do seu usuário.

15. Na caixa de seleção de Acesso à pasta, selecione a opção Criar e excluir arquivo.

16. Pronto! Agora você já tem as permissões necessárias para criar e excluir arquivos.

Instalação via terminal

1. Em um terminal de linha de comando, execute as seguintes linhas:

sudo su
# apt-get install apache2 mysql-server-5.1 php5 php5-mysql php5-gd


2. Durante a instalação será solicitada a senha do usuário root do MySQL, digite uma senha de sua preferência.
Linux: Configurando um ambiente LAMP (acrônimo para Linux, Apache, MySQL e PHP) no Ubuntu 10.04
3. Pronto! Instalação completa. Agora temos que configurar as permissões da pasta www do servidor Apache para o seu usuário criar e modificar arquivos.

4. Em um terminal de linha de comando, execute as seguintes linhas:

sudo su
# chown root.GrupoUsuário /var/www /var/www/index.html ; chmod 775 /var/www /var/www/index.html


5. Pronto! Agora você já tem as permissões necessárias para criar e excluir arquivos.

Outras dicas deste autor

Proxy paralelo MikroTik com ZPH

DVDisaster - Software de recuperação de mídias

Ganhando dinheiro com discador Orolix no Kurumin

Gtkterm, um saída para o Hyperterminal

O VOL no Twitter

Leitura recomendada

Entrando no mundo Open Source

Placa de rede Sundance

Configurando Samba e colocando algumas permissões para usuários

Instalando o R e Rstudio no Ubuntu

O que fazer depois de instalar o Slackware [vídeo]

  

Comentários
[1] Comentário enviado por le_videira em 12/09/2010 - 21:35h

Eu tentei instalar, mas deu erro de dependencia

E: mysql-server-5.1: sub-processo script post-installation instalado retornou estado de saída de erro 1
E: mysql-server: problemas de dependência - deixando desconfigurado


O que houve?

[2] Comentário enviado por le_videira em 12/09/2010 - 21:43h

Eu abri o terminal e dei o comando que você escreveu e


"Lendo informação de estado... Pronto
apache2 já é a versão mais nova.
mysql-server-5.1 já é a versão mais nova.
php5 já é a versão mais nova.
php5-mysql já é a versão mais nova.
php5-gd já é a versão mais nova.
php5-gd configurado para instalar manualmente.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
2 pacotes não totalmente instalados ou removidos.
E: Não foi possível obter trava /var/cache/apt/archives/lock - open (11: Recurso temporariamente indisponível)
E: Impossível criar trava no diretório de download"



[3] Comentário enviado por le_videira em 13/09/2010 - 13:03h

Oi,

Voltei para falar que agora deu certo.

Eu desinstalei tudo e instalei denovo. Mas o mysql não pediu senha desta vez.

Obrigado

Abraços



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts