Configurando sua webcam Creative NX PRO

Publicado por Murilo Diniz em 18/01/2005

[ Hits: 35.357 ]

 


Configurando sua webcam Creative NX PRO



E aí galera, finalmente consegui fazer minha webcam Creative NX PRO funcionar! Bom, isso é fácil, tem que fazer o seguinte.

Primeiro compilar o módulo spca5xx, que você encontra na página:
Baixei o spca5xx-20041224.tar.gz.

Agora vá na pasta que baixou e descompacte ele:

$ tar -xzvf spca5xx-20041224.tar.gz

Entre na pasta criada e digite:

$ make

e depois:

$ su
# make install


Pronto!

Agora é só carregar os módulos com o comando:

# modprobe usbcore
# modprobe spca50x


Para ver ela funcionando, vamos instalar o programa camstream:

# apt-get install camstream

OK. É só rodar o comando "caminfo" para ele detectar a webcam, depois desse comando rode o comando "camstream" para chamar o programa e beleza!

Vá em file e open viewer. Na caixa que abrir, olhe na aba device, é para estar escrito o nome da webcam que o programa reconheceu, selecione a resolução, que nesse caso pode ser vga 640x480 e OK!

Agora você deve estar vendo sua imagem hehehe....

Nessa janela, com a imagem vão ter também 6 ícones, o primeiro é para ajustar as configurações de vídeo, o segundo para configurar um snapshot, o terceiro para mostrar o último snapshot tirado, o quarto para tirar o snapshot, o quinto para tirar snapshots em intervalos regulares e o último para ligar ou desligar o som da webcam caso tenha microfone embutido, na NX PRO o microfone é separado.

OBS: Testei esse artigo com a webcam CREATIVE NX PRO, não sei se ele funciona com outras.

Para ver a lista de compatibilidade desse módulo vá em:
e ache a sua.

Valeu galera, até a próxima!

Outras dicas deste autor

Sites clássicos para download de software para Linux

Informações com o KnewsTicker

Nova versão do KDE

Leitura recomendada

Colocando sua Nvidia série 8 para funcionar no Ubuntu 7.04

Debian 5.0 Lenny no notebook W93 - Passando da tela preta do boot

Instalando Dell Wireless 1395 mini-Pci no Ubuntu 8.04 Hardy Heron com NdisWrapper

Iniciando o Linux em notebooks

Impressora HP D110 Photosmart

  

Comentários
[1] Comentário enviado por heavinu em 22/01/2005 - 16:42h

só tem uma coisa.. eu tentei instalar o driver no meu debian (kernel 2.2) e ele não foi :\
é impressão minha ou o kernel tem que ser 2.4 ou superior? porque se for assim.. eu atualizo aqui ;)

Abracetas :)

[2] Comentário enviado por dinizmu em 22/01/2005 - 17:30h

hehehe bom eu instalei aqui no meu debian sarge (testing) com kernel 2.6.8
intão provavelmente deve ser o kernel....
agora acho melhor vc atualizar logo para o 2.6 ao invés de 2.4
o que vc pode fazer é tentar ver na página do módulo se o problema é esse mesmo...
flw

[3] Comentário enviado por dinizmu em 11/02/2005 - 18:44h

ae eu descobri um outro software muito bom , é o camorama
apt-get install camorama
ou
http://camorama.fixedgear.org/download.php

flw

[4] Comentário enviado por junior_ms em 21/02/2005 - 17:33h

Para q serve módulo spca5xx, ele eh o driver da Webcam? É pq eu estou tentando instalar uma webcam de modelo diferente.
Obrigado

[5] Comentário enviado por dinizmu em 21/02/2005 - 18:51h

Sim junior_ms , esse é o módulo que dá o suporte a esta webcam , você pode ver as webcams suportadas por este módulo no site:

http://mxhaard.free.fr/spca5xx.html

e também já está disponível no site uma versão superior a essa dando suporte a mais webcams...

flw

[6] Comentário enviado por kdmais em 01/03/2005 - 23:23h

Eu tenho o kernel ls /lib/modules/ |more
2.6.8.1-3-386

Fiz o download spa5xx-2050206.tar.gz

Segui os comandos que aconselhas-te e o resultado foi:

# make
Building SPCA5XX driver for 2.5/2.6 kernel.
PLEASE IGNORE THE "Overriding SUBDIRS" WARNING
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/njsdias/spca5xx-20050206 modules
make: *** /lib/modules/2.6.8.1-3-386/build: Arquivo ou diretório não encontrado. Pare.
make: ** [default] Erro 2

Como eu ainda sou mt novato em Linux, será que m poderias ajudar?

Obrigado

[7] Comentário enviado por dinizmu em 02/03/2005 - 13:31h

bom kdmais vc precisa instalar o pacote kernel-headers da versão do seu kernel no caso a 2.6.8-3-386
flw

[8] Comentário enviado por kdmais em 02/03/2005 - 21:27h

dinizmu e como faço isso? penso k n existe esse pacote para o ekrnel 2.6.8.1-3-386.
Se realmente n existe, pelo k m disseram, como faço pra instalar um kernel mais recente e depois pra instalar o kernel-headers?
Depois desses passos feitos é só seguir as instruções k referencias na tua dica, n é?
É urgente pra mim ter essa cam a funcionar.

Brigado pela atenção e desculpa t chatear mais uma x.

[9] Comentário enviado por dinizmu em 02/03/2005 - 23:25h

e ai... bom seguinte aqui está o pacote em .deb :

http://higgs.djpig.de/ubuntu/www/warty/devel/linux-headers-2.6.8.1-3-386

para instalar:

dpkg -i nomedopacote.deb

agora se a sua distro nao usa pacotes deb intao da uma procurada em www.google.com.br/linux

flw

[10] Comentário enviado por kdmais em 02/03/2005 - 23:32h

thanks...minha distro usa pacotes deb.

Brigado mais uma x

[11] Comentário enviado por kdmais em 03/03/2005 - 01:13h


Oi de novo. Instalei ai o pacote.
# dpkg -i linux-headers-2.6.8.1-3_2.6.8.1-16.1_i386.deb
A seleccionar pacote previamente des-seleccionado linux-headers-2.6.8.1-3
(Lendo a base de dados ... 62208 ficheiros e directórios actualmente instalados.)
A descompactar linux-headers-2.6.8.1-3 (desde linux-headers-2.6.8.1-3_2.6.8.1-16.1_i386.deb) ...
Definindo linux-headers-2.6.8.1-3 (2.6.8.1-16.1) ...



De seguida fiz make na directoria spca5x.... e o problema continua na mesma

# make
Building SPCA5XX driver for 2.5/2.6 kernel.
PLEASE IGNORE THE "Overriding SUBDIRS" WARNING
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/njsdias/spca5xx-20041224 modules
make: *** /lib/modules/2.6.8.1-3-386/build: Arquivo ou diretório não encontrado. Pare.
make: ** [default] Erro 2

[12] Comentário enviado por kdmais em 03/03/2005 - 01:20h


ERRO NO MAKE do SPC5XX

# make
Building SPCA5XX driver for 2.5/2.6 kernel.
PLEASE IGNORE THE "Overriding SUBDIRS" WARNING
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/njsdias/spca5xx-20041224 modules
/usr/src/linux-headers-2.6.8.1-3-386/scripts/gcc-version.sh: line 1: gcc: command not found
/usr/src/linux-headers-2.6.8.1-3-386/scripts/gcc-version.sh: line 1: gcc: command not found
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.8.1-3-386'
CC [M] /home/njsdias/spca5xx-20041224/drivers/usb/spca50x.o
/bin/sh: line 1: gcc: command not found
make[2]: ** [/home/njsdias/spca5xx-20041224/drivers/usb/spca50x.o] Erro 127
make[1]: ** [_module_/home/njsdias/spca5xx-20041224] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.8.1-3-386'
make: ** [default] Erro 2

[13] Comentário enviado por dinizmu em 03/03/2005 - 12:52h

vc precisa instalar o pacote gcc:

apt-get install gcc

flw

[14] Comentário enviado por kdmais em 03/03/2005 - 13:03h

dinizmu já fiz isso ainda a pouco antes d ver a tua ajuda. Obrigado mais uma x pela atenção...
Agora deixa eu t xatear mais um poucos n t importas :)
Acabei de seguir os passos k tu aconselhaste pra instalar a webcam mas achei algo estranho nos 2 ultimos comandos (Atenção eu sou mt novo em Linux)...
Eu digito modprobe usbcore e simplesmente na contece nada... a linha d comando k a seguir aparece é só a path /home/meunome... n deveria aparecer mais kk coisa? sei lá kk indicio k esta a carregar o módulo?

Só mais uma coisinha: apt-get install camstream na distro ubuntu o resultado: n encontra o pacote... devo d fazer o download do source 1ª, acertei?

MT Brigado mais uma x...

[15] Comentário enviado por dinizmu em 03/03/2005 - 13:21h

hehehe isso ae..
olha nao acontece nada mesmo pq esse comando modprobe é pra ele carregar o modulo intao ele carrega e pronto!
agora eu acho melhor vc instalar o camorama ele tem mais recursos que o camstream...na verdade eu tenho instalado os 2 hehhee...
bom aqui estão os sites dos 2:

camorama:
http://linux.org.by/debian/pool/main/c/camorama/camorama_0.17-3_i386.deb

camstream:

http://linux.org.by/debian/pool/main/c/camstream/camstream_0.26.3-7_i386.deb

flw

[16] Comentário enviado por kdmais em 03/03/2005 - 22:19h

dinizmu já tenho a webcama funcionar. ainda n cheguei a instalar o camorama nem o camstream mas irei instalar nem k seja pra saber como é k funciona. já fiz uma tentativa d instalação mas n resultou... depois eu chateio-te mais um pouco :).
Só passei aki pra t agradecer mais uma x por td a ajuda e atenção.
Agora vou colocar um screnshot com a webcam a funcionar.
Baixei o qnext... Mas ainda n experimentei totalmente as potencialidades do programa pra webcam.
Obrigado mais uma x

[17] Comentário enviado por rsesma em 27/04/2005 - 02:13h

consegui instalar da forma como foi postado por você e a minha é a Mini Web Cam 300 GoTec da Leadership ( motivo : Muito Barata ),e ela foi reconhecida como FLEXCAM 100 CAMERA, e esta funcionando perfeitamente, valewwww, PARABÉNS.

[18] Comentário enviado por flavioc em 07/05/2005 - 23:16h


Dúvida de configuração de webcam

Tenho uma webcam creative nx (comum) que usava no Windows. Achei em um site um driver que dizem que é compatível para ela. Já baixei e instalei duas versões desse driver, o tal zc030x. Entretanto, quando instalo uma das versões a placa de captura de vídeo que tenho deixa de funcionar. O programa TV time vilwer da a mensagem que não é possível encontrar /dev/video0. A versão mais nova do driver a placa de captura funciona, mas a imagem é péssima (usando o programa camstream) e o mandrake 10.1 que uso trava daí há um minuto...Acabo por ter que dar um boot no computador. Alguém sabe como resolver o problema?

[19] Comentário enviado por mrmax em 08/05/2005 - 11:33h

Bem so um pequeno a parte para quem tem este erro:
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/njsdias/spca5xx-20041224 modules
/usr/src/linux-headers-2.6.8.1-3-386/scripts/gcc-version.sh: line 1: gcc: command not found
/usr/src/linux-headers-2.6.8.1-3-386/scripts/gcc-version.sh: line 1: gcc: command not found
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.8.1-3-386'
CC [M] /home/njsdias/spca5xx-20041224/drivers/usb/spca50x.o
/bin/sh: line 1: gcc: command not found
make[2]: ** [/home/njsdias/spca5xx-20041224/drivers/usb/spca50x.o] Erro 127
make[1]: ** [_module_/home/njsdias/spca5xx-20041224] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.8.1-3-386'
make: ** [default] Erro 2

Eu tambem tinha este erro, para resolver este erro e necessario a compilaçao do kernel. Depois de estar tudo a funcionar aconcelho a editarem /etc/rc.d/rc.modules e porem /sbim/modprobe spca5xx
isso e so para envitar ter k montar a webcam todos as vezes que reeniciarem a maquina.

[20] Comentário enviado por dinizmu em 08/05/2005 - 11:59h

Flaviooc tente instalar a webcam com o outro driver o spca, o site para ele está na dica...
Mrmax você precisa instalar o pacote GCC que é um compilador para poder compilar o programa..

flw

[21] Comentário enviado por mrmax em 09/05/2005 - 10:39h

dinizmu - aquilo era so um penqueno "aparte" para quem tem aquele erro como eu ja tive mas agora minha webcam esta a funcionar as 1000 maravilhas :)

[22] Comentário enviado por felipefoz em 09/11/2005 - 10:58h

instalei tudo certinho, dei o caminfo, ele reconheceu a camera, porém na hora que abro o camstream ou o gnomemetting, simplesmente congela o sistema! será que o driver esta errado, pq se estivesse, eu acho que não reconheceria no caminfo

[23] Comentário enviado por rafaelmm em 16/11/2005 - 13:37h

felipefoz estou com o mesmo problema que voce, Compilei o modulo carreguei, utilizo o caminfo ele retorna a minha webcam, ou seja, reconhece inclusive o modulo, como segue:

Device node : /dev/video1
Name of device : "Creative Live! "
Minimum size : 176x144
Current size : 0x0
Maximum size : 640x480
Video inputs : 1
Input 0
Name : "ZC301-2"
Type : Camera
Audio : no
Tuners : 0
Audio inputs : 0

Entretanto quando tento utilizar qualquer programa que chame a camera, por exemplo o camstream ou camorama, ele trava todo o sistema operacional, tenho que resetar na força bruta. Se encontrar algo a respeito por favor me avise.

Já li toda documentação do site do e não vi reportarem erro dessa forma.

[24] Comentário enviado por anagvi em 26/01/2006 - 20:50h

Olá Murilo eu preciso da sua ajuda eu ganhei uma webcam creative e nao consigo instalar esse programa eu já baixei só nao sei descompactar como fazo me ajuda aguardo resposta.

[25] Comentário enviado por bsantucci em 15/02/2006 - 11:46h

Baixei o Drive descompactei e quando escrevo make "command not faund" não acontece nada uso mandriva 2006 e Creative LIVE alguma sugestão?

[26] Comentário enviado por escovadordebit em 16/07/2006 - 20:30h

Eu tive 2 problemas de instalação não relatados neste tutorial:

4- Entre no diretório criado (spca5xx-20051105), e edite o Makefile que está lá dentro.
Procure esta linha:

MODULE_INSTALLDIR=/lib/modules/$(KERNEL_VERSION)/kernel/drivers/usb/media/

e acrescente o spca5xx/ ficando assim:

MODULE_INSTALLDIR=/lib/modules/$(KERNEL_VERSION)/kernel/drivers/usb/media/spca5xx/

E também tive um erro na carga do módulo:
FATAL: Error inserting spca5xx (/lib/modules/2.6.12-10-686/kernel/drivers/usb/media/spca5xx/spca5xx.ko): Invalid module format

Que foi resolvido com:
#modprobe -f spca5xx

Aqui vai o link de onde retirei esta dicas:
http://mmendes.jb0.org/blog/?p=6

[27] Comentário enviado por pergamo em 27/03/2009 - 21:57h

Por Favor podem me dizer como um novato em linux ativa webcam em um notebook intelbras i211 ele veiu com fenix linux fraquinho ai instalei ubuntu 8.10 não ta detectando a webcam no amsn :diz q nao ta instalada coisa assimm..
[email protected]:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:~$



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts