Configurando placa de rede para IP fixo no Debian

Publicado por Perfil removido em 03/11/2009

[ Hits: 155.952 ]

 


Configurando placa de rede para IP fixo no Debian



Vamos configurar a placa de rede no Debian para colocar IP fixo caso você use uma rede.

Primeiramente abra o terminal e entre como root (utilize o editor que preferir):

# nano /etc/network/interfaces
ou
# vim /etc/network/interfaces

Agora vamos configurar. Lembrando que eth0 é o dispositivo correspondente à minha placa:

auto eth0
   iface eth0 inet static
   address 192.168.1.20
   netmask 255.255.255.0
   gateway 192.168.1.1

Broadcast não é necessário, pois ele é configurado automaticamente.

Obs.: Está é a minha configuração, provavelmente você terá que adaptar para a sua rede.

Se você utiliza uma placa de rede para acesso externo, como eth0, basta modificar "eth0" para "eth1".

Agora vamos reiniciar a conexão de rede:

# /etc/init.d/networking restart

Pronto, configuração feita e é só aproveitar.

[]'s
Bino - www.binoinformatica.com

Outras dicas deste autor

Instalando pacotes RPM e resolvendo as dependências em modo texto

Configurando placa Realtek RTL8191SE-VA2 no Kismet (Ubuntu e similares)

Cube 2 - Sauerbraten

FreeBSD 7.0 CURRENT para STABLE de forma simples

Título: Instalando e configurando wireless no Vector Linux 6.0

Leitura recomendada

Umbrello, modelador UML em pt-BR

Vídeo aula: Trabalhando com o Quanta Plus

Zoom nas fontes de sites pelo Firefox

Conky - Misteriosos Retângulos

Fedora 22: Prefira o RVM

  

Comentários
[1] Comentário enviado por jgiusti em 05/03/2010 - 14:59h

Eu ainda tenho dúvidas... não manjo de linux...

minha configuração ta assim:

# This file describes the network interfaces available on your system
# andlow to activate then. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# the primary network interface
iface eth1 inet static

address 192.168.1.11
netmask 255.255.255.0
gateway 192.168.1.1


O que devo mudar?

[2] Comentário enviado por removido em 05/03/2010 - 16:05h

Está correto!

Não está conectando?

Abraços

[3] Comentário enviado por alex.feitosa em 17/01/2012 - 14:42h

Amigo quando vou fazer as configuraçães em /etc/resolv.conf
Dá uma mensagem de "acesso negado", sendo que estou logado com o usuario "root".
Pode me dizer o que devo fazer????

[4] Comentário enviado por bruno_proweb em 06/07/2012 - 15:47h

Amigo, vc precisa colocar o seguinte código:

# the primary network interface

auto eth1

iface eth1 inet static
address 192.168.1.11
netmask 255.255.255.0
gateway 192.168.1.1


Caso tenha resolvido avalie!

[5] Comentário enviado por marcelobenevento em 15/08/2013 - 23:27h

Perfeito funcionou bem aqui. valeu amigo

abraço

[6] Comentário enviado por xessika em 02/06/2014 - 11:20h

"Amigo quando vou fazer as configuraçães em /etc/resolv.conf
Dá uma mensagem de "acesso negado", sendo que estou logado com o usuario "root".
Pode me dizer o que devo fazer????"

Aqui tambem alex, o que posso fazer?

[7] Comentário enviado por piropo em 19/12/2014 - 11:10h


[6] Comentário enviado por xessika em 02/06/2014 - 11:20h:

"Amigo quando vou fazer as configuraçães em /etc/resolv.conf
Dá uma mensagem de "acesso negado", sendo que estou logado com o usuario "root".
Pode me dizer o que devo fazer????"

Aqui tambem alex, o que posso fazer?


Cara, falto o editor na frente... nano ou vim ......

[8] Comentário enviado por marcusveiga em 22/10/2015 - 16:11h

100 % funcionando !

Obrigado por compartilhar o conhecimento.

[9] Comentário enviado por nofearjr07 em 11/11/2017 - 21:56h

-Virtualizando Debian-
Galera no meu computador(fisico) minha rede está assim:
Vem um cabo direto do poste que a empresa provedora de internet puxou diretamente para a porta de rede do meu computador(sem passar por um roteador ou outro centralizador). minha conexão é DSL PPoe e é preciso eu por um id e senha para ter acesso.
no windows 8(no meu computador Físico) no ipconfig mostra o seguinte:

PPP PONTO NET:
ipv4 ..... 10.21.238.32
mascara ..... 255.255.255.255
gateway padrao.......... 0.0.0.0


adaptador ethernet Ethernet:
ipv4 ....192.168.137.1
sub-rede.... 255.255.255.0
gateway: (em branco, não consigo ver o gateway)


... na minha máquina virtual usando Virtual box (Debian)
coloquei em modo bridge porém não estou sabendo como vou configurar o

nano /etc/network/interfaces

alguem awe pode me ajudar ? qual quer coisa meu email é : luan.augusto.sa@gmail.com




Contribuir com comentário