Configurando apt-get com proxy

Publicado por Giovanni Won Dias B. Victorette em 01/05/2005

[ Hits: 215.489 ]

 


Configurando apt-get com proxy



Visitando fóruns, vi uma grande quantidade de perguntas referentes à configuração do apt-get com proxy. E para tentar ajudar aí vai uma dica para configuração que fiz no Kurumin.

Primeiro, estando com terminal aberto, vá em:

$ sudo vi /etc/environment

Adicione as seguintes linhas e salve (este caso é para servidores que não requerem autenticação):

http_proxy="http://10.2.1.2:3128"
ftp_proxy="http://10.2.1.2:3128"

Acquire {
HTTP::Proxy 10.2.1.2:3128;
FTP::Proxy 10.2.1.2:3128;
};

alias wget="wget -Y on"
# observe que a porta que usei 3128 é padrão do Squid,
# no caso verifique a porta HTTP, verifique também ftp
# e façam as alterações necessárias

Agora vá em:

$ sudo vi /etc/apt/apt.conf

E adicione as seguintes linhas:

Acquire{
HTTP::proxy "http://10.2.1.2:3128";
FTP::proxy "http://10.2.1.2:3128";
}
# observe novamente a configuração das portas

Adicione as seguintes linhas em /etc/profile:

export http_proxy ftp_proxy

Complementando, no caso do proxy que requer autenticação:

$ sudo vi /etc/environment

http_proxy="http://usuario:senha@10.2.1.2:3128"
ftp_proxy="http://usuario:senha@10.2.1.2:3128"

Acquire {
HTTP::Proxy usuario:senha@10.2.1.2:3128;
FTP::Proxy usuario:senha@10.2.1.2:3128;
};
alias wget="wget --proxy-user=usuario --proxy-passwd=senha"

Espero ajudar!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Internet Explorer no Ubuntu

Bloqueio definitivo do Facebook com IPtables

Synaptic com proxy

Conectando Debian em roteador VPN Cisco 3000 com IPsec

Proteja seus filhos de conteúdo adulto e impróprio

  

Comentários
[1] Comentário enviado por salexfer em 19/05/2005 - 21:52h

Muito boa dica, resolveu meu problema.

[2] Comentário enviado por gigiow em 20/05/2005 - 14:02h

Obrigado! a proposta é sempre ajudar!

[3] Comentário enviado por skoln1 em 08/11/2005 - 16:16h

Elton

Como faz pra Configurar Essa Jossaaaaaaaaaaaaaa de proxy no Linux.....
Sempre Da Chabu nessa Configuracao.....
Se Alguem Tiver Um Tutorial Decente manda belga2@ig.com .br

[4] Comentário enviado por Gilfran em 21/09/2006 - 14:11h

O fato de voce nao ter consiguido implementar nao quer dizer que o artigo nao seja "decente", com o salexfer funcionou e comigo tambem, acho que deverias se retratar com o companheiro que teve todo o trabalho de fazer o artigo de dicas, verifique os erros e tente corrigilos, no meu caso o apt nao aceita comentarios no arquivo apt.conf, bastou remover e funcionou muito bem, garanto que configurando corretamente ele vai funcionar.
Otima dica Giovanni, parabens...

[5] Comentário enviado por jose.rob.jr em 13/05/2007 - 16:35h

Valeu!! Muito boa a dica! Tava louco atraz disso! :D

Ignore o skoln1, tua dica tá 10!

[6] Comentário enviado por danfox10 em 14/08/2007 - 16:57h

Muito bem explicado, resolveu o problema...
Valew

[7] Comentário enviado por todeschini em 10/09/2007 - 14:01h

carlos-ti:/etc/apt# apt-get update
Obtendo:1 http://security.debian.org etch/updates Release.gpg [189B]
Atingido http://security.debian.org etch/updates Release
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Atingido http://security.debian.org etch/updates/main Packages
Atingido http://security.debian.org etch/updates/contrib Packages
Atingido http://security.debian.org etch/updates/main Sources
Atingido http://security.debian.org etch/updates/contrib Sources
Baixados 1B em 2s (0B/s)
E: Não foi possível obter trava /var/lib/dpkg/lock - open (11 Recurso temporariamente indisponível)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?


alguem sabe me dizer oq pode ser isso??

[8] Comentário enviado por gigiow em 10/09/2007 - 16:52h

Sim todeschini,

a sua mensagem significa que o processo de gerenciamento de pacotes está sendo utilizado e encontra-se temporariamente bloqueado:

Ex.: se tu tiver com o synaptic(gerenciador de pacotes debian) aberto, tu não vai conseguir executar um apt-get no terminal...pois já está em uso...ou então um outro terminal já rodando o apt-get. Ou seja, nenhum outro processo pode estar utilizando este recurso...isso ocorre para que inconsistencias e erros não ocorram no sistema de pacotes.

[]'s

Giovanni

[9] Comentário enviado por sanae_am em 16/01/2008 - 13:18h

serviu pra mim, no meu caso eu tenho o dansguardian tambem e mudei a porta para 8080, valeu!

[10] Comentário enviado por marianapc em 06/03/2008 - 02:56h

Ótima dica, serviu direitinho. Só tem uma coisa: eu tive que reiniciar pra funcionar e isso não está descrito na dica. Então o cara muda os arquivos de configuração e testa (sem reiniciar) e acha que não funciona. Obrigado e parabéns.

[11] Comentário enviado por gigiow em 09/03/2008 - 19:47h


marianapc

Obrigado pela contribuição!

[12] Comentário enviado por tbretzc em 11/08/2008 - 12:13h

olá amigo,

eu uso meu pc em um lugar que usa proxy e outro que não usa....
como eu faço?
tem como habilitar de desabilitar?
desde ja agradeço
abcs

[13] Comentário enviado por gigiow em 15/08/2008 - 13:43h

Uma alternativa é criar um script para habilitar e desabilitar. Veja bem a dica é para configurar o apt-get.

abraço

[14] Comentário enviado por ricardojrm em 26/08/2008 - 11:23h

na parte que tem "usuario:senha" devo colocar no nome do usuario o nome junto com o dominio, por exemplo
"dominio\usuario:senha"

[15] Comentário enviado por gigiow em 26/08/2008 - 16:30h

Opa, não precisa colocar o nome do dominio.

Falou!

[16] Comentário enviado por davidsonpaulo em 24/09/2008 - 14:28h

Maravilha. Vai para os meus favoritos. :-)

[17] Comentário enviado por airtinho31 em 25/11/2008 - 15:45h

Heii vcs poden me ajuda como fasso pra ativar u meu msn?

[18] Comentário enviado por claonilton em 23/01/2009 - 14:06h

Valeu pela dica... Aqui precisei usar ele autenticado e funcionou direitinho, só adicione além do Enviroment o arquivo apt.conf tb com o Usuário e Senha....

[19] Comentário enviado por wellingtoncunha em 04/02/2010 - 16:22h

Cara não funcionou. eu acho que deve ser por ele não tá exportando esse arquivo.

[20] Comentário enviado por haoliveira em 23/03/2010 - 13:43h

Para quem usa o Debian Lenny tem que criar dentro do diretorio /etc/apt/apt.conf.d/ um arquivo chamado 02proxy, dentro dele é só colocar
Acquire{
HTTP::proxy "http://10.2.1.2:3128";
FTP::proxy "http://10.2.1.2:3128";
}

[21] Comentário enviado por Staypuff em 10/05/2010 - 13:09h

Show de bola funcionou no Ubuntu corretamente mas tive que fazer o que haoliveira disse, estou usando o ntlmaps pois o proxy do serviço é ISA server mas agora ta Show... Valeu (Ubuntu 9.04 e agora 10.04)

[22] Comentário enviado por kaberdock em 18/08/2010 - 19:39h

muito bom, me ajudo muito aqui!!!

[23] Comentário enviado por andremir em 06/10/2011 - 11:39h

Excelente post! Problema 100% resolvido! Obrigado (Ubuntu 11.04)

[24] Comentário enviado por jucieudo em 12/07/2012 - 14:00h

Ola galera eu utilizo o debian squeeze, eu fiz e não deu certo, o diretório /etc/apt/apt.conf.d e criei um /etc/apt/apt.conf mais também não deu certo não.

[25] Comentário enviado por alnetosilva em 21/07/2012 - 21:19h

simples + objetivo = lindo!

VOL - Porque nós amamos a liberdade!

para o amigo de cima

sudo export http_proxy=http://ip:port
sudo export ftp_proxy=http://ip:port

[26] Comentário enviado por cleycesar em 27/06/2013 - 11:12h

Muito Obrigado muito boa essa configuração!

[27] Comentário enviado por ceil em 12/08/2014 - 22:55h

Foi de grande valia essa ajuda. Consegui no entanto baixar os pacotes que faltavam.

[28] Comentário enviado por Aslipe em 31/08/2014 - 13:36h

Olá!

Fiz como mandado acima mais quando fui digitar:
sudo apt-get update aparece isso:

felipe@lipeenanda-POSITIVO-MOBILE:~$ sudo apt-get update
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy Release.gpg
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy Release
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main TranslationIndex
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted TranslationIndex
Err cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main amd64 Packages
Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs
Err cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted amd64 Packages
Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs
Err cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main i386 Packages
Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs
Err cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted i386 Packages
Por favor, use o apt-cdrom para fazer com que este CD-ROM seja reconhecido pelo APT. O apt-get update não pode ser usado para adicionar novos CD-ROMs
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Translation-pt_BR
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Translation-pt
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Translation-en
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Translation-pt_BR
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Translation-pt
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Translation-en
38% [Conectando em 10.2.1.2 (10.2.1.2)] [Conectando em 10.2.1.2 (10.2.1.2)] [Conectando em 10.2.1.2 (10.2.1.2)] [Conectando em 10.2.1.2 (10.2.1.2)] [Conectando em 10.2.1.2 (10.2.1.2)]

Logo depois de muito tempo aparece:

Err http://ppa.launchpad.net precise/main Translation-pt
Não foi possível ligar a 10.2.1.2:3128:
Err http://ppa.launchpad.net precise/main Translation-en
Não foi possível ligar a 10.2.1.2:3128:
W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/intrepid/Release.gpg Não foi possível conectar em 10.2.1.2:3128 (10.2.1.2). - connect (110: Tempo esgotado para conexão)

W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/intrepid-updates/Release.gpg Não foi possível ligar a 10.2.1.2:3128:

Como resolvo isso (Não sei se ajuda ou atrapalha mais tentei instalar o skype e o playonlinux sem sucesso)(E uso o ubuntu 12.04 LTS)



[29] Comentário enviado por nikoloko em 07/07/2015 - 14:40h


Amigo e no caso da senha possuir o caracter @, no meu aqui esta apresentando erro!
Obrigado.

[30] Comentário enviado por gigiow em 07/07/2015 - 15:36h


[29] Comentário enviado por nikoloko em 07/07/2015 - 14:40h


Amigo e no caso da senha possuir o caracter @, no meu aqui esta apresentando erro!
Obrigado.


nikoloko, por acaso tentastes colocar um caractere de escape \ antes do @
Algo do tipo :
"http://usuario:senh\@1@10.2.1.2:3128"

[31] Comentário enviado por nikoloko em 07/07/2015 - 15:42h


[30] Comentário enviado por gigiow em 07/07/2015 - 15:36h


[29] Comentário enviado por nikoloko em 07/07/2015 - 14:40h


Amigo e no caso da senha possuir o caracter @, no meu aqui esta apresentando erro!
Obrigado.

nikoloko, por acaso tentastes colocar um caractere de escape \ antes do @
Algo do tipo :
"http://usuario:senh\@1@10.2.1.2:3128"


Consegui utilizando %40 no lugar do @ da senha! Funcionou 100%. Obrigado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts