Como usar o MonoGame SDK no seu Ubuntu 14.10

Publicado por eric koga em 30/12/2014

[ Hits: 3.932 ]

 


Como usar o MonoGame SDK no seu Ubuntu 14.10



Bom, primeiramente precisamos ter o Monodevelop 4.0 instalado no seu Ubuntu, para isso teremos que adicionar o repositório do monodevelop que encontrei no launchpad.net, é muito simples. Basta adicionar via linha de comando:

sudo add-apt-repository ppa:ermshiperete/monodevelop

Vamos atualizar:

sudo apt-get update

E agora instalar o monodevelop:

sudo apt-get install monodevelop

Pronto! O Monodevelop atual nós já temos, agora precisamos de instalar o MonoGame SDK para Linux e para isso encontrei a solução, que é instalar esse comando via apt-get (para usuários Ubuntu):

sudo apt-get install libmonogame-cil-dev monodevelop-monogame

Usuários Debian devem instalar com esse outro comando:

sudo aptitude install libmonogame-cil-dev monodevelop-monogame

Agora é só entrar no site www.monogame.net/downloads/ e baixar em development builds o "MonoGame for Monodevelop Linux", é um arquivo bem leve, apenas o MonoGame content, o cara que irá gerenciar em nosso projeto de criação de jogos a organização dos conteúdos de assets, imagens, sprites, sons e modelos 3D.

Para instalar o .mpack do site do monogame.net é só abrir o monodevelop e ir em:

Gerenciador de plugins > Adicionar > Install from file

e adicionar o arquivo .mpack.

O MonoDevelop irá instalar o gerenciador de conteúdos para fazer algo que se chama de content pipeline, que é organizar os assets do nosso jogo e deixar o projeto mais organizado.

Em breve trarei artigos sobre criação de jogos no Linux.

Até mais, espero que tenha ajudado.

Outras dicas deste autor

Atualização do kernel 3.18 no Ubuntu

Leitura recomendada

Como instalar o Age of Empires2 sem PlayOnLinux ou Lutris

Site brasileiro de jogos para Linux

Counter-Strike 1.6 no GNU/Linux via Wine

Jogo AlterEgo do Desura não funciona [Resolvido]

Minecraft no Fedora 18

  

Comentários
[1] Comentário enviado por Victoralm em 20/12/2015 - 02:19h

Estou tendo problemas no Ubuntu 15.10.
Os pacotes libmonogame-cil-dev e monodevelop-monogame não são encontrados, mesmo adicionando o ppa indicado no artigo e os dois indicados na página oficial do Mono...
Qualquer ajuda é muito bem vinda !! :)



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts