Como atualizar do Debian Etch (servidor ou desktop) para o Debian Lenny (tradução)

Publicado por Andre (pinduvoz) em 21/02/2009

[ Hits: 17.633 ]

Blog: http://casadopinduvoz.wordpress.com/

 


Como atualizar do Debian Etch (servidor ou desktop) para o Debian Lenny (tradução)



Tradução livre de:

How To Upgrade A Debian Etch System (Server & Desktop) To Debian Lenny
Version 1.0
Author: Falko Timme <ft [at] falkotimme [dot] com>
Last edited 02/17/2009

Original em: How To Upgrade A Debian Etch System (Server & Desktop) To Debian Lenny

Este texto mostra como atualizar o Etch para o Lenny, seja servidor ou desktop.

Não há garantia de que funcione para você!

1) Preliminarmente:

Você deve fazer um backup do Etch, caso algo dê errado.

2) Instalando as últimas atualizações do Etch:

Antes de atualizar para o Lenny é preciso instalar as últimas atualizações do Etch.

Verifique se o seu arquivo /etc/apt/sources.list usa "etch" e não "stable" (porque o Lenny é o novo "stable"):

# nano /etc/apt/sources.list

deb http://ftp2.de.debian.org/debian/ etch main
deb-src http://ftp2.de.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib

Agora instale as atualizações:

# aptitude update
# aptitude upgrade


3) Modique o arquivo "/etc/apt/sources.list" para que sejam usados os repositórios do Lenny (troque as ocorrências de "etch" por "lenny"), assim:

# nano /etc/apt/sources.list

deb http://ftp2.de.debian.org/debian/ lenny main
deb-src http://ftp2.de.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

E atualize o cache do aptitude:

# aptitude update

4) Fazendo a atualização:

Agora precisamos instalar as versões do "dpkg", "aptitude" e "apt" do Lenny, porque as versões do Etch são incapazes de lidar com a atualização.

# aptitude install dpkg aptitude apt

E fazer uma atualização mínima (a completa pode apresentar erros neste estágio).

# aptitude upgrade

Se estamos lidando com um desktop, precisamos checar se o pacote "libfam0c102" está instalado:

# dpkg -l libfam0c102 | grep ^ii

E se está, agora instalaremos a versão o Lenny:

# aptitude install libfam0

Depois disso, passamos à atualização completa:

# aptitude full-upgrade

(este comando é equivalente a "aptitude dist-upgrade")

Completada a tarefa, reinicie o sistema:

# reboot

e cheque a versão do kernel (a resposta deve mostrar um kernel 2.6.26):

uname -r
2.6.26-1-486

E o /etc/debian_version agora deve conter "5.0":

cat /etc/debian_version
5.0

Obs.: A idéia aqui e facilitar a vida daqueles que não entendem inglês, merecendo o autor original do texto o crédito pelo tutorial, minimamente modificado.

Outras dicas deste autor

Teclado sem LED Indicador? Use um via software

Adicionando um menu à barra de tarefas do Acer Aspire One

Emerald no Ubuntu 12.04

Ubuntu remasterizado pelo Hamacker

Corrigindo tema de ícones no Ubuntu 12.04

Leitura recomendada

Clone do RHEL 6.4 já disponível

Personalizar o painel do Gnome no Ubuntu Lucid Lynx - versão 2

Webmind - Personalize a página de resultados do Google

Resolvendo problemas com a pasta "Área de Trabalho"

Como deixar o KDE com um visual inovador

  

Comentários
[1] Comentário enviado por viniciusnito em 22/03/2009 - 10:08h

isso é praticamente o mesmo que um apt-get dist-upgrade ?

demora menos o download ? ou não ? :D

[2] Comentário enviado por pinduvoz em 23/03/2009 - 01:04h

É um "apt-get dist-upgrade", mas com alguns cuidados para não "quebrar" o SO.

Portanto, no quesito "tempo" não há ganho algum.

[3] Comentário enviado por viniciusnito em 24/03/2009 - 09:53h

Hum... bem, fui fazer isso mas no meio da operação de atualização, eu cancelei.

hoje fui refazer e agora é como o lenny ja estivesse instalado. dou um cat/etc/debian_version e ele me responde 5.0

kernel 2.6.26 tbm ...
+ sei q não é o lenny, e sim o etch.

e mesmo no gnome, as janelas, configurações arecem ser do kde.

tem como refazer isso ?
se não souber ta tranquilo também ;)
obg, abração aê.

[4] Comentário enviado por pinduvoz em 26/03/2009 - 06:20h

@ vinicius

Continue a atualização com um

# aptitude dist-upgrade

E o que faltou atualizar vai ser atualizado.

[5] Comentário enviado por jucaetico em 06/06/2009 - 15:21h

Cara, aqui funcionou belezinha!! Valeu
Abraços

[6] Comentário enviado por metall em 06/09/2009 - 19:06h

Boa Noite!

fiz os passo conforme manda o figurino mais me apresenta os seguintes erros

aptitude install dpkg aptitude apt


Atualiza os pacotes a seguir :
apt-utils [0.6.46.4-0.1+etch1 (now) -> 0.7.20.2+lenny1 (stable, stable)]
dpkg-dev [1.13.26 (now) -> 1.14.25 (stable)]
libbz2-1.0 [1.0.3-6 (now) -> 1.0.5-1 (stable)]

Pontuação é -373

Aceitar esta solução ? [Y/n/q/?] Respondo Y


A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg: erro processando /var/cache/apt/archives/libc6_2.7-18_i386.deb (--unpack):
subprocesso pre-installation script retornou código de saída de error 1
Erros foram encontrados durante processamento de:
/var/cache/apt/archives/libc6_2.7-18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar :
dpkg: problemas de dependência impedem configuração de libc6-dev:
libc6-dev depende de libc6 (= 2.7-18); porém:
Versão de libc6 no sistema é 2.3.6.ds1-13etch9+b1.
dpkg: erro processando libc6-dev (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem configuração de locales:
locales depende de glibc-2.7-1; porém:
Pacote glibc-2.7-1 não está instalado.
dpkg: erro processando locales (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem configuração de binutils:
binutils depende de libc6 (>= 2.7-1); porém:
Versão de libc6 no sistema é 2.3.6.ds1-13etch9+b1.
dpkg: erro processando binutils (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante processamento de:
libc6-dev
locales
binutils

o devo fazer?


[7] Comentário enviado por pinduvoz em 07/09/2009 - 18:24h

Segundo a mensagem do aptitude, vc precisa remover um pacote "avulso" (foi vc que instalou na mão?):

# aptitude remove libc6-i686

e tentar de novo:

# aptitude install dpkg aptitude apt

Lembrando que este tutorial de atualização tem por base o Lenny 5.0 e hoje o Lenny é 5.0.x (5.0.3, se não me engano).

Pode ser que as atualizações do Lenny desde o lançamento prejudiquem o procedimento aqui recomendado.


[8] Comentário enviado por metall em 14/09/2009 - 11:21h

entao pode ser....

Fiz o seguinte agora.. arrumei tudo os pau q tinha!! deixei tudo do Etch

Fico redondo... ai

Mudei o sources.list para: "Usando stable"

deb http://ftp2.de.debian.org/debian/ stable main
deb-src http://ftp2.de.debian.org/debian/ stable main

deb http://security.debian.org/ stable/updates main contrib
deb-src http://security.debian.org/ stable/updates main contrib

# apt-get update
# apt-get -f upgrade
Fez os Downloads 400 e pouco mega!
Beleza ate ai tudo normal
ai quando comeceu a Descompactar e instalar

Apacereu este a seguinte mensagem...

Pré-configurando pacotes ...
(Lendo banco de dados ... 45998 arquivos e diretórios atualmente instalados.)
Preparando para substituir libc6 2.3.6.ds1-13etch9+b1 (usando .../archives/libc6_2.7-18_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg: erro processando /var/cache/apt/archives/libc6_2.7-18_i386.deb (--unpack):
subprocesso pre-installation script retornou código de saída de error 1
Erros foram encontrados durante processamento de:
/var/cache/apt/archives/libc6_2.7-18_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
#

debian_version 4.0
uname -r 2.6.18-4-686

O que pode ser isso! Como solucionar este problema... se alguem souber!

[9] Comentário enviado por pinduvoz em 14/09/2009 - 22:12h

Tente atualizar o "libc6-i686" separadamente.

# aptitude upgrade libc6-i686

Ou remover, tirar ele do cache e depois instalar.

# aptitude remove libc6-i686
# rm /var/cache/apt/archives/libc6_2.7-18_i386.deb
# aptitude install libc6-i686

Depois rode:

# aptitude safe-upgrade

[10] Comentário enviado por antuerpiano em 19/12/2009 - 15:52h

Depois da atualização:
aptitude upgrade

houve o seguinte erro:
Starting Kerberos KDC: krb5kdckrb5kdc: cannot initialize realm SERVIDOR.COM.BR - see log file for details

Falhou bind9


Depois disso o servidor não conectou mais à internet.

[11] Comentário enviado por saitam em 12/05/2011 - 19:47h

Essa atualização também funciona da versão Debian Lenny(5) para Squeeze(6)
Claro fazendo as modificações necessárias...
Atualizar o Lenny
# aptitude update
# aptitude upgrade

Modificar a versão do Lenny para Squeeze
#vim /etc/apt/sources.list

deb http://ftp2.de.debian.org/debian/ squeeze main
deb-src http://ftp2.de.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main contrib
deb-src http://security.debian.org/ squeeze/updates main contrib

Atualizar
# aptitude update

Instalar dpkg,aptitude,apt referente a versão squeeze
# aptitude install dpkg aptitude apt

# dpkg -l libfam0c102 | grep ^ii

# aptitude install libfam0

Atualização mínima
# aptitude upgrade

Atualização completa
# aptitude full-upgrade

# reboot

Teste na máquina virtual!

[12] Comentário enviado por carmona.leo em 01/09/2011 - 11:25h

Bom dia pessoal sei que estou anos atrasdo mas...

Todos os procediimentos ficaram 90% OK pra mim.
O melhor mesmo foi do metal:
[8] Comentário enviado por metall em 14/09/2009 - 11:21h:
entao pode ser....
Fiz o seguinte agora.. arrumei tudo os pau q tinha!! deixei tudo do Etch
Fico redondo... ai

Mas o Kernel não muda. E devido a problemas com driver da placa de rede preciso atauliza-lo.
observem:

nsgti1:/etc/apt# uname -r
2.6.24-etchnhalf.1-486
nsgti1:/etc/apt# cat /etc/debian_version
6.0.2
O que vcs sugerem.
Muito obrigado



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts