Captive - Suporte a NTFS para leitura e escrita

Publicado por Elvio Lampugnani em 13/02/2004

[ Hits: 16.164 ]

 


Captive - Suporte a NTFS para leitura e escrita



Para quem utiliza a distribuição RedHat 9 e não tem suporte nativo a partições NTFS (Win NT/200x/XP), está disponível um pacote que permite acessar tais partições nos modos "leitura" e "gravação" sem precisar recompilar o kernel.
Vale conferir!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Montando arquivos NTFS editando o /etc/fstab

[rsync] Sincronizando becapes e outros dados

Recuperando arquivos skiplist corrompidos

CD de boot para o Fedora Core 2

Espelhamento remoto com ChironFS

  

Comentários
[1] Comentário enviado por mlilians em 17/02/2004 - 17:10h

Elvio,

Você conseguiu o Captive funcionar? Eu tentei e ainda não conseguí, instalei o pacote seguí as instruções, entretanto mostra a seguinte mensagem:
Try running /usr/share/lufs/prepmod to see more. at /usr/bin/captive-lufsd line 180.

Você pode me ajudar?

[2] Comentário enviado por elvio.tche em 18/02/2004 - 23:54h

Ok!
Instalei e rodei o 'captive' sem problema algum!
O mesmo erro ocorreu qdo tentei montar no próprio ponto de montagem q o linux gerou na instalação, ou seja, /mnt/win.
Porém, quando o captive é instalado ele cria diretórios (pontos de montagem) conforme as partições que vc tem no HD. No meu caso, os pontos de montagem ficaram assim:
/mnt/captive-seagate_p1 para hda1 (ntfs)
e
/mnt/captive-seagate_p2 para hda5 (ntfs)
a parte 'seagate_p1' e 'seagate_p1' são as referencias aos nomes dos volumes no Windows XP (Home).

*IMPORTANTE*
Utilizei os seguintes comandos para montagem:
mount -t captive-ntfs /dev/hda1 /mnt/captive-seagate_p1
para a partição primária com o OS Windows XP Home Edition e
mount -t captive-ntfs /dev/hda5 /mnt/captive-seagate_p2
para a partição extendida com meu conteúdo de backup.

para desmontar as mesmas:
umount /mnt/captive-seagate_p1
e
umount /mnt/captive-seagate_p2

... e, fim da história!

Espero ter te ajudado!
Dúvidas, escreva.
Um abraço,
Elvio.

Minha distro:
RedHat 9 (Shrike) Kernel 2.4.20-8 i686

[3] Comentário enviado por mlilians em 26/02/2004 - 10:23h


Desisntalei o captive e reinstalei; foi criado pelo captive como ponto de montagem o diretório: captive-disco_local.
Utilizei o seguinte comando: mount -t captive-ntfs /dev/hda1 /mnt/captive-disco_local, entretanto deu a mesma mensagem de erro.

Considerações:

Segundo as orientações para instalação do Captive, é necessário a existência de dois drivers (ntoskrnl.exe e ntfs.sys) dentro de /var/lib/captive, mas só é instalado pelo pacote do captive o driver ext2fsd.sys.

No meu entendimento deveria ser instalado pelo Captive os dois drivers necessários, me corrija se eu estiver esrrada. Por isso que ocorre erro na montagem, até copiei estes dois drivers dentro do diretório captive mas não adiantou, acho que o captive é que tem que realizar a operação para os mesmos serem reconhecidos pelo sistema.

Você pode me ajudar na solução?

Um abraço.

Lilian.

[4] Comentário enviado por elvio.tche em 27/02/2004 - 10:34h

postei uma resposta pra ti. Meio extensa, copie e cole em algum processador de texto. Altere o formato de letra de todo o texto para fonte "Courier New" tamanho 8 ou 9, pois a mesma tem tamanho fixo e distribui melhor as capturas de tela do console.
é issu....
[]'s
Elvio.

[5] Comentário enviado por staypuff em 01/04/2004 - 23:38h

Fala Galera,

Bem o que escreveu o elvio esta correto mais a principal dica é:
mont a partição NTFS na raiz /
e com o seguintes comandos:
mount -t captive-ntfs /dev/hda1 /mnt/captive-<complemento que o captive cria na pasta /mnt/captive-???????>
asssim é certo que funciona
um Abraço
Staypuff

[6] Comentário enviado por eduardok em 07/06/2004 - 15:45h

Pessoal estou com o mesmo problema, já li vários artigos e todo mundo fala que e só instalar o pacote e depois montar, mas o meu erro e o mesmo do mlilians, acho que esta faltando o pacote lufs que deve agir junto com captive, qualquer coisa repassem.

valeu...

[7] Comentário enviado por davisvictor em 15/09/2004 - 12:40h

Antes de tentar rodar o programa executa o captive-install-acquire que ferificara na na sua partição do windows os arquivos referentes ao ntfs.sys e os demais! depois eh soh montar o diretorio! e montar o captive.

PS-verificar se a partição com windows jah não esta montada na inicialização, se tiver desmonte e inicialize o captive.

[]`s

[8] Comentário enviado por cytron em 20/10/2004 - 10:03h

Eu instalei o captive e montei a unidade numa boa... o problema é que simplesmente não tem acesso write. Uso o Conectiva 10, e ele próprio monta NTFS, mas não tem acesso para escrita. Com o captive está a mesma coisa. A única diferênça é que o sistema de arquivo montado ficou captive. Alguém sabe pq não tem acesso w?

[9] Comentário enviado por ddeia em 15/12/2004 - 00:44h

Bom quando eu instalei o conectiva 10, ele leu e escreveu na boa.
No Fedora C2 eu instalei o Captive e deu certo pra escrever na particao W2K mas tive que colocar o -w pra dizer que era pra escrever.
Agora minha particao XP, ele nem montou. Mas parece que é pq tem que instalar um tal de Captive-Acquire no proprio XP.
Tem ate no site onde baixa o Captive falando sobre isso. Como so leitura me servia nao tentei fazer pra escrever.

[10] Comentário enviado por SuporteTecnicoID em 25/01/2005 - 14:03h

Segue abaixo :

http://www.jankratochvil.net/project/captive/

Script de instalação ( debian ): http://indexdata.com.br/Kurumin/Pacotes/instalar-captive

Imagem do instalador deste script para o Captive-Acquire o qual procura automaticamente na propria paratição um pequeno comando do windowsXP para poder gerar os recursos de RW.
http://indexdata.com.br/Kurumin/Imagens/Captive.png

[11] Comentário enviado por Maximus77 em 22/03/2007 - 22:44h

Boa noite, amigo, como vai, beleza?
É o seguinte, estou com uma dúvida e uma pendencia para resolver! Eu instalei o fedora core 5, estou curtindo demais essa distro.
Eu possuo dois hds SCSI, um de 18.2, que está o sistema operacional FC5 e outro de 36.4 GB, secundário, que estão meus dados e estão em NTFS, pois eu usava ruindows XP. Eu não estou conseguindo montar ele e ele não aparece m modo gráfico, como aparecia nates! Eu tentava montar ele e dava erro, mas agora, ele nem aparece mais, só aparece o de 18.2, como boot.
Como faço para o FC5 enxergar ele, ou seja, montar ele? Depois disto, preciso ter a cesso a ele, ou seja, pleo menos ler. A questão de escrever nele, nós resolvemos depois desta duvida esclarecida.
Obrigado e aguardo o retorno.
Marcelo



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts